Topic Title: R9 280x 2d Flickering
Topic Summary: Asus R9 280x flickers randomly when downclocked
Created On: 10/28/2013 11:04 AM
Status: Post and Reply
Linear : Threading : Single : Branch
1 2 3 4 5 6 7 Next Last unread
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 10/28/2013 11:04 AM
User is offline View Users Profile Print this message

Author Icon
vstream
Peon

Posts: 2
Joined: 10/28/2013

  • Asus R9 280x DC2T
  • Windows 8.1
  • 13.11 beta6
  • Benq xl2410 120hz
  • Corsair TX650

I am getting a random flicker when in 2d mode while watching videos or browsing firefox.  It is not a consistent flicker and happens randomly.  The card works perfectly while gaming (no issues at all in Bf3).

The link below has an example of what I see, though it doesnt happen on desktop, only when doing light tasks such as watching videos.  It also doesn't happen that frequently, maybe once a minute at most.

http://www.overclock.net/t/1212246/how-to-stop-a-7970-idling-down-and-going-to-2d-mode/20

From lots of Googling, I have found that changing my 2d memory clocks to not underclock might fix this, but I would rather not have to do this as it seems like more of a workaround than a fix.  It also seems to be a issue in the 7000 line and 120hz monitors.  My last video card (560ti) had zero issues with flickering while downclocking and 120hz.

So far I have tried the 13.101whql and 13.11 beta6 drivers.  I have also tried messing with alternate DVI operational mode and video settings in CCC.  I may try a clean install of Windows 7, but I'm not sure I can pass up playing BF4 tonight to mess with reinstalling things.

Any advice on this issue would be appreciated.

 

 

 10/28/2013 01:24 PM
User is offline View Users Profile Print this message

Author Icon
Tunerko90
Peon

Posts: 10
Joined: 10/27/2013

Same problem but I don't have 120Hz. Flickering, shadow blinking, glitches... I think it is a driver problem. While playing games...



Edited: 10/29/2013 at 01:05 AM by Tunerko90
 10/28/2013 06:26 PM
User is offline View Users Profile Print this message

Author Icon
Biebo
Peon

Posts: 2
Joined: 10/28/2013

Same problem with my gigabyte 280x. It only happens in 2d mode, when the memory clocks change. I have to force my minimum memory clocks to 550mhz via overdrive profile editing for this to go away. Everything works perfect when i'm playing 3d games, because the memory clocks stay constant there. I hope you guys at amd will look into this.

I have a 60hz monitor btw.

 10/30/2013 06:49 PM
User is offline View Users Profile Print this message

Author Icon
655321
Peon

Posts: 1
Joined: 10/30/2013

Same problem here. Flickering in 2D mode, especially in Firefox.

Sapphire R9 280X Dual-X with Catalyst 13.11 Beta 7

Windows 7 x64

Dell U2311H



Edited: 11/01/2013 at 06:46 AM by 655321
 10/31/2013 03:53 AM
User is offline View Users Profile Print this message

Author Icon
Valrak
Peon

Posts: 1
Joined: 10/31/2013

Having the exact same issue. However it does not happen very often on the desktop. There is one exception to games where this happens. It's League of Legends. My thoughts are the game isn't very graphically intense. Otherwise every other 3D game I play has no issues.

  • Windows 7 x64
  • Asus R9 280x DC2T
  • 13.9 WHQL, 13.11 Beta1 ( Happened on BOTH drivers)
  • Asus VW266H, 1920x1200 60hz
 10/31/2013 07:11 AM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7216
Joined: 11/13/2009

Disable hardware acceleration. Use software rendering...in IE  tools > internet options > advanced. Firefox and all other browsers have this setting as well. Funny how this would be considered a AMD issue.



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 * A clear conscience is usually a sign of bad memory *

 10/31/2013 07:18 AM
User is offline View Users Profile Print this message

Author Icon
Thanny
Alpha Geek

Posts: 1343
Joined: 07/13/2009

Playing video with a player that uses the GPU to accelerate decoding changes the memory clock speed, which is what causes the screen jump.

There are two options to prevent it, if it really bugs you:

1)  Disable GPU video acceleration in the video player.  For Flash in a web browser, right-click, choose options, and uncheck acceleration.  For a desktop video player, choose a renderer that doesn't involve GPU processing (options will vary from program to program).

2)  Set an overclock with MSI Afterburner on the memory, which will prevent it from being changed.

 

 11/03/2013 01:32 AM
User is offline View Users Profile Print this message

Author Icon
vstream
Peon

Posts: 2
Joined: 10/28/2013

Disabling Hardware Acceleration does not work.  I have tried this in Firefox and in Silverlight (Netflix).  Watching the clocks, they still bounce up and down regardless of these settings.

As for overclocking, as I said I would rather not have to do this because it is a workaround rather than a fix.  My last card (Nvidia) had zero issues with downclocking and it also had clocks that bounced around during video playback; so yes, I believe this is an AMD issue.

 11/04/2013 05:24 PM
User is offline View Users Profile Print this message

Author Icon
JavierL
Peon

Posts: 1
Joined: 11/04/2013

Hi, im have the SAME problem, different vga (Gigabyte r9 280x windforce), im having the problem that my pc don't recognize the vga like r9 200, only recognizing like VGA Standar, when i turn off my pc and then turn on, that's when my pc recognizes like r9 200 but after a some time, my screen start to flicker, i try alot of things, but i dont get any solution, i try to change the pci-e port, change modular wire of my PSU and nothing.

My pc settings is:
Intel i5 3570k + corsair h80, OC 4.3ghz (i leave default and the problem persist)
Motherboard asrock z77 extreme4-m (last bios, i clear CMos, no solution)
2x4gb ddr3 1600mhz
PSU SeaSonic Platinum 1000w (the PSU has 2 modes, hybrid and normal, i try the two and nothing)
1 HDD.

http://imageshack.us/photo/my-images/708/vwvm.gif/
http://imageshack.us/photo/my-images/580/3g1j.gif/

I try different versions of driver and nothing, different versions windows7-8-8.1 and nothing =(

Sorry for my bad english.

 11/04/2013 06:08 PM
User is offline View Users Profile Print this message

Author Icon
Vegan
Elite

Posts: 1183
Joined: 01/31/2010

I would like everyone to know this is not unique to AMD, many with the other brand are also experiencing issues with FF

I ue Chrome and it has not been a problem that I have noticed

Chrome uses the GPU for rendering not that it is a demanding load

 



-------------------------

 11/05/2013 05:06 AM
User is offline View Users Profile Print this message

Author Icon
Medussa
Peon

Posts: 18
Joined: 11/05/2013

Hi, I have the same problem like many of you ppl. My card is R9 270X and card of mine sister is R9 280 and same problems we share. Flicker on 2D must be corected and plz do not talk about this that is not AMD issue, cos it actually is. I checked HD 7770, HD 7790, HD 7850, GTX 660, GTX 760 on our computers and there is no flicker problem, so issue is related with AMD and new R9 serie.

 I dont know is it related or not but couple of my friend who bought R9 serie from other brand than Asus, like sapphire ,gygabyte have same problem with flicker.



-------------------------

i5 3570k,  Asus p8Z77-M pro,  Kingston 2x 4gb 1333,  Intel SSD,  PSU Seasonic 600w,  Asus R9 270X Top,  Dell U2212HM 1080p,  Win 8.1,  OSX 10.9

 11/05/2013 02:43 PM
User is offline View Users Profile Print this message

Author Icon
laberbla
Peon

Posts: 3
Joined: 11/05/2013

Hi there,

I just wanted to let you know that I am experiencing the exact same problem since I swapped my old 2x HD6950 with 2x R9 280X. The screen flickers randomly and mainly on the Desktop. I did not recognize any flickering while playing. 

Funny fact: I have a dual-screen setup and while playing FIFA14 on the one screen, the random flickering happens on the other one -.-

I'm glad to see that i am not the only one, having this problems with my brand new cards. 

My setup:

  • Mainboard: ASUS Crosshair V Formula-Z
  • CPU: AMD FX-8350 @4GHz
  • PSU: BeQuiet! PowerZone 1000W
  • RAM: 16 GB RAM 
  • GPU: 2x Sapphire Dual-X R9 280X
  • Screens: 2x Iiyama ProLite B2480HS via DVI, 1x Philips 47PFL7704D via HDMI (all screens show the same flickering-bug)
  • OS: Windows 8.1 x64
I could reproduce the problem with the following drivers:
  • 13.11 Beta6
  • 13.11 Beta7
  • 13.11 Beta8
Any help would be greatly appreciated  
 

Thanks in advance, 

Manuel

 11/05/2013 03:08 PM
User is offline View Users Profile Print this message

Author Icon
Thanny
Alpha Geek

Posts: 1343
Joined: 07/13/2009

Yes, it's a bug in the driver. 

How does that justify spurning a workaround?  Would you really rather pout until it's fixed in a new driver, instead of doing a 1MHz memory overclock right now?

 

 11/05/2013 05:47 PM
User is offline View Users Profile Print this message

Author Icon
laberbla
Peon

Posts: 3
Joined: 11/05/2013

Thanny: Overclocking has never been an option for me, having things on the Desktop fixed. I sometimes overclock for a better gaming experience, yes, but not any MHz for the Desktop... until now

As I'm always curious, I've overclocked my cards and tried to give them - that's what you told me - 1MHz memory clock more and guess what: It doesn't work

I'm not using MSI Afterburner: AMD OverDrive should do the job as well. Shouldn't it?

But it doesn't, because the Desktop is not really known for being a real 3D Monster - the settings have no effect as long as no overclocking is needed at all.

Well: I launched "FIFA14" and tweaked the clocks - no effect... maybe FIFA14 isn't the "real thing" in graphics?! EA would have said: "Well, Your rig is not fast enough for the new ignition engine, but hey - maybe next year".
I launched "Metro: Last Light" - i really love this one - and tweaked the clocks: no effect on that noisy flickering - the Desktop kept flickering randomly on the second screen. Changing the clocks apparently has no real effect on the random flickering. 

.oO( maybe I should've left the fridge open while trying ... )

So: Any driver-update would be greatly appreciated

 11/05/2013 06:22 PM
User is offline View Users Profile Print this message

Author Icon
Thanny
Alpha Geek

Posts: 1343
Joined: 07/13/2009

The screen jump I'm talking about is caused by the memory clock (not the core clock) changing.  If you're not getting that problem, then fixing the memory clock with an overclock won't help.

Have you kept a monitor open and actually correlated a memory clock change with the flicker?  Do you have a video of what you're seeing?

 

 11/06/2013 07:46 AM
User is offline View Users Profile Print this message

Author Icon
labudesnica
Peon

Posts: 1
Joined: 11/06/2013

Flickering in desktop Sapphire R9 280x Dual-X Catalyst 13.11 in all beta include beta 8

Code:
Flickering in desktop Sapphire R9 280X Dual-X with Catalyst 13.11 Beta 8
 11/06/2013 11:01 AM
User is offline View Users Profile Print this message

Author Icon
Biebo
Peon

Posts: 2
Joined: 10/28/2013

A vga bios update fixed my"screen jumping"

gigabyte 280x

 11/06/2013 02:32 PM
User is offline View Users Profile Print this message

Author Icon
laberbla
Peon

Posts: 3
Joined: 11/05/2013

Thanny: Well it's hard to record because sometimes it takes ages to happen - I'm not sure, if a screen-recorder would capture the glitches so I'm going to film it using my Camera - I think I can catch it that way.

I'll give it a try and put it on YouTube  

Link follows in a few hours / tomorrow

 11/07/2013 10:05 PM
User is offline View Users Profile Print this message

Author Icon
gazn1
Peon

Posts: 6
Joined: 11/07/2013

finally found people who have my problem been trying to figure this out all day but new it was todo with the 13.11 driver update cause got my sapphire R9 280x duel-x today installed it worked perfectly upon till i updated from 13.10 to 13.11 and bamm all went down hill from there this annoying flickering started or lets say the screen jumps in 2d mode like google chrome or even just the desktop so i've unistalled it and gone back to 13.10 so untill they fix this i aint updating 

 11/08/2013 04:05 PM
User is offline View Users Profile Print this message

Author Icon
Medussa
Peon

Posts: 18
Joined: 11/05/2013

I cant believe that no answer from AMD. If you browse net you can find that Sapphire and MSI admit error and they relese new VBIOS, flicker free BIOS for R9 270X cards. What ASUS w8ing for?



-------------------------

i5 3570k,  Asus p8Z77-M pro,  Kingston 2x 4gb 1333,  Intel SSD,  PSU Seasonic 600w,  Asus R9 270X Top,  Dell U2212HM 1080p,  Win 8.1,  OSX 10.9

AMD Support and Game » AMD Radeon™ Graphics » R9 280x 2d Flickering

1 2 3 4 5 6 7 Next Last unread
Topic Tools Topic Tools
Statistics
84854 users are registered to the AMD Support and Game forum.
There are currently 11 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.