Topic Title: Windows 8.1 black Screen Radeon HD 7970
Topic Summary:
Created On: 10/30/2013 09:49 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 10/30/2013 09:49 AM
User is offline View Users Profile Print this message

Author Icon
BeeGeePee
Peon

Posts: 4
Joined: 10/30/2013

Hello,

My computer uses a Sapphire Radeon HD 7970 3GB GDDR5 OC with BOOST: 

http://www.sapphiretech.com/presentation/product/product_index.aspx?pid=1481&lid=1

Here are the components of my PC:

I tried to update windows 8 to windows 8.1.  During the installation process I noticed a few times it said there were errors in the process, but it eventually seemingly successfully installed it.  
However, when windows 8.1 booted up, I noticed the graphics were messed up (i.e. wrong resolution etc.)  So, I installed the newest *Beta graphics drivers 13.11 for my graphics card which can be found here:
http://support.amd.com/en-us/download/desktop?os=Windows%208.1%20-%2064

(I chose that one because I noticed there was no 8.1 drivers released by Sapphire for this GPU.) 
During this installation, the computer completely crashed.  It then tried to restart several times, and windows tried to automatically fix the problem.  I tried to do that automatic start-up repair (said it would check disk which could take up to an hour) but that didn't do anything.  
I then did a restore to a point prior to updating to 8.1 or installing the new graphics drivers.  (time was 3AM 10/29/2013).  It STILL did not load up properly even though it said it successfully restored my computer to a time when it was working perfectly fine.
I rebooted my computer and spammed F2 and F8 (wasn't sure which allowed me to view my boot options).  I reset my motherboard to the default UEFI settings (I had done some OC tweaking which was very stable prior to any of this).  
However, none of this fixed my issue.  When I restart my computer it shows the little blue windows logo (4 blue squares) with a little loading thing under it.  After a few seconds the screen goes completely blank.  So, I don't know if windows is just not loading or if it is loading but my graphics card isn't working.
I can get my computer to load windows 8.1 in safe mode right now.  But now when I try and install drivers it says "Failure to load detection driver".  I have tried to install several different drivers.  Some of your old Sapphire drivers for this card as well as some of the older drivers for the card released by Radeon.  It appears there is something wrong with Catalyst Control Center.  I cannot repair CCC while I am in safe mode, but I cannot access windows in a regular boot. 

I was wondering if you have any suggestions on how I might fix this.  Is it possible i could load windows properly if I just disable/remove my graphics card and just run my MOBO's integrated graphics card?  
Any help would be immensely appreciated,

BeeGeePee

Code:
[url=http://pcpartpicker.com/p/1s2nB]PCPartPicker part list[/url] / [url=http://pcpartpicker.com/p/1s2nB/by_merchant/]Price breakdown by merchant[/url] / [url=http://pcpartpicker.com/p/1s2nB/benchmarks/]Benchmarks[/url]

[b]CPU:[/b]  [url=http://pcpartpicker.com/part/intel-cpu-bx80637i53570k]Intel Core i5-3570K 3.4GHz Quad-Core Processor[/url]  ($219.96 @ OutletPC) 
[b]CPU Cooler:[/b]  [url=http://pcpartpicker.com/part/cooler-master-cpu-cooler-rrb10212pg1]Cooler Master Hyper 212 Plus 76.8 CFM Sleeve Bearing CPU Cooler[/url]  ($24.99 @ NCIX US) 
[b]Motherboard:[/b]  [url=http://pcpartpicker.com/part/asrock-motherboard-z77extreme4]ASRock Z77 Extreme4 ATX LGA1155 Motherboard[/url]  ($124.98 @ OutletPC) 
[b]Memory:[/b]  [url=http://pcpartpicker.com/part/patriot-memory-pgd38g1600elk]Patriot Gamer 2 Series 8GB (2 x 4GB) DDR3-1600 Memory[/url] 
[b]Storage:[/b]  [url=http://pcpartpicker.com/part/samsung-internal-hard-drive-mz7pc128bww]Samsung 830 Series 128GB 2.5" Solid State Disk[/url]  ($124.80 @ SuperBiiz) 
[b]Storage:[/b]  [url=http://pcpartpicker.com/part/seagate-internal-hard-drive-st1000dm003]Seagate Barracuda 1TB 3.5" 7200RPM Internal Hard Drive[/url]  ($59.99 @ NCIX US) 
[b]Video Card:[/b]  [url=http://pcpartpicker.com/part/sapphire-video-card-111970340g]Sapphire Radeon HD 7970 3GB Video Card[/url]  ($328.98 @ SuperBiiz) 
[b]Case:[/b]  [url=http://pcpartpicker.com/part/corsair-case-cc600twmwht]Corsair 600T White Graphite ATX Mid Tower Case[/url]  ($159.99 @ Amazon) 
[b]Power Supply:[/b]  [url=http://pcpartpicker.com/part/antec-power-supply-hcp750]Antec High Current Pro 750W 80 PLUS Gold Certified ATX12V / EPS12V Power Supply[/url] 
[b]Optical Drive:[/b]  [url=http://pcpartpicker.com/part/lite-on-optical-drive-ihas124-04]Lite-On iHAS124-04 DVD/CD Writer[/url]  ($14.98 @ OutletPC) 
[b]Total:[/b] $1058.67
[i](Prices include shipping, taxes, and discounts when available.)[/i]
[i](Generated by PCPartPicker 2013-10-30 09:49 EDT-0400)[/i]
 10/31/2013 06:35 PM
User is offline View Users Profile Print this message

Author Icon
chemman81
Peon

Posts: 1
Joined: 10/31/2013

I had a simialar problem with a simialar system.  Do you by chance have Virtu MVP installed?  When I uninstalled it from safe mode everything started working again and I was successfully able to install CCC from a normal boot up.  

Hope this helps!

 11/01/2013 09:40 AM
User is offline View Users Profile Print this message

Author Icon
BeeGeePee
Peon

Posts: 4
Joined: 10/30/2013

Hello,

I did uninstall VirtuMVP.  I actually got my system to function.  I booted in safe mode, uninstalled virtuMVP, ran CCcleaner and whiped everything, ran Driversweeper and whiped everything.  Then installed AMD drivers 13.9.  

 

However, now whenever I play League of Legends or Battlefield 4 the game crashes fairly frequently.  It was almost unplayable for League of Legends.  I also tried uninstalling 13.9 and using the newer 13.11 beta drivers but same issues.  When Battlefield 4 crashes it gives me some error about DirectX.  I found a post by EA about disabling all additional GPU modifcations in Catalyst Control Center which did aliviate the crashing, but it eventually did crash still. 

When League of Legends crashes and I send a report it gives me a link to possible help topics which all seem to be regarding firewall issues (completely different then what the Battlefield 4 issues are).  I am very confused at this point.  I feel like there is just a general lack of stability with windows 8.1 and I deeply regret making the upgrade.  I am at a loss for ideas on how to stabilize my computer at this point.

Statistics
81002 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.