Topic Title: Windows 8.1 Broke Radeon HD 6870
Topic Summary: Update broke card functioning
Created On: 10/30/2013 06:04 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 10/30/2013 06:04 PM
User is offline View Users Profile Print this message

Author Icon
webguy1001
Peon

Posts: 2
Joined: 10/30/2013

After updating to Windows 8.1 I got an error message that CCC could not start and I could not load it.

Also my dual screen setup reverted to both screens being the same and the resolution being low with black line around edge as overscan is not set.

I downloaded the latest driver from ATI site.  Half way through installation my screen went black then a few seconds later the machine restarted.

CCC was still not working.  I tried to install again and same thing happened.

I then used driver sweeper to remove driver as uninstall would not work.  I tried installing again and exactly same thing happened.

I have:

Asus P8Z77-V MotherBoard
Intel i5 Processor
16GB Ram 

I have updated all of my drivers to the latest version from Asus for Windows 8.1 and all report to be working.

Not having my HD6870 functioning has made my desktop setup useless.  

Please can someone help me ASAP!

MTIA

Mike

 10/30/2013 07:16 PM
User is offline View Users Profile Print this message

Author Icon
webguy1001
Peon

Posts: 2
Joined: 10/30/2013

Sods law after I made the post I had a look t what else was installed and realised Virtu MVP was installed.

I uninstalled that and re-tried installation.  This time it installed without crashing PC.

Statistics
84175 users are registered to the AMD Support and Game forum.
There are currently 4 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.