Topic Title: One DisplayPort doesn't work on two different Radeon cards
Topic Summary: Same issue on Radeon 6950 and R9 280X
Created On: 11/05/2013 02:38 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 11/05/2013 02:38 PM
User is offline View Users Profile Print this message

Author Icon
peksa
Peon

Posts: 1
Joined: 11/05/2013

I have an issue that I had with a Radeon 6950 and that I now also experience with a new R9 280X.

I run a 6 monitor setup (4x Dell U2412M over display port cables and 2x HP LP2465 over DVI, all at 1920x1200). With my 6950 the issue was that the monitor connected to the fourth display port flickered and displayed artifacts and sometimes would not work at all. Flickers as in sudden black frames every 1-15 seconds, it also showed some pixel/line artifacts at times.

I have now (2 years later) bought a new R9 280X, and again the same port doesn't work correctly! With the R9 280X I get no image at all in Windows.

With both cards I've tried changing cables and monitors, but the problem always occurs with whichever of the monitor is connected to the "fourth" display port. By fourth I mean the port farthest to the left if looking at the cards from behind.

It shows up regardless of how many monitors are connected, and only on the monitor connected to that port (whichever monitor it is!)

I have some videos of the flickering that occured with the 6950 (with the R9 280X the monitor is always black):

 

Top middle monitor flickering:

http://dl.dropbox.com/u/12279637/flickering1.mov (1.8 MB)

Bottom middle monitor (different monitor and different cable) flickering (and some horizontal line artifacts):

http://dl.dropbox.com/u/12279637/flickering2.mov (2.6 MB)

With both cards the monitor detects that it's connected - it either displays "No DisplayPort Cable" or "Entering Power Save mode" depending on if the cable is connected or not.

 

Specs otherwise:

Motherboard: Asus P8Z68-V PRO

CPU: Intel Core i7 2600K

Mem: Vengeance DDR3 1600MHz XMS3 CL9-9-9-24 1.5V (4x4GB)

Os: Windows 7 64-bit

Drivers: Practically all Catalyst drivers since late 2011... Right now the latest 13.11 beta 8 ones.

 

Any ideas?

Statistics
86514 users are registered to the AMD Support and Game forum.
There are currently 5 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.