Topic Title: Help! Is my New Radeon R9 270X in bad condition?
Topic Summary:
Created On: 11/06/2013 06:36 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 11/06/2013 06:36 PM
User is offline View Users Profile Print this message

Author Icon
jefdetor
Peon

Posts: 2
Joined: 11/06/2013

Please tell me if this sound is normal or shall I change my new grapphic card?

start at second 5

http://www.youtube.com/watch?v=qXmulda4q2o

 

Graphic Card
sapphire dual-x R9 270X
no overclocked

catalyst version 13.6 (just installed some hours ago from the cd)

Windows 7 64 bit ultimate edition

Issue Details
Rare sound, annoying one
(hear the starting sound at second 5 http://www.youtube.com/watch?v=qXmulda4q2o)
That happs running any hard 3D charge game or grapphic card test

Motherboard
Asus Crosshair III Formula

Power supply
OCZ 750 silencer quad

Memory
DDR3 1600 ocz blade 1.65v

 11/06/2013 10:17 PM
User is offline View Users Profile Print this message

Author Icon
masterx1234
Peon

Posts: 50
Joined: 07/21/2013

sounds like its either coil whine or the bearing on the fan is bad, the sound may go away the more you use it, if it keeps it up take you some wd-40 and spray the bearings on the fan very lighly being careful not to get any on the cards electronics, my 7870 actually did the same thing and it was easily fixed just by lubing up the bearing, also it helped the fan move more smoothly

 11/06/2013 10:18 PM
User is offline View Users Profile Print this message

Author Icon
masterx1234
Peon

Posts: 50
Joined: 07/21/2013

also be sure to update to the latest beta drivers because the 13.6 drivers dont have full support for the new r9 cards and your frames per second will suffer greatly

 11/07/2013 04:48 PM
User is offline View Users Profile Print this message

Author Icon
jefdetor
Peon

Posts: 2
Joined: 11/06/2013

Thank you ! Looks like this is coil whine (new concept for me) , it always happs with benchmarks and test software, and running hard 3d graphics games. After install the last beta drivers the sound is very much better, dont know if that sound is "acceptable" or if it is a problem's signal. AMD supports says me may be it is not a problem, now I am trying to submit one support ticket at sapphire oficial support site.

Statistics
84118 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.