Topic Title: R9 270x 2d Flickering
Topic Summary:
Created On: 11/10/2013 09:36 AM
Status: Post and Reply
Linear : Threading : Single : Branch
<< 1 2 3 4 5 6 7 Previous Next Last unread
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 12/04/2013 08:36 AM
User is offline View Users Profile Print this message

Author Icon
shoker
Peon

Posts: 5
Joined: 12/04/2013

Same problem with MSI R9 270X Gaming 2G.....flickering/flash monitor every 5 minutes....or up auto clock

bad card  D:

I have 9.5 beta driver!

Need Fix!

 12/04/2013 09:35 AM
User is offline View Users Profile Print this message

Author Icon
ggenev91
Peon

Posts: 5
Joined: 12/01/2013

The BIOS fixed the flickering while browsing but I was still getting flickering while playing LoL.

But I think the driver fixed even LoL for me. ( Gigabyte R9 270X )

I will make more tests with LOL soon.

 12/04/2013 09:40 AM
User is offline View Users Profile Print this message

Author Icon
shoker
Peon

Posts: 5
Joined: 12/04/2013

which bios? motherboard just update..same problem..

How flash vga bios ?

 12/04/2013 11:35 AM
User is offline View Users Profile Print this message

Author Icon
ashleylai87
Peon

Posts: 33
Joined: 11/26/2013

It appears that I might spoke too early.

V9.5 merely reduce the occurence of flickering and "driver has stopped and recovered etc".

At least it only happen after 2 or more hours of usage.
Better than the previous beta driver in which it happen immediately.

 12/04/2013 11:45 AM
User is offline View Users Profile Print this message

Author Icon
shoker
Peon

Posts: 5
Joined: 12/04/2013

1) I resolve for now with enable physical switch on board and 9.5 beta driver

2) How can boot system with enable Windows 8 Feature from bios? can't boot 

TY

 

 12/04/2013 02:14 PM
User is offline View Users Profile Print this message

Author Icon
RRdeon228
Peon

Posts: 8
Joined: 12/02/2013

Originally posted by: shoker which bios? motherboard just update..same problem..

 

How flash vga bios ?

 

 

Each manufacturer has its own program to update the BIOS. "MSI Live Update 5" for example.

 12/04/2013 10:15 PM
User is offline View Users Profile Print this message

Author Icon
TERROR404
Peon

Posts: 3
Joined: 11/22/2013

ASUS R9 270x here. Flickering completely stopped with 13.11 Beta 9.5, even after setting 2D clocks back to 300/150.

 12/05/2013 08:08 AM
User is offline View Users Profile Print this message

Author Icon
ggenev91
Peon

Posts: 5
Joined: 12/01/2013

After a lot of testing flickering is GONE with the new driver (Gygabite card)!

 12/05/2013 10:29 AM
User is offline View Users Profile Print this message

Author Icon
RRdeon228
Peon

Posts: 8
Joined: 12/02/2013

Originally posted by: ggenev91 After a lot of testing flickering is GONE with the new driver (Gygabite card)!

 

Well, it's very good. What BIOS you use. Standard or the one who gave man name samsai? 

 12/05/2013 01:12 PM
User is offline View Users Profile Print this message

Author Icon
Max_odb
Peon

Posts: 3
Joined: 11/26/2013

I have the Gigabyte card and the default BIOS version with the driver 13.11 beta 9.5 and the flickering is fixed

 12/06/2013 04:48 AM
User is offline View Users Profile Print this message

Author Icon
VWM
Peon

Posts: 29
Joined: 12/05/2013

Naah.. yesterday I updated to beta 9.5 my gigabyte card but still I notice one flicker when browsing in firefox.But no flickering when I play BF4. I think to try vbios update, looks like this helped some users, as user samsai teaching in page 2.



-------------------------

CPU: AMD FX-8350 (black edition FD8350FRHKBOOX) + Cooler Master Hyper 212 X Army (push/pull config. fans Enermax T.B.Silence UCTB12P) / MOBO: Asus M5A99FX Pro2.0 / GPU: Gigabyte Amd Radeon R9 279x ( GV-R927XOC-2GD ) / RAM: Kingston HyperX 2x4GB DDR3 1600Mhz / SSD: Samsung Evo 840 250Gb / Case: Coolermaster K280 / PSU: Chieftec Smart Series GPS-600A8

 12/07/2013 04:48 AM
User is offline View Users Profile Print this message

Author Icon
samsai
Peon

Posts: 10
Joined: 11/12/2013

Originally posted by: VWM Naah.. yesterday I updated to beta 9.5 my gigabyte card but still I notice one flicker when browsing in firefox.But no flickering when I play BF4. I think to try vbios update, looks like this helped some users, as user samsai teaching in page 2.

 

Yeah!! I spent 10days to "fight" with gigabyte(TW)....
From Day 1- 9, they just give me a shxx of typical reply... keep asking me to take the PC/display card for checking,  or reinstall window/driver... although I provided thousand of evidence..

Anyway, good to see that most of us are saved!!

 

 



-------------------------

i5-4440@3.1GHz, ASROCK B85 Pro4,  Gigabyte R9 270X OC, Kingston 2x 4gb 1600, Intel SSD, Corsair CX-500 V3 500W,Window 7

 12/07/2013 09:41 AM
User is offline View Users Profile Print this message

Author Icon
BigBoss91
Peon

Posts: 14
Joined: 11/30/2013

***** amd... any fix for the random low fps issue in games?
 every time I got to restart my pc to get rid of this *****. 

 12/08/2013 10:33 AM
User is offline View Users Profile Print this message

Author Icon
Dexter_prog
Peon

Posts: 2
Joined: 12/03/2013

does anyone have a 270X manufactured by HIS?

 12/09/2013 01:37 PM
User is offline View Users Profile Print this message

Author Icon
VWM
Peon

Posts: 29
Joined: 12/05/2013

Originally posted by: samsai
Originally posted by: VWM Naah.. yesterday I updated to beta 9.5 my gigabyte card but still I notice one flicker when browsing in firefox.But no flickering when I play BF4. I think to try vbios update, looks like this helped some users, as user samsai teaching in page 2.

 

 

 

 

Yeah!! I spent 10days to "fight" with gigabyte(TW).... From Day 1- 9, they just give me a shxx of typical reply... keep asking me to take the PC/display card for checking,  or reinstall window/driver... although I provided thousand of evidence..

 

Anyway, good to see that most of us are saved!!

 

 

 

 

 

Hi, so...two days after I flash new vbios and no flickerings since. Thanks samsai! .



-------------------------

CPU: AMD FX-8350 (black edition FD8350FRHKBOOX) + Cooler Master Hyper 212 X Army (push/pull config. fans Enermax T.B.Silence UCTB12P) / MOBO: Asus M5A99FX Pro2.0 / GPU: Gigabyte Amd Radeon R9 279x ( GV-R927XOC-2GD ) / RAM: Kingston HyperX 2x4GB DDR3 1600Mhz / SSD: Samsung Evo 840 250Gb / Case: Coolermaster K280 / PSU: Chieftec Smart Series GPS-600A8

 12/10/2013 05:19 PM
User is offline View Users Profile Print this message

Author Icon
Medussa
Peon

Posts: 18
Joined: 11/05/2013

Finally, Asus release new vbios. You can DL here

https://www.asus.com/Graphics_Cards/R9270XDC2T2GD5/#support



-------------------------

i5 3570k,  Asus p8Z77-M pro,  Kingston 2x 4gb 1333,  Intel SSD,  PSU Seasonic 600w,  Asus R9 270X Top,  Dell U2212HM 1080p,  Win 8.1,  OSX 10.9

 12/13/2013 02:23 PM
User is offline View Users Profile Print this message

Author Icon
nikhoxz
Peon

Posts: 1
Joined: 12/13/2013

Asus DCII TOP BIOS working well with 13.11 Beta 9.5, thanks!

 

I will test the new asus driver AMD_VGADriver_Win7_8_8_1_32_64_VER13_251 

 

 

 

 

 12/14/2013 04:10 AM
User is offline View Users Profile Print this message

Author Icon
eddyiek2
Peon

Posts: 2
Joined: 12/14/2013

Hi,

I own the same Gigabyte 270x OC.

I have been using latest the ati 13.11 beta 9.5 from the begining and the problem is not solved.

The flickering/artefacts appear both in 2D and 3D apps.

I have tried samsai's VBIOS F2 and the problem still doesn't go away.

Furthermore, after some usage time (10-15 mins), the image permanently scrambles, you cannot do anything about it and you have to reset 

 12/14/2013 04:15 AM
User is offline View Users Profile Print this message

Author Icon
VWM
Peon

Posts: 29
Joined: 12/05/2013

strange, for me everything is ok now. one week using and no flickering at all and no freezing ( I use factory settings ). new 9,5 beta driver + F2 vbios.



-------------------------

CPU: AMD FX-8350 (black edition FD8350FRHKBOOX) + Cooler Master Hyper 212 X Army (push/pull config. fans Enermax T.B.Silence UCTB12P) / MOBO: Asus M5A99FX Pro2.0 / GPU: Gigabyte Amd Radeon R9 279x ( GV-R927XOC-2GD ) / RAM: Kingston HyperX 2x4GB DDR3 1600Mhz / SSD: Samsung Evo 840 250Gb / Case: Coolermaster K280 / PSU: Chieftec Smart Series GPS-600A8

 12/14/2013 10:16 AM
User is offline View Users Profile Print this message

Author Icon
shoker
Peon

Posts: 5
Joined: 12/04/2013

It's for all brand? i have a msi r9 270x

AMD Support and Game » AMD Radeon™ Graphics » R9 270x 2d Flickering

<< 1 2 3 4 5 6 7 Previous Next Last unread
Topic Tools Topic Tools
Statistics
85549 users are registered to the AMD Support and Game forum.
There are currently 4 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.