Topic Title: 290X issues AMD DONT IGNORE US!
Topic Summary:
Created On: 11/17/2013 08:53 AM
Status: Post and Reply
Linear : Threading : Single : Branch
<< 2 3 4 5 6 7 8 Previous Next Last unread
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 11/25/2013 10:06 PM
User is offline View Users Profile Print this message

Author Icon
Earnhardt
Case Modder

Posts: 879
Joined: 09/11/2008

Originally posted by: mikexx
Originally posted by: Earnhardt
Originally posted by: mikexx The 290(x) cards are made by AMD right now they are 'ref' designs wihc means all the same and builded by AMD. The only difference is that some company's put their own sticker on it.

 

 

Though it did at one time, AMD does not distribute Radeon cards directly to consumers. Instead, it sells Radeon GPUs to third-party manufacturers, who build and sell the Radeon-based video cards to the OEM and retail channels. Manufacturers of the Radeon cards include Sapphire, XFX, Asus, Gigabyte, MSI, Biostar, Gainward, Diamond, HIS, PowerColor, Club 3D, VisionTek and Force3D.

 

True and the fact remains that it basicly is a amd gpu, they are being sold to the manufacturers but are all the same, same layout reference design provided by amd with stock coolers. Iam pretty close to this and i know how it works. I asked intern why these cards fail but iam not getting any response so even their manufacterers dont know.

A GPU,much like a CPU,then the card manufacturers build the PCB and puts it on it and then builds the card.

got it now?



-------------------------

AMD Phenom II 1100t @4.0Ghz /Asus sabertooth 990fx/2x Gigabyte 3G 7950's in crossfire/500G samsung 840 ssd/16G G-Skill Ripjaw 1600/2-samsung 24" monitors 1920X1200/Corsair AX1200W psu/W7 pro 64,G19 keyboard,Roccat kone pure mouse,Cooler master HAF932,Corsair H100i water cooler,Zalman ram cooler.Sound Blaster X-Fi Titanium Fatal1ty Champion Series,Logitech Z5500 speakers,Roccat Kave 5.1 headset.

 11/26/2013 12:13 AM
User is offline View Users Profile Print this message

Author Icon
neo5555
Case Modder

Posts: 936
Joined: 08/13/2008

I was so close to buying a 290x..  Instead, i decided to buy another 7970 to crossfire with my existing one...  couldn't be happier.  Crossfire performance has come a long way in the last 12 months...



-------------------------

Pics of my rig
i7 4770k, custom water cooling, 8Gig Corsair Dom 2133 9-11-10-27, ASrock Z87 OC Formula, SilverStone ST-1500 PSU, Creative X-Fi Platinum, Logitech Z-5500D , 2xHIS 7970 CF, Asus VW246H Monitor, Win 7 64Bit HP, Corsair 800D Case

 11/26/2013 05:01 AM
User is offline View Users Profile Print this message

Author Icon
Hackezeh
Peon

Posts: 1
Joined: 11/26/2013

Hi,

got the same problemes with my new R9 270X. It´s a Gigabyte Windforce 3x.

I got blackscreens in BF4 every 10 minutes. Errordescription from my monitor: No signal from graphiccard. Must reboot the system completly.

I installed the new beta driver 9.4 but it don´t help.

Help me !

 11/26/2013 03:43 PM
User is offline View Users Profile Print this message

Author Icon
jjjsong
Peon

Posts: 18
Joined: 11/03/2013

Received my replacement yesterday.  So far no issues (only 1 night so it doesn't mean anything).

However it has a pretty bad coil whine... that's 2 cards back to back with this coil whine issue.  So freaking annoying.  And RMA is such a waste of time (although I may have to do it still - can't stand the noise).  This is getting so frustrating.

 11/26/2013 06:47 PM
User is offline View Users Profile Print this message

Author Icon
trokker
Peon

Posts: 1
Joined: 11/26/2013

I bought a r9 290 from saphire. I have had 3 bsod, and 4 random restarts in 6 days, I turned it in to have it checked out. If they say it's ok I will return it and get an nvidia card (I hate to do it cause i really want there to be competition).

Please let this be a driver fault and not hardware related like I highly suspect.

 11/28/2013 09:57 AM
User is offline View Users Profile Print this message

Author Icon
kray28
Peon

Posts: 18
Joined: 11/17/2013

RMA replacement R9 290 arrived two days ago. Actually Newegg just gave me a brand new card. With this one.... so far no funny business. I have not really stress tested on games though.... using the latest beta driver v9.4.


II noticed that that Overdrive is completely gone in CCC though and there is no way for me to monitor temps.

 

 11/28/2013 04:24 PM
User is offline View Users Profile Print this message

Author Icon
mikexx
Peon

Posts: 29
Joined: 11/17/2013

Originally posted by: kray28 RMA replacement R9 290 arrived two days ago. Actually Newegg just gave me a brand new card. With this one.... so far no funny business. I have not really stress tested on games though.... using the latest beta driver v9.4.

 

II noticed that that Overdrive is completely gone in CCC though and there is no way for me to monitor temps.

 

 

 

Open regedit en search for 'overdrive' set EULA_Accepted 'true'

 11/29/2013 06:13 AM
User is offline View Users Profile Print this message

Author Icon
Patski
Peon

Posts: 2
Joined: 11/14/2013

My r9 290 is still black-screening in BF4 on the latest drivers.

I wish AMD would let people know whether it was a driver issue or a hardware issue, I'm taking my card back tomorrow and hopefully getting a replacement on the spot or a full refund but we will have to see.

I'm super happy with everyone about the r9 290 minus the black screen issue which is incredibly frustrating. Is this a driver issue? Will it be fixed? Or should I stop holding out and return my card.

 

 

 11/30/2013 07:21 AM
User is offline View Users Profile Print this message

Author Icon
mikexx
Peon

Posts: 29
Joined: 11/17/2013

I havent got any black screen anymore with my core on 1130 and ram on 1300.

if i go higher yes it randomly starts to black screen again.
On Uber modus (stock) and up to 1130/1300 i havent got any isseus anymore. 

 11/30/2013 11:54 AM
User is offline View Users Profile Print this message

Author Icon
Euda
Peon

Posts: 4
Joined: 11/24/2013

Sign.

Now suddenly no issues anymore. At all.

Thank you



-------------------------
FX-8350
R9 290X
DDR3-1866 CL9
 11/30/2013 04:58 PM
User is offline View Users Profile Print this message

Author Icon
jjjsong
Peon

Posts: 18
Joined: 11/03/2013

Been 5+ days on the new beta9.4 driver and no blue screens at all.  It's looking promising!

Sadly I still need to RMA this due to loud coil whine.

 11/30/2013 05:32 PM
User is offline View Users Profile Print this message

Author Icon
kray28
Peon

Posts: 18
Joined: 11/17/2013

RMA replacement R9 290 is working great for me. Hasn't crashed/black screened once with betav9.4...and I spent the whole day today gaming with it.

Running Deus EX: HR, DX11 mode, max settings at 1440p, which I think is pretty taxing on the GPU. 

I do get some coil whine, but it's faint, and my case does a good job of muffling most of it....so not enough of a reason to replace. 

I wasn't able to activate Overdrive per mikexx's instructions above....so I would like the next driver to give us back the Performance/Overdrive tabs please.

 11/30/2013 06:58 PM
User is offline View Users Profile Print this message

Author Icon
mikexx
Peon

Posts: 29
Joined: 11/17/2013

Originally posted by: kray28 RMA replacement R9 290 is working great for me. Hasn't crashed/black screened once with betav9.4...and I spent the whole day today gaming with it.

 

Running Deus EX: HR, DX11 mode, max settings at 1440p, which I think is pretty taxing on the GPU. 

 

I do get some coil whine, but it's faint, and my case does a good job of muffling most of it....so not enough of a reason to replace. 

 

I wasn't able to activate Overdrive per mikexx's instructions above....so I would like the next driver to give us back the Performance/Overdrive tabs please.

 

Strange.. for me it works? i dont use it, i prefer 3rd party tools

You did a reboot afterwards right? 

 11/30/2013 07:33 PM
User is offline View Users Profile Print this message

Author Icon
mikexx
Peon

Posts: 29
Joined: 11/17/2013

Cant believe it i just had a black screen :<! !!!

 12/02/2013 10:37 AM
User is offline View Users Profile Print this message

Author Icon
pcvanvliet
Peon

Posts: 6
Joined: 11/28/2013

Hi All,

Has anybody tried using oc tools to resolve their issues with the R9 290?

My Gigabyte R9 290 came with OC GuruII. At first I had mayor stabillity issues, which I could pinpoint to having a thermal reason. Because everyone said that this card is supposed to be loud, and mine wasn't, I started playing with driver settings in combination with OC Guru II.

I have my system running perfectly now with the following:

Latest AMD Catalyst driver 13.11 Beta9.4 because the beta is not running my fans on high enough speeds I use OC Guru II to take care of fan speeds. And what do you know, no more thermal issues and I'm able to play BF3 for hours and hours!

needless to say, I'm a happy camper now! However I will be on the lookout for a solutions from AMD, as this card out of the box is not working at all! Once you put some load on it, it rockets to 95c and then crashes your computer.

 12/02/2013 05:45 PM
User is offline View Users Profile Print this message

Author Icon
HI0K
Peon

Posts: 2
Joined: 12/02/2013

In my case, my Gigabyte 290x 10 minutes worked at  97 C. Installing the latest drivers at the moment. I was pleasantly surprised that the threshold was 95 overstep

 

                      Date   / Core /Memory/Temp/Fan/Speed

02/12/2013 14:50:24/ 727.0/1250.0/96.0/45/2241,

-------------------------------------------------- -------------------

02/12/2013 14:55:46, 727.0/1250.0/97.0/45/2410

-------------------------------------------------- -------------------

02/12/2013 15:02:27/727.0/1250.0/96.0/45,2240

 12/02/2013 05:48 PM
User is offline View Users Profile Print this message

Author Icon
Euda
Peon

Posts: 4
Joined: 11/24/2013

Blackscreens returned again...



-------------------------
FX-8350
R9 290X
DDR3-1866 CL9
 12/02/2013 05:53 PM
User is offline View Users Profile Print this message

Author Icon
HI0K
Peon

Posts: 2
Joined: 12/02/2013

Originally posted by: Euda Blackscreens returned again...

 

The system worked fine, but do not return from hibernation mode and hangs after logging in (a couple of times)



Edited: 12/02/2013 at 06:12 PM by HI0K
 12/06/2013 08:01 PM
User is offline View Users Profile Print this message

Author Icon
mistakenot
Peon

Posts: 6
Joined: 11/18/2013

Originally posted by: pcvanvliet

Hi All,

 

Has anybody tried using oc tools to resolve their issues with the R9 290?

 

My Gigabyte R9 290 came with OC GuruII. At first I had mayor stabillity issues, which I could pinpoint to having a thermal reason. Because everyone said that this card is supposed to be loud, and mine wasn't, I started playing with driver settings in combination with OC Guru II.

 

I have my system running perfectly now with the following:

 

Latest AMD Catalyst driver 13.11 Beta9.4 because the beta is not running my fans on high enough speeds I use OC Guru II to take care of fan speeds. And what do you know, no more thermal issues and I'm able to play BF3 for hours and hours!

 

needless to say, I'm a happy camper now! However I will be on the lookout for a solutions from AMD, as this card out of the box is not working at all! Once you put some load on it, it rockets to 95c and then crashes your computer.

 

I did a similar thing with MSI Afterburner.  Did up my own custom fan speed control and I now never get above 90c and GPU is always running at 1ghz.  I only wish AMD had done a much better job of the cooler, this card would have been outstanding if they had.  Nvidia do a far far better job of their coolers.

All told though, very happy with the performance.  I used to have an issue with Wow but that turned out to be a stupid ass addon causing a 40fps hit outdoors.  Now that I fixed that it runs unbelievably well.  

Eyefinity for the most part also works pretty darn well. I am running 3x2560x1440.  Neverwinter and Bioshock Infinite look nothing short of amazing and run pretty well with just one card  The presets though in Catalyst need more work because it is quite flakey.  I had issues with saving them and also swaping between presets doesn't always resync each monitor so I end up with 2 running and one black.  Swap back and forth a couple of times generally fixes it.

 12/20/2013 01:42 PM
User is offline View Users Profile Print this message

Author Icon
relevanze
Peon

Posts: 1
Joined: 12/20/2013

I have a Gigabyte r9 290 and still Blackscreens.

Usually mostly after startup from cold PC.

I tried the following Drivers without getting rid of the Blackscreens.

13-12_win7_win8_64_dd_ccc_whql

AMD_Catalyst_13.11_BetaV9.4

AMD_Catalyst_13.11_R9_290_WHQL

AMD_Catalyst_13.11_BetaV9.5

AMD_Catalyst_13.11_BetaV9.2

 

AMD Support and Game » AMD Radeon™ Graphics » 290X issues AMD DONT IGNORE US!

<< 2 3 4 5 6 7 8 Previous Next Last unread
Topic Tools Topic Tools
Statistics
84960 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.