Topic Title: Radeon HD7870 Ghz Edition 2Gb GDDR5
Topic Summary: Max fan speed but not showing anything
Created On: 11/18/2013 03:31 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 11/18/2013 03:31 PM
User is offline View Users Profile Print this message

Author Icon
milanvipa
Peon

Posts: 2
Joined: 11/17/2013

So, to cut to case , i have PowerColor Radeon HD7870 Ghz Edition 2Gb GDDR5 , i connect the card to the motherboard  , then 2 x 6pin power cables . Then i start the PC ,graphic  card goes to the max fan rpm , and stay like that , doesnt give a sign of a life to the monitor ,  and keep spinning the fan at max ( it like you havin a boing 747 in your room ) , (or two of them) . The motherboard is Asus Maximus VGene , i7 processor , 16 gb of ram , power supply is cooler master 1000w modular , 256 ssd by samsung , 1 tb baracuda . So whats wrong with this card , does anybody know can i fix this , and is it fixable . 

Thanks in advance .
Greetings from Serbia .

EDITED: I have removed the offensive language.  I notice the same use of language in another post of yours.  I am warning you now - avoid that language.



-------------------------

Intel i7 4770k 


Asus Maximus VGENE Z77


Samsung 256 Gb ssd 


16 Gb RAM by Kingston


Watercooling by CoolerMaster 


Case CoolerMaster Mystique black 


1000w full modular CoolerMaster 


R9 290x  x2 in one pc 


HD7870 in another 



Edited: 11/19/2013 at 08:52 AM by AMD Support and Game Moderator
Statistics
88776 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.