Topic Title: AMD R9 290X: Still getting blackscreens with Beta 9.4
Topic Summary: Still got the blackscreen-issue even after reinstalling Windows 7 64 Bit including the new Catalyst Beta 9.4 drivers.
Created On: 11/24/2013 04:56 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 11/24/2013 04:56 PM
User is offline View Users Profile Print this message

Author Icon
Euda
Peon

Posts: 4
Joined: 11/24/2013

Good evening AMD staff,

 

just wanted to report that I'm still getting the usual blackscreen-issue (blackscreen+1-2 corrupted frames before, sound loop for ~10 seconds + hard lock, complete cold reboot is necessary to boot, reset-button doesn't help).

 

Tested BF4 @ 200% Res-Scale @ 4xMSAA @ Ultra (FHD-display) @ SP-Shangai-Mission. It blackscreened after 3 (three) minutes.

Irrelevant if that's an unusual high GPU-load with unplayable FPS. It should work stable and flawless like that and I'm running without any OC. Aftermarket cooler, the Accelero Hybrid from Arctic, is installed and both VRM & GPU keep cool while playing. So no heat problems at all.

Since the issues seem to got fixed for some people, I'm still hoping for future WHQL & Beta-releases to get the issue fixed, though mine definitively still exist. I just want to report to you.

 

Thanks for reading

Euda



-------------------------
FX-8350
R9 290X
DDR3-1866 CL9
 11/24/2013 05:55 PM
User is offline View Users Profile Print this message

Author Icon
kray28
Peon

Posts: 18
Joined: 11/17/2013

You should RMA the card...I do think that there's a batch of faulty cards out in the wild.

 11/24/2013 06:01 PM
User is offline View Users Profile Print this message

Author Icon
Euda
Peon

Posts: 4
Joined: 11/24/2013

Originally posted by: kray28 You should RMA the card...I do think that there's a batch of faulty cards out in the wild.

 

I can't because of the Aftermarket-cooler. I'm forced to wait for a fix

If you're true, they should acknowledge the faulty cards IMO.



-------------------------
FX-8350
R9 290X
DDR3-1866 CL9
 11/27/2013 04:22 AM
User is offline View Users Profile Print this message

Author Icon
kdawgmaster
Peon

Posts: 37
Joined: 11/01/2010

Im also more leaning to a fault with the card and not a problem with the drivers. 

 

I can only say this as i havent had 1 issues so far with the new 13.11 V9.4 besides BF's massive fps drop which i think people have linked to the last patch for BF and not the drivers but i cant say.

 

This is also why i didnt consider a aftermarket cooler as thermal adheisive means ur on ur own now. Normally as long as u can get the stock cooler back on and its still causing faults then u still get warranty.



-------------------------
Tri-Fire R9 290x 2560X1440
Game benchmarker
Benchmarking youtube channel http://www.youtube.com/user/kdawgmaster?feature=mhum
Statistics
88815 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.