Topic Title: Gigabyte R9 280X Flickering Issue
Topic Summary: Gigabyte R9 280X Flickering Issue
Created On: 11/27/2013 05:10 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 11/27/2013 05:10 PM
User is offline View Users Profile Print this message

Author Icon
Blastwave
Peon

Posts: 3
Joined: 11/25/2013

 

 

I have a Gigabyte R9 280X OC Windforce


I'm getting flickering only in 2D. Works fine with games.

Ive updated to 13.11 drivers. Still the same flickering.


What to do?

please advise.

Thank You

P.S. I've read around the forum and I've been suggested to decrease Memory clock and increase shader clock.

How do I do that?

And Will that help in this situation?
 03/03/2014 04:08 PM
User is offline View Users Profile Print this message

Author Icon
Brucy
Peon

Posts: 7
Joined: 03/02/2014

I just bought two of these cards. Same issue. I've read over the forums and seems a lot of people have this issue not specific to the Gigabyte models.

 03/05/2014 04:12 AM
User is offline View Users Profile Print this message

Author Icon
scanz
Peon

Posts: 1
Joined: 03/05/2014

Also having this problem and with my second card because RMA'd the first. Now after experiencing the issue on the second card I found a lot of people are having similar issues. Is it hardware or software related? What can be done to fix it? Really don't want to go through the hassle of an RMA again.

 03/05/2014 08:41 PM
User is offline View Users Profile Print this message

Author Icon
Brucy
Peon

Posts: 7
Joined: 03/02/2014

I sent a card in for RMA yesterday because I troubleshot with Gigabyte and that was determined the defective card. The flickering seem to have went away. Guess what. My other card is now flickering too. 

 03/07/2014 06:37 PM
User is offline View Users Profile Print this message

Author Icon
Vegan
Elite

Posts: 1152
Joined: 01/31/2010

Check the panel and see what the redraw speed is set for.

You can also check with video properties.

 



-------------------------

 03/07/2014 06:59 PM
User is offline View Users Profile Print this message

Author Icon
Brucy
Peon

Posts: 7
Joined: 03/02/2014

Where do I check that?

 03/08/2014 08:49 AM
User is offline View Users Profile Print this message

Author Icon
Brucy
Peon

Posts: 7
Joined: 03/02/2014

Just to give an idea of what my system is:


Intel i5 3570K

ASUS P8Z77-V PRO

2x GIGABYTE GV-R928XOC-3GD REV2 Radeon R9 280X

Kingston Hyper-X Blu 16GB

Antec 1000W PSU

I also have an Antec DF-85 case. So air flow is not a problem. The card does not exceed 75c ever and as the rest of this thread suggest it happens when idle or doing 2D tasks such as browsing.


I have sinced RMAed one of the cards because I thought I isolated it to one card and was recommended by Gigabyte. This was 3 days ago. The day after I started noticing a flicker on the other card by itself in my system.

I found a post on another forum that recommended downgrading drivers to the drivers that came on the CD with the card which is 13.10. Since fully uninstalling the old drivers and reverting to these drivers I have only noticed a flicker maybe once.

Based on that this leads me to believe this is purely driver or bios related. Not to mention other vendors ASUS, Sapphire have all fixed the issue with a BIOS update.


If I don’t get a resolution to this soon AMD will be losing a long term customer of almost 15 years.

Statistics
84254 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.