Topic Title: R9 280x flickering squares problem
Topic Summary:
Created On: 12/22/2013 05:23 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 12/22/2013 05:23 AM
User is offline View Users Profile Print this message

Author Icon
Br1Ght
Peon

Posts: 1
Joined: 12/22/2013

Card ASUS R9280X-DC2T-3GD5-V2, system Windows 8.1 x64

Several days ago made a clean system installation with asus drivers.

It worked fine for 2d tasks. Today i began to install games and decided to update drivers to latest version.

After update, everything worked fine. Then i did Unigine Heaven benchmark, temp raised to 74C. I also installed Comodo Internet security, DX9 and Nvidia physx. I  launched Risen 2 and played for 15 minutes.

After reboot i recieved flickering black and coloured squares all over the screen.

Only solution i have found so far is to uninstall all amd drivers and work with MS video drivers (or using intel HD4600).

Re-installing drivers causes flickering to reappear.

I guess i have to try one more fresh OS installation, but i don't expect it to work.

All tips would be appreciated.

 

My system config is

Intel Core i5-4670,  MB ASUS H87-PRO, PSU Corsair AX 760i

Statistics
84124 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.