Topic Title: HD7870 fps drops on most games
Topic Summary: Fps drops on Far Cry 3, Red Faction: Guerrilla and State of Decay
Created On: 12/22/2013 06:15 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 12/22/2013 06:15 PM
User is offline View Users Profile Print this message

Author Icon
metalsynkk
Peon

Posts: 2
Joined: 12/22/2013

Like the title implies, I am having lag spikes on games where there shouldn't be any. The games (State of Decay, Far Cry 3 and Red Faction: Guerrilla, but also other relatively new titles) have lag spikes approximately every 45 seconds, for a period of 5 seconds.

 

The settings for the games are mostly set to high or ultra, and I get a solid 50+ fps if not higher during the 45 normal seconds, so this is why I am presuming the drops shouldn't be there. For State of Decay I know for a fact that the game is kind of unoptimised and there are issues that should be fixed since it is a port from the Xbox 360, but the other games should run fine for the specs I gave (see signature).

 

The games except SoD have also been played prior to 2 things: the switch from Windows 7 to Windows 8.1 and the switch fron the AMD FX6100 to the FX8120, since I remember playing those flawlessly before.

 

That's basically all there is to say, I have experimented with multiple graphical settings in the games themselves (even setting everything to the lowest possible settings, and I still get the drops) and I have also set everything in Catalyst to "Use application settings" so that wouldn't mess with it.

 

If anyone has this issue and has any information that could help me resolve it, that would be very much appreciated. Also, any information that you may require which I am able to provide will be provided if need be.



-------------------------
AMD FX8120 Black Edition
AMD Radeon HD7870 Double Dissipation
G.Skill 8GB DDR3 RAM
WD 1.5TB Hard Drive
 12/22/2013 06:26 PM
User is offline View Users Profile Print this message

Author Icon
Thanny
Alpha Geek

Posts: 1331
Joined: 07/13/2009

All I can suggest at this point is that you look in the Windows Event Viewer for anything suspicious at the time you experience the lag.

 

 12/22/2013 09:35 PM
User is offline View Users Profile Print this message

Author Icon
metalsynkk
Peon

Posts: 2
Joined: 12/22/2013

Originally posted by: Thanny All I can suggest at this point is that you look in the Windows Event Viewer for anything suspicious at the time you experience the lag.

 

 

 

 

Thanks, I will look into that, never used the Event Viewer before. However, I did just upgrade from Catalyst 13.9 to 13.12, it seemed to fix the problem for 5 minutes. And I am generally cleaning up the pc right now and have noticed that there are some unnecessary applications running/installed in the first place, maybe that could be the issue.



-------------------------
AMD FX8120 Black Edition
AMD Radeon HD7870 Double Dissipation
G.Skill 8GB DDR3 RAM
WD 1.5TB Hard Drive
Statistics
84742 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.