Topic Title: Triple monitor setup - Screens go black when launching games
Topic Summary:
Created On: 12/30/2013 05:20 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 12/30/2013 05:20 PM
User is offline View Users Profile Print this message

Author Icon
Strygwyr
Peon

Posts: 4
Joined: 12/27/2013

So I finally got my triple monitor setup up and running again after it failed me the first time. Had to get new adapters etc and now all 3 monitors work fine. 
Now the problem is... when I turn on a game, Diablo, WoW, Hearthstone, DOTA2, doesn't matter which game, all 3 monitors go black and flicker on/off until I alt+f4 to close the game or restart the computer. 

I have monitored Activity and Temperature on the card using AMD's Catalyst Control Center, activity goes as high as 80% sometimes with no crashes and temperature as high as 58C with no crash and then after a few minute of gaming it just starts the blinking on and off on all 3 screens, like the card is losing power. Windows also makes a sound like I just disconnected a device or something every time, like a monitor is being disconnected and reconnected.

I am running a Sapphire Radeon 7850 2gb connected to 3 monitors via DVI->DVI cable, 
HDMI->DVI Cable and an Active MiniDP->DVI cable

One thing I have managed to gather, every time the monitors turn on and off, sometimes the monitor connected via HDMI to DVI wont come back on and if I go into CCC and change its resolution, it works again. Otherwise it will just stay black with the power light on, but the GPU not sending it any picture.

Could this just be another faulty MiniDP->DVI adapter? I am trying my damn best to not spend a couple hundred bucks on a new GPU.

 

Update;

 

Seems the issue ONLY occurs when I use my active MiniDP->DVI adapter, does this just mean a faulty adapter?



Edited: 12/30/2013 at 08:06 PM by Strygwyr
 12/30/2013 05:35 PM
User is offline View Users Profile Print this message

Author Icon
Vantharas
Polygon Pusher

Posts: 3516
Joined: 03/01/2009

What resolutions are the monitors running at total? Eyefinity SLD , or Just extended desktop mode. 

Are the games window'd / full screen. Are you useing crossfire. 

have you tried useing a different displayport on the back of your card. Have you tried useing a different adapter?



-------------------------

I5 3570K@4~5.0ghz: Gigabyte GA-Z77X-UD3H:Corsair Hydro H110 :16GB Corsair Vengeance DDR-3 1600: x2 XFX Radeon 7950 @ 1100/1575 : Corsair AX 860 PSU: x1 WD Black 1TB HDD's: 90GB Agility 3: 960GB SSD : Creative Labs X-FI:Corsair 500R Arctic White Edition:3 22inch Monitors Eyefinity @ 5294x 1050 : Alienware Tact-X Keyboard: Razer Naga :Corsair Vengence 1500 Headset: Corsair SP2500 Speakers

 12/30/2013 05:47 PM
User is offline View Users Profile Print this message

Author Icon
Strygwyr
Peon

Posts: 4
Joined: 12/27/2013

All monitors are 1900x1080

Not using Eyefinity (but it works, I tested it), just extended desktop.

I tried the games in all different modes, Windowed, Windowed fullscreen, Fullscreen, same problem every time.

This is actually the second adapter I am using, my first MiniDP->DVI adapter (also an active one) didnt work at all.

One additional piece of info however, I have been using only 2 out of 3 monitors until the problem is resolved, and I dont have any issues with just 2 monitors.

 12/31/2013 01:27 PM
User is offline View Users Profile Print this message

Author Icon
zipsi
Elite

Posts: 1050
Joined: 11/22/2010

I've heard so much trouble with all those active adapters that makes recommend that all future monitors have displayport connectors, no adapters, no issues. 



-------------------------
Intel I7 3770K @ 4.5ghz, Cooler Master Hyper 212 Evo, Gigabyte Z77X-UD3H, Gigabyte HD7970 ghz edition, 4x4gb Kingston HyperX Beast 2133mhz, Seasonic Platinum 860, Samsung 840 Pro 256gb, OCZ Vertex 4 128gb, WD Black 1TB, WD Green 3TB+1.5TB, ASUS Xonar Essence ST, ASUS VE278Q, Windows 3.11
Statistics
89096 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.