Topic Title: MSI 7850 Problems - Artifacts
Topic Summary:
Created On: 01/01/2014 11:46 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 01/01/2014 11:46 PM
User is offline View Users Profile Print this message

Author Icon
Jimmy Gibbs Jr.
Peon

Posts: 1
Joined: 01/01/2014

Hi everyone.

I have to share my pain with some more experienced users in case I might find out the right thing to do.

My specs:

ASUS H87 PLUS
i5 4570 3,2 GHz
8GB RAM Gskill 1600
PSU OCZ 600W
SAMSUNG EVO SSD 120GB
Windows 7 64 bit

Two days ago I upgraded my Sapphire 6670 1GB DDR5 to an MSI 7850 OC 2GB. It's been 2 very difficult days. Main problem is that the card is artifacting in some games and also sometimes flickering when I browse with Firefox (both when using DVI or a DVI-VGA adapter). My monitor is a BenQ make, rather old, maxes at 1280x1024 resolution.

In Skyrim I see flashing pixels at random times if I play at any resolution higher than 1024x768. The same stands for Metro 2033 (those flashing pixely artifacts and also CTD followed by the "display driver stopped.." message), however, if I switch to DirectX 10 or 11 the game runs without problems, even at 1280x1024. RAGE and Left 4 Dead 2 are the other 2 games installed at the moment and they both run without problems. I wanted to install more games from steam (especially DX9 games) and test further, but here is what I actually did. I thought that maybe my new card and my old monitor were not best buddies so I went to my HD TV. Used the HDMI port to connect and tested games at hi-res (that's why I got the bloody 7850 in the first place, planning to buy a good HD pc monitor). Metro 2033 at 1080, frequent flashes and artifacts, skyrim as well. RAGE and L4D2 were still fine. I have tried:

-Altering the 2d/3d clocks with Afterburner and Asus gpu tweak,
-Catalyst 13.1 and 13.12 drivers(with 13.12 the DVI port of the card was acting stupid with the little monitor, basically refusing to light up on startup, had to replug to get some picture)
-underclocking the memory clock
-increasing voltage (sice this is a factory OC card and maybe needs some extra juice. V was set at 1138 I raised it to 1225)
-Switching on/off AA, Vsync

Nothing worked. I was almost certain this was a skyrim issue but when I saw the same pixels in Metro 2033 I was mortified and convinced it's the GPU. I will test more games tonight and see what happens at hi-res with games like Fallout NV, Borderlands 2, Bioshock Infinite, Witcher 2 and Guild Wars 2 but I was hoping for some advice too. Should I RMA the card or insist on fixing the issues? I would give the extra 30-40 € and go for a 7870 or a R9 270. I have read soo many posts from heart-broken AMD 7xxx owners and I don't know what to do.

To anyone who actually took the trouble to read my huge post: You are awesome and you have my sincere thanks. I'd be eternally grateful if you could help.

My kindest regards.

EDIT:


OK, so I have a few pics and a little update after some thorough testing.
This is what I get in Metro 2033, Skyrim, Fallout NV and Borderlands 2:

http://i1328.photobucket.com/albums/w532/Tanuki13/Borderlands22014-01-0113-53-50-56_zps1d1ac8ba.png
http://i1328.photobucket.com/albums/w532/Tanuki13/FalloutNV2013-12-3117-49-25-57_zps78a55dcd.png
http://i1328.photobucket.com/albums/w532/Tanuki13/TESV2013-12-3117-41-19-86_zps6a9f298c.png
http://i1328.photobucket.com/albums/w532/Tanuki13/Metro20332014-01-0101-08-50-20_zpsd1b7c28c.png


The glitch is frequent enough to easily capture those screenshots with fraps, flashing every few seconds.

GPU temp hovers around 45 and peaks at 50 C. GPU usage is between 50-90 % at all games (usually hovering around 70% and spiking at 90%)
Core clock is fixed at 900MHz under load and 300MHz idle while Memory clock is 1200MHz load and 150MHz idle.
The artifacts appear on both monitors (my 1280x1024 BenQ and also the big HD TV downstairs at 1920x1080)
I am inclined to RMA the card tomorrow or the day after, I just want to exhaust the possibility that this might be some other hardware-related fault which I have yet not discovered (I would be really miserable If I get a replacement 7850 or If I buy a 7870 with the refund money and still have the same problems). Before packing the box to send the card back I will try the other PCI slot on the mobo. I don't want to flash the BIOS and risk frying up things, my ASUS H87 is brand new, I think newer than the GPU, and the whole computer worked fine with the previous 6670 card. RAM should be ok too.

I have tried catalyst 13.1, 13.12, and 12.6 with the same results. One interesting thing is that fallout, when auto-detecting specs, sets the game setting to medium quality, which I find hilarious but leads me to believe that the card is indeed the culprit. Needless to say that I could play at ultra high with the 6670.

For powering the card I am using the pci-e extension from the PSU not the double molex to 6-pin that came with the card and judging from my devices i shouldnt be using more than 350-375 W at highest loads.

Once again any thoughts, suggestions or expertise would be greatly appreciated.
Happy new year folks
It's gonna be a good one...

Statistics
84247 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.