Topic Title: Resolution issue HIS R9 270X
Topic Summary: Catalyst won't support 1920x1080
Created On: 01/09/2014 12:21 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 01/09/2014 12:21 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 2
Joined: 01/09/2014

Good afternoon,

Seems that my newly bought HIS R9 270X IceQX2 Turbo Boost is not living up to my expectations. 

ASUS M5A78L M LX3 motherboard
AMD FX(tm)-6300 Six-Core Processor (6 CPUs), ~3.5GHz
8192MB RAM
Direct X Version 11
HIS R9 270X PCIe 3.0 2GB DDR5 
Primary monitor LG IPS277(HDMI)
Secondary monitor Samsung Syncmaster 205 BW
Current graphics driver version: 13.12 


The reccomended resolution for my primary monitor is 1920x1080. First of all, this option does not show in the catalyst control center. When I use windows screen settings and put it on the reccomended resolution, my desktop screen will appear again after a short black out but it will end up with a large black surronding box. What I am trying to say is that not the entire 27inch of my monitor is being used. Something that really pisses me off

Also, Photoshop is telling me that my color settings are wrong. I have no flying clue how to fix that. I reckon something is wrong with my drivers or the card itself.

Tried the following: 

- Reinstall drivers
- Unplugging secondary screen and retrying the 1920x1080
- Tried to do same via HD TV option in catalyst. Same issue when put on 1080p or 1080i.

Please respond, as I'm out of ideas how to solve this irritating issue. 

Many thanks in advance.

Regards, Ani




 01/09/2014 12:53 PM
User is online View Users Profile Print this message

Author Icon

Posts: 1045
Joined: 11/22/2010

Intel I7 3770K @ 4.5ghz, Cooler Master Hyper 212 Evo, Gigabyte Z77X-UD3H, Gigabyte HD7970 ghz edition, 4x4gb Kingston HyperX Beast 2133mhz, Seasonic Platinum 860, Samsung 840 Pro 256gb, OCZ Vertex 4 128gb, WD Black 1TB, WD Green 3TB+1.5TB, ASUS Xonar Essence ST, ASUS VE278Q, Windows 3.11
 01/09/2014 01:01 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 2
Joined: 01/09/2014

You are my hero. Can't believe it was that easy though...

Apologies for my stupidity and many thanks for your quick reply!

84893 users are registered to the AMD Support and Game forum.
There are currently 6 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.