Topic Title: URGENT: Impossible to download R9 280 drivers from AMD website?
Topic Summary: AMD website is defective and do not allow to download the R9 280 drivers
Created On: 01/10/2014 08:49 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 01/10/2014 08:49 AM
User is offline View Users Profile Print this message

Author Icon
wipeout01
Peon

Posts: 6
Joined: 09/05/2012

Hello

I tested this with several browsers, Firefox and Internet Explorer... and I cannot download my graphics drivers.

I've bought a Sapphire Radeon R9 280 Toxic and I want to download the last graphics drivers... so I go to:

http://support.amd.com/en-us/download

And I select...

Step 1

Desktop Graphics

Step 2

Radeon R9 Series

Step 3

Radeon R9 2XX Series

Step 4

Windows 8.1 64 bit

Step 5

DISPLAY RESULTS

I press display results, and I do not get the link for the Catalyst Package for this graphics card.

I only have available the optional downloads: Hydravision and Hydravision Package... but I cannot download the drivers...

I NEED TO DOWNLOAD THE DRIVERS WITH URGENCY, BECAUSE I NEED TO INSTALL THEM IN A NEW PC I WILL PICK UP IN A SHOP, NEXT WEEK.

Please, could you solve this problem?

Thanks

 01/10/2014 09:21 AM
User is offline View Users Profile Print this message

Author Icon
Hardwood
Polygon Pusher

Posts: 3979
Joined: 01/27/2008

Well that's pretty lame...

Use win7 64bit instead of win8 when choosing the OS, you'll see it's the same for win8 win8.1 and win7.



-------------------------

#1: Phenom II C2 955BE @ 3.6, Antec Kuhler 920, Gigabyte GA-MA790FX-DS5, Asus 5870/V2, ASUS Xonar D2X, 4 x 1gig OCZ2N1066SR2GK @800, Antec Truepower New 750, Arc Midi, Vistax64
#2: Athlon 64 X2 4200+, AGP 1950pro, Audigy 2, Asus A8V-D, 2gig ram,  Enermax 465P, Antec900case. Now on Win8.1pro cat 10.2

 01/10/2014 10:28 AM
User is offline View Users Profile Print this message

Author Icon
black_zion
Nanotechnology Guru

Posts: 11577
Joined: 04/17/2008

Step 6: Download the drivers here which gives you the link for the Catalyst package.

Works fine for me with Firefox 26 and IE 11.

-------------------------
ASUS Sabertooth 990FX/Gen3 R2, FX-8350 w/ Corsair H60, 8 GiB G.SKILL RipjawsX DDR3-2133, XFX HD 7970 Ghz, 512GB Vertex 4, 256GB Vector, 240GB Agility 3, Creative X-Fi Titanium w/ Creative Gigaworks S750, SeaSonic X750, HP ZR2440w, Win 7 Ultimate x64
 01/10/2014 06:51 PM
User is offline View Users Profile Print this message

Author Icon
wipeout01
Peon

Posts: 6
Joined: 09/05/2012

Originally posted by: black_zion Step 6: Download the drivers here which gives you the link for the Catalyst package. Works fine for me with Firefox 26 and IE 11.

Hello, when I go to the link you suggested me...

http://support.amd.com/en-us/download/desktop?os=Windows%208.1%20-%2064

What I get is this:

Nothing.

 

I think it is a problem of the + - deployable menu, that is not compatible in all browsers or all environments.

You display it, but I prove you, and also to AMD I cannot see it.

Many people won't download the drivers if they experience this problem, so I would like the forum's moderator talk to someone at AMD to explain this, or just, explain me why I cannot see this?

I GET THE SAME RESULT IN: Firefox 26, Maxthon 3, Chron e 31.0.1650.63 m, Internet Explorer 11

Thanks

 



Edited: 01/10/2014 at 06:59 PM by wipeout01
 01/10/2014 07:40 PM
User is offline View Users Profile Print this message

Author Icon
black_zion
Nanotechnology Guru

Posts: 11577
Joined: 04/17/2008

And when you click on the direct link I posted for the package?

-------------------------
ASUS Sabertooth 990FX/Gen3 R2, FX-8350 w/ Corsair H60, 8 GiB G.SKILL RipjawsX DDR3-2133, XFX HD 7970 Ghz, 512GB Vertex 4, 256GB Vector, 240GB Agility 3, Creative X-Fi Titanium w/ Creative Gigaworks S750, SeaSonic X750, HP ZR2440w, Win 7 Ultimate x64
 01/10/2014 08:25 PM
User is offline View Users Profile Print this message

Author Icon
wipeout01
Peon

Posts: 6
Joined: 09/05/2012

Originally posted by: black_zion And when you click on the direct link I posted for the package?

Says the download cannot be completed.

I tested this in 2 different computers, one of them, recently formated and with a Windows 8.1 running, the other, my desktop computer, with Windows 7 64 bits running and all the updates.

I finally downloaded the drivers USING TOR, WITH AN IP FROM GERMANY AND ENTERING IN THE AMD WEBSITE FROM SPAIN...

Seems to be AMD server is rejecting the connection from some countries, so if you are living in Spain, you cannot download it. You need a foreign country IP to access the drivers.

Quite weird.

I really need someone from AMD check out this urgently, because I don't know if this is a global issue or if it is affecting some countries.

 01/10/2014 11:09 PM
User is offline View Users Profile Print this message

Author Icon
black_zion
Nanotechnology Guru

Posts: 11577
Joined: 04/17/2008

There's always the best third party site, FileHippo. Download here that is the 64 bit package for Vista, 7, 8, and 8.1.

-------------------------
ASUS Sabertooth 990FX/Gen3 R2, FX-8350 w/ Corsair H60, 8 GiB G.SKILL RipjawsX DDR3-2133, XFX HD 7970 Ghz, 512GB Vertex 4, 256GB Vector, 240GB Agility 3, Creative X-Fi Titanium w/ Creative Gigaworks S750, SeaSonic X750, HP ZR2440w, Win 7 Ultimate x64
 01/11/2014 01:04 PM
User is offline View Users Profile Print this message

Author Icon
wipeout01
Peon

Posts: 6
Joined: 09/05/2012

hi, thanks, I got the drivers already

however I think someone from AMD should take a look to this, now, we are not talking about the drivers, just about the website, it's not working...

where may I report this?

Statistics
80952 users are registered to the AMD Support and Game forum.
There are currently 4 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.