Topic Title: AMD R9 270 | Unable to install "Multimedia Controller"
Topic Summary: AMD Catalyst Installs, but left with one Unidentifiable Device on the Video Card.
Created On: 01/11/2014 04:10 PM
Status: Post and Reply
Linear : Threading : Single : Branch
<< 1 2 Previous Last unread
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 02/15/2014 11:54 PM
User is offline View Users Profile Print this message

Author Icon
WarChild007
Peon

Posts: 9
Joined: 01/18/2014

The retailer are going to swap it for the MSI card.

 07/09/2014 09:30 AM
User is offline View Users Profile Print this message

Author Icon
Mototrick
Peon

Posts: 2
Joined: 07/09/2014

Hate to drag up an old topic, but did anyone manage to get a fix for this problem? I have it too, XFX R9 270 on an ASUS Maximus VII Ranger with an Intel i54670K CPU.

 

 07/09/2014 08:12 PM
User is offline View Users Profile Print this message

Author Icon
KissSh0t
Peon

Posts: 15
Joined: 01/11/2014

I was told by XFX to return my video card to the retailer I purchesed it from.

Which I decided was too much hasle.

I just disable the "Multimedia Controller" via the device manager.

So basically XFX sold us cards with a bug..

I will be getting another brand in the future.

 07/10/2014 11:06 AM
User is offline View Users Profile Print this message

Author Icon
Mototrick
Peon

Posts: 2
Joined: 07/09/2014

Thanks for the reply.

I figured as much. I've submitted a bug report to AMD and filed a ticket with XFX, but i'm not expecting any miracles.

Great way to loose customers XFX.

Statistics
84900 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.