Topic Title: Please Help me :(
Topic Summary:
Created On: 01/11/2014 09:09 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 01/11/2014 09:09 PM
User is offline View Users Profile Print this message

Author Icon
thuoclano12
Peon

Posts: 2
Joined: 01/11/2014

I bought a vga named Gigabyte AMD RADEON HD 5570 1GB DDR3

I've been running AMD Driver Autodetect file but it can not find the driver and error out (we were Unable to Find Your product or os). Now I can run drivers?

Driver of GIGABYTE or AMD?

http://www.gigabyte.com/products/product-page.aspx?pid=4093#dl

http://support.amd.com/en-us/download

Thank you for helping. ^^

 01/11/2014 09:19 PM
User is offline View Users Profile Print this message

Author Icon
WMudrockJr
Overclocker

Posts: 705
Joined: 04/01/2013

For Windows 7 and up use this link, as autodetect really doesn't work.

http://sites.amd.com/us/game/downloads/pages/downloads.aspx

Otherwise use this link to pick your driver.

http://www.oldapps.com/ati.php



-------------------------

AMD A10-5800K, XFX 7850 Ultra OC Edition 975MHz, 16GB RAM, Win 8.1 Pro 64 bit, MSI 7778 motherboard, 500W PSU, HP P7-1235, CCC 13.12 WHQL

Statistics
88806 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.