Topic Title: R9 280X Toxic : Artifacts, flckering, crashes (new build)
Topic Summary:
Created On: 01/28/2014 07:30 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 01/28/2014 07:30 PM
User is offline View Users Profile Print this message

Author Icon
kokorochin
Peon

Posts: 1
Joined: 01/28/2014

Hey guys,

So I bought a R9 280X Toxic two weeks ago along with my brand new rig. It got tremendous reviews everywhere so I decided to break the bank and get it despite my low budget. So here's the problem :

 

Out of the box, no overclocking no nothing, had artifacts, flickering, black shapes, crashes, all both in 3D applications as well as in 2D desktop/web browsing.

I tried many different drivers, tried to underclock, tried to up the voltage. No success. After 10** hours of trying various things, I sent the card back. RMA.

 

Today I just received the replacement card, and exactly the same issues are happening. Tried many drivers but no change (including the Catalyst 13.30). As soon as I start Furmark, the display goes out of control after a while, and if it doesn't, the application simply crashes after a while. In 3DMark and games, same things. Some games even crash 2 minutes in. Actually web browsing and desktop are fine, before you start any 3D application. But after display becomes corrupted in 3D applications or benchmarks, then 2D will be damaged and corrupted until the computer is rebooted.

 

(Card never goes over 80°c - everything is normal on that department)

 

I sent a ticket to Sapphire, but honestly I don't know what to do. I'm really sad and angry. My build is brand new and I haven't even been able to enjoy it yet. 2 weeks since I got the part, already one card sent back... Now this... 

 

What should I do, send back the card and go for another brand ? I doubt Sapphire will magically find a solution to this problem.

Some are saying it's the PSU, other that it's the motherboard...

 

My specs :

 

i5 4670K

MSI Z87-G43

CM V550S

Ripjaws 14900 8Gb

Samsung 840 Evo

Windows 7 - 64 Bits

Core stocks on everything

 01/30/2014 12:17 PM
User is offline View Users Profile Print this message

Author Icon
columbosoftserve
Peon

Posts: 8
Joined: 08/07/2012

I am experiencing the exact same thing.

My specs:

i7 4770

Gigabyte H87M-D3H

Gigabyte R9 280x Windforce (came with BF4)

Thermaltake Smart Power 750W 80 Plus Bronze

Patriot-S 1600MHz 8GB

Seagate Barracuda 1TB

Windows 8.1 64 Bit

 

Using any of the 13.11 WHQL, betas and 13.12 WHQL driver sets gives me these issues.

 02/25/2014 03:37 PM
User is offline View Users Profile Print this message

Author Icon
gtriantafyllakis
Peon

Posts: 1
Joined: 02/25/2014

i have the same problem but i ask  for my saler to check the cart and he says its ok! have eny resolve this proplem?

 02/26/2014 03:18 AM
User is offline View Users Profile Print this message

Author Icon
jznightmare
Peon

Posts: 1
Joined: 02/26/2014

same issues for me, texture flickering between right and wrong textures, shard like rays of textures, z-fighting ( checkerboards) etc.

im on my 2nd 280x toxic, the first one i rma'ed because it had the same issues as the 2nd card. now after a month of trying a lot of things i still have the same problems as the first one. 

overclocking, underclocking, overvolting, undervolting with trixx, AB, evga precision has no effect.

changing cables, tinkering with catalyst settings, no effect. 

my list of possible solutions is running very dry now.

ive tried 13.4, 13.6, 13.10, 13.12, 14.1beta and 14.2beta, the problem is still there. 

max temp ive reached through gaming (AC4,NFS:rivals,witcher2, bioshock infinite) is around 70-73 celcius. around 75-76 with 3dmark, unigine heaven,valley. idle is at 35 celcius. my computer is around 10months old. My previous video card, sapphire 6850 did not have any kind of issue whatsoever and its almost 4 yrs old and still working very well.

 

i fear that if i rma this thing, the next one i get will have the same symptoms...

 

 

 

 



-------------------------

i7-3770 | AsRock Z77 Extreme 6 | Gamaxx 400 | Kingston DDR3 1600mhz 2 x 8GB | Sapphire R9-280x Toxic | Intel 335 SSD 180gb | WD Blue 500gb |
Thermaltake Smart 630W | Samsung SH-222 DVD Writer | Samsung S23A300B | Logitech Z506



Edited: 02/26/2014 at 03:25 AM by jznightmare
 10/26/2014 09:48 PM
User is offline View Users Profile Print this message

Author Icon
kari.mueller
Peon

Posts: 1
Joined: 10/26/2014

I'm having the same problem with my card as well... i dont suppose theres been any recent updates since it appears to be a problem thats been going on for awhile. .  im in the process of probably sending mind back 

Statistics
88855 users are registered to the AMD Support and Game forum.
There are currently 0 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.