Topic Title: Black screen after reinstalling windows + graphic drivers (Radeon 6370M)
Topic Summary:
Created On: 02/10/2014 05:08 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 02/10/2014 05:08 PM
User is offline View Users Profile Print this message

Author Icon
Meskalyn
Peon

Posts: 1
Joined: 02/10/2014

Hello,

I'm having a problem with my graphic card. I reinstalled Windows on my friend's computer and after trying to install the drivers for the graphic card (the Catalyst Software Suite on this link http://support.amd.com/fr-fr/download/desktop?os=Windows+7+-+64), computer reboots and nothing is displayed but a black screen (I hear Windows's sound when launching the desktop, so the computer is well started, just no display). What do I miss here ? Notice that I tried doing all Windows updates before installing the graphic drivers. I've been googling for a solution for two days, still can't find how to fix this. 


Thanks for everyone who'll help me.

 

Windows : 7 Familial Premium
Graphic Card : HD Radeon 6370M

 02/10/2014 06:12 PM
User is offline View Users Profile Print this message

Author Icon
Frostbeast
Peon

Posts: 4
Joined: 02/08/2014

I have the same problem. I can avoid the problem by installing an older driver from dezember. I can use it without blackscreen at booting but the old driver has no mantle support.

Dont ask me which driver i use. It wont work on all pcs. Just try the older ones for yourself.

 02/21/2014 12:42 PM
User is offline View Users Profile Print this message

Author Icon
dhoeffn
Peon

Posts: 1
Joined: 02/21/2014

I have the same issue. I am installing on an ASUS X52J Laptop with the HD 6370M 512MB card.

 

When it updates to the decemeber 2013 driver the LCD on the laptop goes blank, but if I hook up an LCD to the HDMI adapter it is working fine.

I played around with all of the res settings and never can get the LCD screen to come back on. I believe the adapter is not comunicating with the LCD backlight properly as I can see something barely going on the laptop screen as if it is working but is not lighted.

 

As the driver that comes pre-installed has some performance issues (driver dated 11/2010), I found a driver on the ASUS website from 3/2011 that works better.

 

The 12/2013 driver works really great performance wise besides the issue with the laptop LCD, so I hope they update this soon.

 

Please submit a bug with the online submission and detail your specs so they can update this issue faster.

 02/21/2014 03:53 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7859
Joined: 11/13/2009

Originally posted by: Meskalyn Hello,

I'm having a problem with my graphic card. I reinstalled Windows on my friend's computer and after trying to install the drivers for the graphic card (the Catalyst Software Suite on this link http://support.amd.com/fr-fr/download/desktop?os=Windows+7+-+64), computer reboots and nothing is displayed but a black screen (I hear Windows's sound when launching the desktop, so the computer is well started, just no display). What do I miss here ? Notice that I tried doing all Windows updates before installing the graphic drivers. I've been googling for a solution for two days, still can't find how to fix this. 

Thanks for everyone who'll help me.

 

Windows : 7 Familial Premium Graphic Card : HD Radeon 6370M

You have a mobility graphics chip in a desktop computer? What is the make and model of the computer?




-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *AMD R9 290 4gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit 


***** cetera fallunt, ludere mortuus ******

 12/08/2014 07:22 PM
User is offline View Users Profile Print this message

Author Icon
Magmar
Peon

Posts: 3
Joined: 12/08/2014

I reUP this message because I have a similare problem

I had problem lauching a  game and of the proposed solution was updating the driver.

I updated to the 14.9 and I had a problem of black screen then I tried 14.11.2 Beta and it was the same. 

I also think its a backlight probleme

I have a ASUS  X52J modele KJ52JT with the AMD Radeon HD 6370M with windows 7 family

 

 12/08/2014 07:50 PM
User is offline View Users Profile Print this message

Author Icon
Alphonse386
Peon

Posts: 4
Joined: 12/08/2014

hey, you may get some clue by reading this: http://www.official-drivers.com/articles/Update-Drivers-for-AMD-Radeon-HD-6350

hope this could help

 12/08/2014 08:38 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7859
Joined: 11/13/2009

I don't know why you guys can't post in the correct forum. There is a laptop forum for laptop issues. If you would have looked in this forum, you would see this.

Asus black screen



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *AMD R9 290 4gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit 


***** cetera fallunt, ludere mortuus ******



Edited: 12/08/2014 at 09:02 PM by stumped
 12/08/2014 10:21 PM
User is offline View Users Profile Print this message

Author Icon
Magmar
Peon

Posts: 3
Joined: 12/08/2014

sory for posting in the wrong place and thank you for pointing the wright place to search for answer

 12/17/2014 10:37 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7859
Joined: 11/13/2009

Originally posted by: Alphonse386 hey, you may get some clue by reading this: http://www.official-drivers.com/articles/Update-Drivers-for-AMD-Radeon-HD-6350

 

hope this could help

 

SPAMMER SPAMMER



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *AMD R9 290 4gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit 


***** cetera fallunt, ludere mortuus ******

Statistics
89079 users are registered to the AMD Support and Game forum.
There are currently 0 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.