Topic Title: AMD Display port 1.2 MST does not work. No "4k" support.
Topic Summary:
Created On: 02/15/2014 04:24 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 02/15/2014 04:24 PM
User is offline View Users Profile Print this message

Author Icon
ennss
Peon

Posts: 5
Joined: 02/08/2014

Can anyone report a fully working "4k" 60hz displayport system?

Please report detailed specs. on your system ( monitor model, version, graphics card, bios, etc.) if you DONT have symptoms such as:

 

About half the time, the monitor will not properly resume from the computer being asleep, or from a warm or cold reboot of the system. i.e.  The monitor will need to be powered off and powered back on for the display to resume, and/or the display will resume in an incorrect resolution and the AMD catalyst video card drivers will display one of the following messages:

1)   "The system as detected a problem with the connection between your computer and the displayport display the will prevent you from using the highest resolutions and/or refresh rates..."

or

2) "The system has detected and link failure and cannot set the requested resolution on your displayport display..."


Since the display will often be blank during reboot (no BIOS messages displayed, monitor power-off/power-on required), before windows has started, it does not have anything to do with Windows, drivers or any other software.  This points to a hardware and/or firmware/video card bios issue between the video card and monitor.   Correct DP 1.2 communication is not occuring consistently.

I am waiting for the arrival of a new accell displayport 1.2 cable that I've ordered to see if that helps.

Please advise if this GPU/bios have been tested with this monitor to work correctly using 3840x2160 60hz, DP 1.2.

Please advise if there is a video bios update available to address this issue.

Please advise what other steps I can take to resolve the issue.

Thanks!  

 

 02/15/2014 05:21 PM
User is offline View Users Profile Print this message

Author Icon
Vegan
Elite

Posts: 1175
Joined: 01/31/2010

given its early in the curve for 3820x2160 I epect it may be not until the upcoming holidays before more gear comes to market

HDMI 2.0 is definied, but no video card yet supports it not does any panel.

DisplayPort 1.2 which we both have should be able to provide 4K60 but the ReDeon cards I have are only low end cards.

My GTX 660 Ti has DisplayPort and so does my panel.

Now it is possible cables are not up to par, check the vendor's literature close.

 

 



-------------------------

 02/19/2014 12:35 PM
User is offline View Users Profile Print this message

Author Icon
karopi
Peon

Posts: 1
Joined: 02/19/2014

I have the same problem as ennss. My monitor is Dell UltraSharp UP2414Q  and the card is PowerColor AX7770 1GBD5-PP2DH.

In Dell manul, it said :

To display 3840 x 2160 at 60 Hz:

1.   The DisplayPort source graphics card must be DP 1.2 certified with HBR2 feature capable of supporting resolution up to 3840 x 2160 at 60 Hz and its driver must support Display ID v1.3.This monitor supports DP 1.2 with HDCP1.3 content protection.

I want to know if the AMD driver support Display ID v1.3.

 02/19/2014 03:36 PM
User is offline View Users Profile Print this message

Author Icon
jcwild
Peon

Posts: 25
Joined: 08/27/2013

I have 7990 working fine with DP1.2 on UP3214Q @ 4k 60Hz, other than my power on/off issue (see other thread).

 02/19/2014 11:40 PM
User is offline View Users Profile Print this message

Author Icon
ennss
Peon

Posts: 5
Joined: 02/08/2014

Originally posted by: karopi I have the same problem as ennss. My monitor is Dell UltraSharp UP2414Q  and the card is PowerColor AX7770 1GBD5-PP2DH.

 

In Dell manul, it said :

 

To display 3840 x 2160 at 60 Hz:

1.   The DisplayPort source graphics card must be DP 1.2 certified with HBR2 feature capable of supporting resolution up to 3840 x 2160 at 60 Hz and its driver must support Display ID v1.3.This monitor supports DP 1.2 with HDCP1.3 content protection.

I want to know if the AMD driver support Display ID v1.3.

 

 

 

On the powercolor web site, it does not say that that card has DisplayPort 1.2.

Are you sure that your card is capable of "DisplayPort 1.2 with MST" ?

 

Statistics
84661 users are registered to the AMD Support and Game forum.
There are currently 5 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.