Topic Title: [MSI R9 270x] Glitching Blocks
Topic Summary: Not properly functioning R9 270x
Created On: 03/21/2014 03:20 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 03/21/2014 03:20 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 1
Joined: 03/21/2014

Hello, I have assembled a PC 2 days ago and everything is working except for the graphics card. It is acting up... 

Graphics Card
It's the MSI R9 270x Gaming 2G

AMD Catalyst Driver Version, and Driver History
I tried:

- The drivers from the MSI website.
- AMD Catalyst 13.12 
- AMD Catalyst 14.3 Beta

Operating System
Windows 7 64 bit with all the latest updates.

Issue Details
Whenever I play a game for a while and sometimes even pretty quickly I get these "blocky: spots on my display. I have a YouTube video that shows the specific glitch:

At first I only noticed these in TrackMania 2, resulting into a BSOD once. Then after playing Just Cause 2 for about 15 minutes it also occured in there.

I have ran a couple of benchmarks to check if there are temperature issues. During the Valley Benchmark in 1920x1200 and on Extreme HD the heat goes up to about 65 degrees Celsius but never goes further than that. I noticed during the 2nd half of the benchmark that there was a flashing white square at the bottom of my display.

Today I ran the MSI Kombustor "Fur" Benchmark. This would drive the temperature up to about 70-75 degrees and after it reached 60 degrees it started showing these same blocky glitches on my desktop. 

Motherboard or System Make & Model
ASRock B85 Pro4

Power Supply

SeaSonic S12II 520W

Display Device(s) and Connection(s) Used
Dell U2412M connected trough DVI

Applications and Games

Just Cause 2
TrackMania 2 Canyon
Valley Benchmark
Fur Benchmark

CPU Details
Intel i5 4570 at 3.2 GHz (stock clock speeds, nothing overclocked)

Motherboard BIOS Version
Newest version, I guess. I tried to update it in the BIOS menu. It says "no new versions available" so version 2.00

System Memory Type & Amount
8 GB Crucial Ballistix Sport

Additional Hardware
Crucial M500 120 GB SSD as boot drive
Western Digital Blue 1 TB as hard drive

Additional Details
Nothing I can think of.

 06/26/2014 08:34 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 1
Joined: 06/26/2014

Have you already found a solution? I am experiencing the same issues with same MOBO and GPU...

 06/26/2014 10:21 PM
User is offline View Users Profile Print this message

Author Icon
Recompile The World

Posts: 2856
Joined: 11/14/2010

Check the vrm temps of that card with AIDA64, but it seems like a bad vram or bad gpu chip.

Test your RAM with memtest as well.


Unless of course you can test another card to see if you have a bad or insufficient PSU.

If you can, rma your gpu and get a new one.


gigabyte X58A-UD3R rev.2, core i7 975 3.9ghz (stock voltage), windows 8.1 64-bit, corsair 12gb DDR3 1600mhz 7-7-7-20 RAM, xfx HD 5970 + gigabyte HD 5970 (950mhz/ 1100mhz), coolermaster ultimate 900w PSU.
AMD Catalyst 15.4 beta

92815 users are registered to the AMD Support and Game forum.
There are currently 4 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.