Topic Title: Sapphire R9 270x 4.0 GB GDDR5 with boost & OC screen flickering problem.
Topic Summary:
Created On: 03/31/2014 11:22 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 03/31/2014 11:22 AM
User is offline View Users Profile Print this message

Author Icon
Tuuube
Peon

Posts: 2
Joined: 03/31/2014

I get random flickers, in games, in normal internet browsing, even with idle. Sometimes it happens as often as 5 times a minutes, and some times it happens once an hour. Here's the video: ttps://www.youtube.com/watch?v=AmFCx7mgJoY

If I using default preferences in AMD overdrive I get the grey screen of death.

Here's my GPU-Z screenshot:

With underclocking I can run apps without flickers and glitches, but performance is getting low. 

I found some solution for similar GPU here and they are all for 2 gb cards. I am using the latest beta catalyst driver 14.3 beta windows 7 x64 build. It looks like something weird going on with VDDC or AMD PowerPlay.

My specs: 

  • GPU: Sapphire R9 270x 4.0 GB GDDR5 with boost & OC
  • CPU: Phenom X3 8450
  • MB: Foxconn M61PMV
  • PSU: Booster Atx-500w
  • SSD: Corsair Force Series GS 128gb
  • RAM: Kingston DDR2 1066 3GB 
 03/31/2014 06:02 PM
User is offline View Users Profile Print this message

Author Icon
Vegan
Alpha Geek

Posts: 1417
Joined: 01/31/2010

That system board is very old and not the best options

That board uses an old NVIDIA chipset, they do not even make them anymore and have not for many years now.

you power supply is another issue, you might want to get a more modern model as old lower end ones degrade over time.

 



-------------------------

Statistics
87535 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.