Topic Title: R9 270x black screen and at game start
Topic Summary:
Created On: 04/10/2014 06:55 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 04/10/2014 06:55 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 1
Joined: 04/10/2014

Hi guys, I'm having a little bit of problem with my r9 270x and would greatly appreciate any assistance.

Please excuse my English, as it's not my native.

When starting certain games, my screen would go black and there's nothing I could do aside from a hard reboot.
The issue would only happen when I started certain games with HDMI.

When I use VGA instead of HDMI, the games works flawlessly. Tried two different monitors with HDMI at 1080p resolution and both ended up with a black screen at game start.

Does anyone know what went wrong and is there anything I could do to resolve this issue? Please find below my PC specifications and other informations related to the issue.


AMD Catalyst Package: 14.3 Beta (Clean install)
Proc: AMD FX-8320 (Factory setting)
Mobo: Gigabyte GA-970A-D3P
GPU: Sapphire R9 270X 2Gb Dual X (Elpdia) (Factory setting)
Memory: 8Gb PC15000
HDD: 1Tb
Power: SeaSonic M12II-520
OS: Win 7 64 

Games that doesn't work with HDMI but worked fine with VGA cables:

Saints Row IV
7 Days to Die

Games that are working fine with either HDMI or VGA:

AC: Black Flag
Space Engineer
Splinter Cell: Black List
Far Cry 3 


Please let me know if you know something that I should try.
Thank you, I appreciate your time



Edited: 04/10/2014 at 07:47 AM by Jams
93040 users are registered to the AMD Support and Game forum.
There are currently 0 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.