Topic Title: Radeon HD7670 Catalyst software not installing packages
Topic Summary: Even did it on the first installation of a fresh OS install
Created On: 04/17/2014 09:18 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 04/17/2014 09:18 PM
User is offline View Users Profile Print this message

Author Icon
nikaido
Peon

Posts: 3
Joined: 04/17/2014

HP Pavilion m9340f
Mobo: Asus IPBL-LB
Bios Ver: 5.43
Processor: Intel Core 2 Quad Q6700 (2.66Ghz)
Memory: 8GB DDR2 (800Mhz)
Video: AMD Radeon HD7670
PSU: 600W Corsair
OS: Windows 7 Professional (64-bit)

The problem I'm having is the fact that the Catalyst install software is not able to install the packages and the video driver (the HDMI audio driver installs fine). I have already made sure that I have .Net Framework 4.5 and the latest C++ distribution installed. The "Action Center" is able to install the driver without any problems (which plays Bioshock fine), though I have no Catalyst Control Center. I've tried uninstalling the drivers themselves (since I don't have the catalyst software) using both the Catalyst setup application and the device manager and then reinstalling using the setup but to no avail I cannot get the control center to install.

Software Version:
Display Driver ver. 13.251
OpenCL(tm) Driver ver. 10.0.1348.5
Catalyst Control Center ver. 2013.1206.1602.28764

LOG:
Hardware information
Name                                       AMD Radeon Graphics Processor
Manufacturer                           Advanced Micro Devices, Inc.
Device ID                                 0x675b
Vendor ID                                0x1002
Class Code                              0x030000
Revision ID                              0x00
Subsystem ID                          0x6888
Subsystem vendor ID              0x103c

Packages for install
AMD Catalyst Install Manager
Final Status:                            Fail
Version of Item:                      8.0.915.0
Size:                                       20Mbytes

HDMI Audio Driver
Final Status:                           Success
Version of Item:                     7.12.0.7707
Size:                                      1Mbytes

Other detected devices
Manufacturer                         Advanced Micro Devices, Inc.
Device ID                               0xaa90
Vendor ID                              0x1002
Class Code                            0x040300
Revision ID                            0x00
Subsystem ID                        0xaa90
Subsystem vendor ID            0x103c

Error Messages
Application Install: install package failure!

I'm at my wits end with this thing...



Edited: 04/17/2014 at 09:31 PM by nikaido
 04/17/2014 10:46 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7250
Joined: 11/13/2009

To perform a 'clean install' of AMD graphics drivers:

1. IMPORTANT: All Windows Updates should be current, including the 'optional/suggested' updates
2. IMPORTANT: Disable all anti-virus/ad blockers/anti-malware/ anti-anything before trying to install
3. IMPORTANT: Netframework is required and must be the latest version. (from Windows Update)

Create a system restore point before, just in caes.

Download the drivers for your computer to the desktop. Follow steps 1-5 ( http://support.amd.com/en-us/download ).
 Do not use 'auto-detect and install.

Delete existing drivers from your computer:

In computer control panel select 'uninstall a program'
For computers with Intel processors:
Select AMD install manager and choose 'express uninstall all AMD software'
Including the install manager.

For computers with AMD processors:
Select AMD install manager and 'custom uninstall' the graphics drivers and CCC only.

Reboot into 'safe mode'
In safe mode run Driver Fusion  http://treexy.com/ (free version).
Select AMD graphics, analyse and delete all it finds.

Reboot

Install the new driver suite.

 



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 * A clear conscience is usually a sign of bad memory *

 04/18/2014 01:15 AM
User is offline View Users Profile Print this message

Author Icon
nikaido
Peon

Posts: 3
Joined: 04/17/2014

Tried all your suggestions and still doesn't want to work (same log info). Now Action Center won't install the drivers, it just installs a generic VGA adapter driver (I'm just using it as a fall back, it's not on while installing from Catalyst setup). 

EDIT: Got Action Center to work again, but still no legway with the Catalyst install.



Edited: 04/18/2014 at 01:25 AM by nikaido
 04/18/2014 06:48 AM
User is offline View Users Profile Print this message

Author Icon
UcouldBrong
Case Modder

Posts: 801
Joined: 01/05/2013

Try to start install quickly when rebooting before Windows detects that there are no drivers installed...



-------------------------

 


 


Non-noob components.

 05/10/2014 12:30 AM
User is offline View Users Profile Print this message

Author Icon
nikaido
Peon

Posts: 3
Joined: 04/17/2014

*bump

I decided to wait till 14.4 released to try again. I did everything on the list; turned off auto detect & install, used Driver Fusion, uninstalled & reinstalled the latest .NET Framework, & turned off all my protective software during install; but it still gives me failures. Now it's not even installing the audio driver (thank god for the restore point). Thinking it was a problem with my mobo chipset I checked to make sure it was compatible. According to pc-specs.com the Asus IBIPL-LB mobo is compatible. 

So thinking that the windows OS was corrupted I tried to install the Linux driver in Mint 16 Petra. Well apparently the .run file gives me an "Unsupported device" message. And yes, I uninstalled xserve and the other amd drivers that mint provides before installing.

I just can't believe that this GPU is screwed up since it plays Bioshock (High settings), Mass Effect (Ultra High settings), and GTA IV (Medium settings) perfectly using the windows supplied driver (8.960.11.2000)



Edited: 05/10/2014 at 01:18 AM by nikaido
Statistics
85507 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.