Topic Title: Radeon HD 7750 (Help a tech-impaired casual gamer out?)
Topic Summary: Need help with installation. Weird beeping noise and monitor says no signal.
Created On: 04/20/2014 09:47 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 04/20/2014 09:47 AM
User is offline View Users Profile Print this message

Author Icon
Ender
Peon

Posts: 3
Joined: 04/20/2014

HP 500-097

Windows 8 64 bit

DirectX 11

 

I'm currently trying to install the Radeon HD 7750 video card I got and everything seems to go fine until I turn on my computer.

I made sure to disable the on-board video card then i inserted the new video card, plugged my monitor into it, started up my computer and theres where things got weird.

It made 3-4 beeping noises and the power symbol flashed as if it was on sleep mode. The monitor is working but when it started up it just said "no signal". Then the beeping stopped and the power button stayed lit up and it sounded like it was running just fine, I just can't get a display.

 

What am I doing wrong?

 04/20/2014 10:20 AM
User is online View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7040
Joined: 11/13/2009

To perform a 'clean install' of AMD graphics drivers:

1. IMPORTANT: All Windows Updates should be current, including the 'optional/suggested' updates
2. IMPORTANT: Disable all anti-virus/ad blockers/anti-malware/ anti-anything before trying to install
3. IMPORTANT: Netframework is required and must be the latest version. (from Windows Update)

Create a system restore point before, just in caes.

Download the drivers for your computer to the desktop. Follow steps 1-5 ( http://support.amd.com/en-us/download ).
 Do not use 'auto-detect and install.

Delete existing drivers from your computer:

In computer control panel select 'uninstall a program'
For computers with Intel processors:
Select AMD install manager and choose 'express uninstall all AMD software'
Including the install manager.

For computers with AMD processors:
Select AMD install manager and 'custom uninstall' the graphics drivers and CCC only.

Reboot into 'safe mode'
In safe mode run Driver Fusion  http://treexy.com/ (free version).
Select AMD graphics, analyse and delete all it finds.

Reboot

Install the new driver suite.

 



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

 04/21/2014 06:59 PM
User is offline View Users Profile Print this message

Author Icon
Ender
Peon

Posts: 3
Joined: 04/20/2014

Thanks for your reply.

I tried out the instructions you gave but I was still met by the monitor displaying "no signal" and the beeping noise.

(Although this time I counted, there were exactly 6 beeps, if that has anything to do with this.)

 04/22/2014 11:45 AM
User is offline View Users Profile Print this message

Author Icon
Slayerx
Button Masher

Posts: 265
Joined: 09/16/2012

If your getting beeps and the power button is flashing means that theres something really wrong with either the video card or your motherboard.

 

Now you said your getting six beeps, is the power button blinking six times too?

 

If it is then theres something really wrong with the video card.



-------------------------

FX 8320// Asus Sabertooth R2.0 // HIS R9 280x //8Gb of 1866Mhz ram, H50 cooling, HX850W psu all stuffed into a NZXT Phantom case.


Was a member of AMD Processer forum since 2008. Last post count 1818.

 04/22/2014 06:38 PM
User is offline View Users Profile Print this message

Author Icon
Ender
Peon

Posts: 3
Joined: 04/20/2014

Yes the power button did flash that many times too.

There's a five year warranty on it, so is the problem something I should just send the card back and get a new one?

Statistics
84198 users are registered to the AMD Support and Game forum.
There are currently 8 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.