Topic Title: Has AMD trouble with his drivers (Especially 14.4) ?
Topic Summary:
Created On: 04/26/2014 07:27 PM
Status: Post and Reply
Linear : Threading : Single : Branch
1 2 Next Last unread
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 04/26/2014 07:27 PM
User is offline View Users Profile Print this message

Author Icon
TypeOverride
Grinding Levels

Posts: 117
Joined: 04/26/2014

I asked myself if AMD has much trouble with his drivers. Ive bought my first AMD graphic card and will get it next week.

But i see here trouble here and trouble there. Especially with the 14.4 driver.

Will i have such troubles too ? i get a Sapphire R9 280x.



-------------------------

[Int Core i7-2600K]
[Asus P8P67 EVO]
[2x Corsair D3 4GB 1333-999 XMS]
[750 Watt]
[NEW Sappihre R9 280x Dual-X OC] - Blue Screen by AMD kernel mode driver
[Windows 7 64-bit]

 04/26/2014 07:35 PM
User is offline View Users Profile Print this message

Author Icon
Practikill
Grinding Levels

Posts: 114
Joined: 08/07/2009

There seems to be a lot of issues, only because those without issues don't come here to say how well it works.

I have been with ATI/AMD for many years, and have never had a serious issue. Not to promise you won't, but that is my experience.



-------------------------
 04/26/2014 07:47 PM
User is offline View Users Profile Print this message

Author Icon
TypeOverride
Grinding Levels

Posts: 117
Joined: 04/26/2014

Originally posted by: Practikill There seems to be a lot of issues, only because those without issues don't come here to say how well it works.

 

I have been with ATI/AMD for many years, and have never had a serious issue. Not to promise you won't, but that is my experience.

 

 

yeah true.

I hope my brand new start with AMD ends not in much problems.



-------------------------

[Int Core i7-2600K]
[Asus P8P67 EVO]
[2x Corsair D3 4GB 1333-999 XMS]
[750 Watt]
[NEW Sappihre R9 280x Dual-X OC] - Blue Screen by AMD kernel mode driver
[Windows 7 64-bit]

 04/26/2014 09:04 PM
User is offline View Users Profile Print this message

Author Icon
QB the Slayer
Master Looter

Posts: 329
Joined: 11/27/2012

I have never had issues with ATI/AMD graphics in my 15+ years using them (First was either a Rage Pro or Rage Pro 128, it's so long ago I can't remeber for sure)...  same can be said with my 11ish years of AMD CPU's (First was a Athlon XP 2600+ Barton).

 

QB



-------------------------

The MONSTER HTPC:

CPU: AMD FX-8350.||.Cooler: Corsair H80i
MB: Gigabyte 990FXA-UD7.||.RAM: 8 GB Mushkin Blackline DDR3 2000MHz (7-10-8-27-1T)
Case: CoolerMaster HAF 932.||.PSU: Corsair HX750
GPU:Asus R9 270X DirectCU II TOP.||.Audio: Creative X-Fi Titanium Fatal1ty Pro w/ Logitech Z-5300e (5.1, 280W-RMS)
System Drive: 2xSamsung 840 Pro 128GB RAID0.||.Working Drive: 2xMushkin Chronos 60GB RAID0



Edited: 04/26/2014 at 09:20 PM by QB the Slayer
 04/27/2014 11:49 AM
User is offline View Users Profile Print this message

Author Icon
UcouldBrong
Case Modder

Posts: 804
Joined: 01/05/2013

On several occaisons in the past...drivers needed a reinstall to work properly. 

Can only recall CrossfireX game related issues with COD Ghosts and ARMAIII only.



-------------------------

 


 


Non-noob components.

 04/27/2014 04:02 PM
User is online View Users Profile Print this message

Author Icon
MyMedia59
Overclocker

Posts: 617
Joined: 10/30/2009

mostly overclockers are whingers but's their choice



-------------------------

GA 990FXA-UD3v3
AMD FX-8320
Kingston 8GB 1600 HyperX
GPU Gigabyte R685OC-1GD
1x SSHD ST1000DX001/ 1x SATA3 WD Blue/ 1x STBV2000300
SeaSonic 650W
Win7x64

 04/29/2014 01:04 PM
User is offline View Users Profile Print this message

Author Icon
TypeOverride
Grinding Levels

Posts: 117
Joined: 04/26/2014

So my graphiccard is there.

Plugged in.

Driver installed.

First Windows Reboot -> He is not shuting down the system -> hard power off.

continue....



-------------------------

[Int Core i7-2600K]
[Asus P8P67 EVO]
[2x Corsair D3 4GB 1333-999 XMS]
[750 Watt]
[NEW Sappihre R9 280x Dual-X OC] - Blue Screen by AMD kernel mode driver
[Windows 7 64-bit]

 04/29/2014 01:47 PM
User is offline View Users Profile Print this message

Author Icon
UcouldBrong
Case Modder

Posts: 804
Joined: 01/05/2013

Had mentioned issues with ARMA III previously...just played Developers Version and Crossfire functioning really well...go figure!



-------------------------

 


 


Non-noob components.

 05/04/2014 02:47 AM
User is offline View Users Profile Print this message

Author Icon
TypeOverride
Grinding Levels

Posts: 117
Joined: 04/26/2014

Like ive said before ... continue....

Now i got a blue screen:

Problemsignatur:
  Problemereignisname:    BlueScreen
  Betriebsystemversion:    6.1.7601.2.1.0.256.48
  Gebietsschema-ID:    1031

Zusatzinformationen zum Problem:
  BCCode:    1000007e
  BCP1:    FFFFFFFFC0000005
  BCP2:    FFFFF8800F14ADBB
  BCP3:    FFFFF88003EAF228
  BCP4:    FFFFF88003EAEA80
  OS Version:    6_1_7601
  Service Pack:    1_0
  Product:    256_1

 

Anyone ? Everyone said to me ..dont buy a AMD graphiccard. They are only make problems. But i said nooooo, i give it a new try. Hmmm....



-------------------------

[Int Core i7-2600K]
[Asus P8P67 EVO]
[2x Corsair D3 4GB 1333-999 XMS]
[750 Watt]
[NEW Sappihre R9 280x Dual-X OC] - Blue Screen by AMD kernel mode driver
[Windows 7 64-bit]

 05/04/2014 03:39 AM
User is offline View Users Profile Print this message

Author Icon
Thanny
Alpha Geek

Posts: 1409
Joined: 07/13/2009

That BSOD very likely indicates defective RAM.

 

 05/04/2014 10:57 AM
User is offline View Users Profile Print this message

Author Icon
Slayerx
Button Masher

Posts: 280
Joined: 09/16/2012

I can't say I've never had problems with ATI/AMD cards, had a X1600 just up and die on me once but the X1650 that replaced it lasted for years and I did have some problems with my new 280X locking up but nothing a little tweeking could't fix

As for drivers I can't say I ever had any real problems with, ran into some flaky ones over the years but nothing that coused any real problems.

 

For people who say " don't buy AMD graphic cards they only make problems"

Like nobody has ever had problems with Nvidia cards.



-------------------------

FX 8320// Asus Sabertooth R2.0 // HIS R9 280x //8Gb of 1866Mhz ram, H50 cooling, HX850W psu all stuffed into a NZXT Phantom case.


Was a member of AMD Processer forum since 2008. Last post count 1818.

 05/04/2014 02:13 PM
User is offline View Users Profile Print this message

Author Icon
TypeOverride
Grinding Levels

Posts: 117
Joined: 04/26/2014

Its the internet who says this.

And my first graphiccard where i was young was an ATI, and i had much trouble with the Driver. Than i got 3 Nvidia graphiccards and had not trouble over the whole time. Now i have a AMD and got trouble again.

coincidence ?



-------------------------

[Int Core i7-2600K]
[Asus P8P67 EVO]
[2x Corsair D3 4GB 1333-999 XMS]
[750 Watt]
[NEW Sappihre R9 280x Dual-X OC] - Blue Screen by AMD kernel mode driver
[Windows 7 64-bit]

 05/04/2014 02:14 PM
User is offline View Users Profile Print this message

Author Icon
TypeOverride
Grinding Levels

Posts: 117
Joined: 04/26/2014

Originally posted by: Thanny That BSOD very likely indicates defective RAM.

 

 

 

 

Do you mean graphiccard RAM or mainboard RAM ?



-------------------------

[Int Core i7-2600K]
[Asus P8P67 EVO]
[2x Corsair D3 4GB 1333-999 XMS]
[750 Watt]
[NEW Sappihre R9 280x Dual-X OC] - Blue Screen by AMD kernel mode driver
[Windows 7 64-bit]

 05/04/2014 03:15 PM
User is offline View Users Profile Print this message

Author Icon
Slayerx
Button Masher

Posts: 280
Joined: 09/16/2012

Originally posted by: TypeOverride Its the internet who says this.

 

And my first graphiccard where i was young was an ATI, and i had much trouble with the Driver. Than i got 3 Nvidia graphiccards and had not trouble over the whole time. Now i have a AMD and got trouble again.

 

coincidence ?

 

 

 

I ran into problems when I first installed my 280X too (no BSOD though just froze up) and that was with 13.12 driver and as I said before a little tweeking of the fan control and power settings and its has not done it since.

 

I think Thanny ment your motherboard Ram

you should run a memory test

 

 



-------------------------

FX 8320// Asus Sabertooth R2.0 // HIS R9 280x //8Gb of 1866Mhz ram, H50 cooling, HX850W psu all stuffed into a NZXT Phantom case.


Was a member of AMD Processer forum since 2008. Last post count 1818.

 05/04/2014 03:28 PM
User is offline View Users Profile Print this message

Author Icon
TypeOverride
Grinding Levels

Posts: 117
Joined: 04/26/2014

Originally posted by: Slayerx
Originally posted by: TypeOverride Its the internet who says this.

 

 

 

And my first graphiccard where i was young was an ATI, and i had much trouble with the Driver. Than i got 3 Nvidia graphiccards and had not trouble over the whole time. Now i have a AMD and got trouble again.

 

 

 

coincidence ?

 

 

 

 

 

 

 

 

I ran into problems when I first installed my 280X too (no BSOD though just froze up) and that was with 13.12 driver and as I said before a little tweeking of the fan control and power settings and its has not done it since.

 

 

 

I think Thanny ment your motherboard Ram

 

you should run a memory test

 

 

 

 

 

 

Thanks.

Yeah memory test i already did. All fine.

Hm... i ask myself so hard why AMD has so much trouble with his drivers.



-------------------------

[Int Core i7-2600K]
[Asus P8P67 EVO]
[2x Corsair D3 4GB 1333-999 XMS]
[750 Watt]
[NEW Sappihre R9 280x Dual-X OC] - Blue Screen by AMD kernel mode driver
[Windows 7 64-bit]

 05/04/2014 07:16 PM
User is offline View Users Profile Print this message

Author Icon
Earnhardt
Case Modder

Posts: 882
Joined: 09/11/2008

Been using ATI/AMD since about 2002,don't remember ever having any driver issues either.



-------------------------

AMD Phenom II 1100t @4.0Ghz /Asus sabertooth 990fx/2x Gigabyte 3G 7950's in crossfire/500G samsung 840 ssd/16G G-Skill Ripjaw 1600/2-samsung 24" monitors 1920X1200/Corsair AX1200W psu/W7 pro 64,G19 keyboard,Roccat kone pure mouse,Cooler master HAF932,Corsair H100i water cooler,Zalman ram cooler.Sound Blaster X-Fi Titanium Fatal1ty Champion Series,Logitech Z5500 speakers,Roccat Kave 5.1 headset.

 05/04/2014 09:21 PM
User is offline View Users Profile Print this message

Author Icon
Vegan
Elite

Posts: 1235
Joined: 01/31/2010

I also have used AMD for a long time, and I can certify that I can reproduce problems with some of the drivers

same for NVIDIA

 



-------------------------

 05/04/2014 09:22 PM
User is offline View Users Profile Print this message

Author Icon
black_zion
80 Column Mind

Posts: 12515
Joined: 04/17/2008

Been using ATI/AMD since the Radeon 9600XT days, and the only real problem I had was the entire 11.x series drivers did not work well for me with my HD 5970 for some reason, 10.10e and 12.1 did just fine.

-------------------------
ASUS Sabertooth 990FX/Gen3 R2, FX-8350 w/ Corsair H60, 8 GiB G.SKILL RipjawsX DDR3-2133, XFX HD 7970 Ghz, 512GB Vertex 4, 256GB Vector, 240GB Agility 3, Creative X-Fi Titanium w/ Creative Gigaworks S750, SeaSonic X750, HP ZR2440w, Win 7 Ultimate x64
 05/04/2014 09:34 PM
User is offline View Users Profile Print this message

Author Icon
TypeOverride
Grinding Levels

Posts: 117
Joined: 04/26/2014

So i guess the BlueScreen comes from the graphiccard because the blue screen says something like:

BlueScreen. Blabla and "try changing video adapters"

So how can i make a support ticket ? I have only few days until i make a refund and buy a Nvidia graphiccard. I dont have fun in BlueScreen and such crashes.

 



-------------------------

[Int Core i7-2600K]
[Asus P8P67 EVO]
[2x Corsair D3 4GB 1333-999 XMS]
[750 Watt]
[NEW Sappihre R9 280x Dual-X OC] - Blue Screen by AMD kernel mode driver
[Windows 7 64-bit]

 05/05/2014 12:01 AM
User is offline View Users Profile Print this message

Author Icon
UcouldBrong
Case Modder

Posts: 804
Joined: 01/05/2013

Two options seem apparent:

Give up.  Stop messing with pesky computer components...too much hassle.

Don't give up.



-------------------------

 


 


Non-noob components.

Statistics
85573 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.