Topic Title: PowerColor Radeon R9 280x - Flickering when 2 displays are connected
Topic Summary:
Created On: 05/01/2014 03:45 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 05/01/2014 03:45 AM
User is offline View Users Profile Print this message

Author Icon
Svante
Peon

Posts: 1
Joined: 02/09/2014

Hi,

 

I have some issues with flickering on one screen when I connect two displays. Details below. Thanks for your assistance!

Graphics Card

- PowerColor Radeon R9 280x TurboDuo

- No over-clocking has been done

AMD Catalyst Driver Version, and Driver History
- Catalyst 14.3
- Driver 13.301
- Also tried the previous one that I updated from today

Operating System
- Win7 64bit

Issue Details
- When I have two screens connected, one through HDMI (LG Smart TV 50") and one through DVI (DELL U2312HM) I get flickering in the bottom if the Dell screen. More exactly it only is the area that covers the Start Menu. Separately the screens and outputs work fine, it is just when both are jacked in at the same time.
- include specifics on symptoms, and steps to reproduce the issue
- describe in detail the issue experienced
- for 3D Games, please include details of your in-game graphics settings (ex: Anti-Aliasing, VSync, etc..)
- links to videos or pictures that may demonstrate your issue

Motherboard or System Make & Model
- ASUS H81-PLUS

Power Supply

Corsair CX600M

Display Device(s) and Connection(s) Used
-
DELL U2312HM
- LG Smart TV 50"
- include specifics about any cables, adapters, splitters, hubs, used

CPU Details
- Intel i5-4760K

Motherboard BIOS Version
- ALASKA - 1072009 BIOS Date: 09/03/13 Ver: 06.01

System Memory Type & Amount
- Corsair Vengeance LP 8GB 1600 MHz

 

 05/17/2014 06:57 AM
User is offline View Users Profile Print this message

Author Icon
Jacobb
Peon

Posts: 1
Joined: 05/17/2014

Hi 

Did u fix it?

I have the same card and the same problem.

I can't find any solution 

 05/18/2014 09:31 AM
User is offline View Users Profile Print this message

Author Icon
jimmy1516
Peon

Posts: 3
Joined: 05/18/2014

Hi

I also have the same problem, even with just a single monitor.

I have read that it can be caused by your 2D shader clocks being too low, but I have not got a clue how to resolve it...

I'm using an MSI R9 280x Twin Frozr OC.

 

Hope this helps, and please let me know if you find a way to up the 2D clocks.

*edit*

Solved it. Go to C:\users\(your user)\appdata\local\ati\ace

Open profiles.xml in something like notepad.

Find the following values and replace them with these:

Under the feature named CoreClockTarget change the value of want_0 to 60000

and

Under the feature named MemoryClockTarget change want_0 to 30000

 

Save it and make profiles.xml read only.

Reboot and enjoy.



Edited: 05/18/2014 at 11:42 AM by jimmy1516
 06/08/2014 05:51 AM
User is offline View Users Profile Print this message

Author Icon
nironz
Peon

Posts: 2
Joined: 06/08/2014

It cannot help!!.. play borderlands 2 gpu cannot reach to the top clock, because transision from 2d to 3d.

I Found this will fix your flicker problem..

How to set up MSI AB profiles:

1. Download MSI AB (Latest version). Make sure you include rivatunerstatisticsserver when you install it.
2. Before you do anything go in to settings and set unoficcial overclocking mode to "without powerplay", Restart MSI AB.
3. Enable "reset display mode on applying unofficial oc" , Restart MSI AB.
4. Now that you're back in MSI AB click the reset button, save this profile to 1.
5. Now make another profile, be it oced or not it doesnt matter. Save this to profile 5.
6. Go in to settings and go all the way to the right where it says "profiles".
7. On 2d profiles you use your profile 1. On 3d you use 5.

This will cause your GPU to reset itself and go back to stock thus letting it throttle whenever you're in 2d, it will engage 3d clock whenever you start a game or a benchmark or something.

There are some rogue applications that will trigger the 3d profile, the only one i know of this far is GPUz.

To keep MSI AB from engaging 3d clocks because of rogue apps like GPUz go to RivaTuner Statistics Server. On the left side you can see a bunch of pre listed programs. GPUz isnt there, to make MSI AB ignore GPUz and keep it from engaging 3d profile you must add GPUz here and put application detection level to None. Use the big + icon in the bottom left corner and browse to GPUz and add it, and then put application detection level to None on GPUz.

You can do this to all .exes as far as i know.

This should fix flickering/stuttering, because you're no longer letting your card decide . Its caused by your card being indecisive



-------------------------
Game for Fun..
Statistics
84124 users are registered to the AMD Support and Game forum.
There are currently 4 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.