Topic Title: Sapphire Radeon HD6950 Death Problem?
Topic Summary:
Created On: 05/22/2014 06:59 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 05/22/2014 06:59 PM
User is offline View Users Profile Print this message

Author Icon
LynchyY
Peon

Posts: 1
Joined: 05/22/2014

Hi I was hoping someone could help me. I have a Sapphire Radeon HD6950 and It was working fine untill i took it out of my motherboard and placed it onto my wooden desk to replace my watercooler. When I had replaced my watercooler i placed it back in the motherboard and suddenly it had magically died and i had no display and it wasnt showing in Device Manager. I tried putting it in my friends pc and it still didnt work and its not my PCI-E slot because my friend put his gpu in my computer and it worked fine.

 

Could someone please help me understand how it could have dies if it is even truley dead?

 

Thanks in advance. 

 05/22/2014 08:51 PM
User is offline View Users Profile Print this message

Author Icon
black_zion
80 Column Mind

Posts: 12677
Joined: 04/17/2008

My guess would be that years of heating and cooling worked a component loose, and the act of moving it jarred it loose.

-------------------------
ASUS Sabertooth 990FX/Gen3 R2, FX-8350 w/ Corsair H60, 8 GiB G.SKILL RipjawsX DDR3-2133, XFX HD 7970 Ghz, 512GB Vertex 4, 256GB Vector, 240GB Agility 3, Creative X-Fi Titanium w/ Creative Gigaworks S750, SeaSonic X750, HP ZR2440w, Win 7 Ultimate x64
Statistics
86482 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.