Topic Title: AMD R9 290x 4K Issues (Flickering/Screen Tearing/Switching Off)
Topic Summary: This is an issue I've recently experienced with my new ASUS PB287Q 4K monitor...
Created On: 06/14/2014 11:09 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 06/14/2014 11:09 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 3
Joined: 05/31/2013

Hi there guys,

Just to keep this short and sweet, my R9 290x (R9290X-DC2OC-4GD5) started giving me issues as I installed my new 4K monitor (ASUS PB287Q). Using Display Port 1.2 (of which both devices are compatible) my games seemingly do something weird that I cannot explain, but I took a video of it;

Now that happens in 90% of my games at any resolution above 1080p, which is not my native monitor resolution... I have tried everything I can, but I do not know what else to do...

It is NOT the monitor or cable, as I tried it in my fiances rig, works 100% with a GTX 760, so I'm hoping team RED will patch this one up soon as the demand for 4K rises?

I went into a large indepth conversation if it will help anyone, over at the OC forums;

If anyone has any advice for me that would be GREATLY appreciated!! As the least thing I wanna do is jamming Mount & Blade: Warband at 4k!!

 06/22/2014 06:46 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 3
Joined: 06/21/2014

Im having the same problem. 3x r9 290x and a AOC U2868PQU. Would be nice to get some solid info on why this happens instead of all the speculations online... 

 06/22/2014 02:12 PM
User is offline View Users Profile Print this message

Author Icon
Case Modder

Posts: 822
Joined: 09/11/2008


AMD Phenom II 1100t @4.0Ghz /Asus sabertooth 990fx/2x Gigabyte 3G 7950's in crossfire/500G samsung 840 ssd/16G G-Skill Ripjaw 1600/2-samsung 24" monitors 1920X1200/Corsair AX1200W psu/W7 pro 64,G19 keyboard,Roccat kone pure mouse,Cooler master HAF932,Corsair H100i water cooler,Zalman ram cooler.Sound Blaster X-Fi Titanium Fatal1ty Champion Series,Logitech Z5500 speakers,Roccat Kave 5.1 headset.

 06/22/2014 09:12 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 3
Joined: 06/21/2014

Already made a error report but fine:

Graphics Card
3x Sapphire Radeon R9 290x 4Gb Gddr5 (stock clocks)

AMD Catalyst Driver Version, and Driver History
14.6 beta, pretty much used every prior beta/release driver
Operating System
Win 7 all SP+uppdates

Issue Details 

AOC 28" 4K LED U2868PQU 

Flickering when running 4k res with 60hz(unuseble) trough display port. No flickering when 30hz. Currently running the screen at 2560x1440 @ 60 hz trough dvi without issue. tested 2 dp cables, same issue with both. 

Motherboard or System Make & Model

Power Supply

Corsair AX 1200W PSU

Display Device(s) and Connection(s) Used

AOC 28" 4K LED U2868PQU tested display port 1.2 and Dvi.

Applications and Games

Everything! Windows/games!

CPU Details
Intel® Core i7-3930K Processor @ 4,5 ghz (100x45 1.33V)

Motherboard BIOS Version
Asus 4503 

System Memory Type & AmountCorsair Vengeance DDR3 1600MHz 32GB CL9

Additional Hardware 

2x 120 gb corsair ssd hds (system+games)

4 Tb storage discs

ALOT of case fans

H100i cpu cooler

Additional Details
Has nothing to do with it? 

 06/24/2014 06:13 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 18
Joined: 05/23/2014

There was an existing thread about this issue:

You will find this with the Sapphire cards. I was working through the issue with Sapphire's Tech Support, but then they stopped responding for two weeks so I RMA'd my root card (the one driving the monitor, not the Crossfire secondaries) and got a new ASUS ROG OC'd 290 (which I am very, very happy with).

I am very worried about DisplayPort going forward. There is a lot of poor quality understanding out there. One of the most frustrating issues I am having is the throughput limit. 1.2 is just enough for 1080p in 3D or a single 4k. DP 1.3 will be enough for a single 8k or 4k 3D, or 4k dual screens. The problem with that thinking is there is not enough bandwidth for a 3 way eyefinity. This makes a crossfire eyefinity setup out of the question, while there is only one DisplayPort per card. It would be great if you could use the DisplayPorts on CrossFire secondaries, but it's currently not possibe.

The second issue is the labelling of DisplayPort products: you can never be sure if it's DP 1.2 or 1.2a. Even getting a DP 1.2 cable has been a battle for me, as all my local suppliers don't even understand the difference between DP 1.1 and DP 1.2, and keep labelling 1.1 cables as 1.2.

 06/24/2014 08:46 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 3
Joined: 06/21/2014

I dont think this problem is a Sapphire problem tho. There has been alot of threads popping up after the new wave of 4k 60hz monitors release with the same problem. Most gfx card brands seems to be involved and most of the monitor makers too. 

For example:

The problem seems most wide spread on amds 290 cards.. 

 07/02/2014 04:28 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 10
Joined: 07/02/2014

Ive been having the same problem with the AOC and a 295x2.

Ive managed to get it working at 50hz without flickering using Custom Resolution Utility.

I have also tried 55hz, but that much the same as 60hz

My plan is to return the monitor and buy the ASUS as they seem to be having less problems

 07/02/2014 05:27 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 1
Joined: 07/02/2014

Same problem here as OP. There is a whole thread on this with the Asus monitor too on 


It seems to be independent of the monitor being used, as both the Asus and AOC use the same panel (I believe).


It also sounds like numerous people are reaching out to the different hardware vendors and are being given the runaround at the customer level, and for those who have contacts within the organizations, they're actually receiving feedback, but that both sides, AMD and NVidia are working on it, while the actual monitor vendors haven't been able to reproduce the issues with the cards they have on hand.


The PB287Q works totally fine in all modes available via HDMI 1.4, just the Displayport 1.2 something isn't right. I'm not sure why reviewers never noted any problems in their reviews of gaming on 4k monitors, it might have something to do with them using different panels. Whatever it is, it seems pretty consistent that there are issues running 4k @ 60hz over displayport across both monitor vendors/models. The weirdest part is that some people have no problems, many people have problems, and there's no consistency in it.

Powercolor AMD 290, using the supplied cable from the monitor manufacturer. 

 07/05/2014 03:43 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 2
Joined: 07/05/2014

experiencing the same issue despite the fact when using dp1.2 i never even get to see any desktop. it stays black all the time because there`s no signal detectetd. running 2 r9 290 with an aoc u2868pqu...i wonder if amd could just release a hotfix for it instead of waiting for a new driver set that addresses this issue which will be available in 2019 if they keep on like this!!!

84146 users are registered to the AMD Support and Game forum.
There are currently 6 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.