Topic Title: R9 200 with EVGA DisplayPort Hub Issues
Topic Summary:
Created On: 07/05/2014 07:22 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 07/05/2014 07:22 AM
User is offline View Users Profile Print this message

Author Icon
reuben.farrelly
Peon

Posts: 1
Joined: 07/05/2014

Hi,

I've recently made some changes to the setup of my card and two monitors to allow me to run both monitors out via the DisplayPort output of my Gigabyte GV-R929OC-4GD card with firmware F4.

The monitors are both Samsung S27A950D monitors running at 1920x1080x120Hz.  The board is an Intel D87KLT-75K with 16G DRAM and running the latest firmware for this mainboard.  I am running Catalyst Control Centre 14.4 (tried an earlier beta of 14.6 but it was hell buggy and unreliable and even worse than 14.4).  The OS is Windows 8.1 x64 with all patches applied.

Previous to this change I had one monitor connected via DisplayPort and the other via HDMI, which for the most part worked - it just seemed like an obvious improvement to move both back to DisplayPort connectivity.

So I went and purchased an EVGA EVGA-200-DP-1301-L4.  There's a PDF of the details of this DP Hub here:

http://www.evga.com/products/pdf/200-DP-1301.pdf

Now at a basic level it works.  But not without causing fairly severe instability and usability problems on the system itself.   Things like;

- The system ALWAYS boots up and requires a press of the reset button on the hub after Windows starts, in order for the system to detect the displays (sometimes one is detected, sometimes both, but never at the normal resolution)

- Sometimes the displays fail to come back after hibernating, necessitating a full reboot of the machine (you can see it's on but the displays don't come active again)

- Sometimes after sleeping the whole system crashes spontaneously when woken

- Periodically the machine will start up, both monitors will show the BIOS sequence and logo when booting up, but when Catalyst Control Centre starts it will only fire up one monitor, with the error "The maximum number of displays that can be supported per DisplayPort connector has been exceeded.  To use the display you just plugged in, first disconnect another display or move the current display to another connector".  Which makes no sense since there's only one active monitor (the other one is asleep, and will initialise then return to sleep after CCC starts).  DisplayPort Diagnostics in CCC tells me 41% bandwidth used with one monitor detected.  No amount of unplugging/plugging/resetting fixes this, but it eventually comes right by itself.

I'm somewhat out of ideas here as to where to go next.  Is this something I should be taking up with AMD?  Or EVGA?  It doesn't strike me as faulty hardware but I'm open to ideas and to hear if anyone else has had a similar (or not) experience with this hardware.

Is CCC 14.4 a known bad release or should I start backpedalling back to earlier releases to try and get some stability back? Or am I effectively wasting my time as it's something no-one else has been able to get to work either ?

Thanks,

Reuben

 

Statistics
84674 users are registered to the AMD Support and Game forum.
There are currently 5 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.