Topic Title: hd7970 with issues
Topic Summary: game always exits
Created On: 07/07/2014 06:56 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 07/07/2014 06:56 PM
User is offline View Users Profile Print this message

Author Icon
Densegers
Peon

Posts: 1
Joined: 07/07/2014

Hi, installed the gpu a few days ago

deleted the old nvidia drivers (550ti) with driver sweeper and installed  14.4 drivers and now 14.6 (used the 12.9 drivers too)

When i play world of tanks it justs exits the game, screen just exits in a few seconds and says error with graphic card drivers

 

Pc specs

 

amd phenom x4 955 BE stock 3.2Ghz (4 cores)

4gb ram kingston

use an older drive (5400rpm) for windows and games are on another newer disk(7200rpm)

windows 7 ult 64 bits 6.1 build7601

dx 11

gigabyte hd 7970 (GV-R7970OC-3GD

psu coolermaster GX 750w bronze (should do the trick)

motherboard asus crosshair 4 formula (stock) version 3029

 

If you need to know anything else just ask, the card is way better but the unexpected exits are really annoying and sometimes just 2 or 3 per day and sometimes 2 in ten minutes.

Maybe reinstall windows like i read somewhere but want to do that in the weekend maybe (maybe sooner )

tried older drivers but didn't help

system is virus free and spyware too, active on system

and cpu and ram should be fine, where checked with the nvidia gtx550ti and never had issues.

Only tested with world of tanks so far, nothing else i play for now.

 

Hope you know something I don't



Edited: 07/07/2014 at 09:33 PM by Densegers
Statistics
84705 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.