Topic Title: R9 280x freezes
Topic Summary:
Created On: 07/25/2014 10:16 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 07/25/2014 10:16 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 2
Joined: 07/25/2014


I just bought a Sapphire R9 280x Dual-x from a friend. It was never used, still in the box, but my friend did not have a reciept, so I probably won't be able to RMA it.

Installed the R9 280x in the following new build:

CPU: Intel I5 4590 3.3 Ghz
Motherboard: Gigabyte GA-B85M-HD3
Memory: G.Skill 2x4GB DDR3
PSU: Corsair CX750M Modular 750W
SSD: Samsung 840 EVO 120GB
HDD: Seagate 2TB Barracuda Sata III 
OS: Windows 7 Professional 64-bit 

The problem: While playing games (Call of Duty, a few Telltale Quests), every few minutes, the system freezes for a few seconds and then returns. Sometimes this crashes the game, and sometimes it doesn't. This is sometimes accompanied by a message from windows that "The display driver stopped responding and has recovered" error. Today, for the first time, this also happened when I was just browsing the internet, without any stress on the GPU.

GPU temperatures, even when playing demanding games, are reasonable (around 65c). 

I've tried to run 3DMark and at some point during the benchmark it fails with the message "Device hung due to badly formed commands. DXGI_ERROR_DEVICE_HUNG: ID3D11DeviceContext::FinishCommandList:". Running the benchmark again after this failure produces bad artifacts.

What I've tried to do so far:

- Removed AMD drivers, cleaned everything with Drive Sweeper, and reinstalled the 14.4 driver. Problem remains.

- Tried to install the 14.7 beta driver. The installer quits with an non-informative error while trying to install the driver.

- Made sure motherboard drivers are updated. Looked for a bios update but it seems that there isn't one available.

- Reconnected PSU cables to GPU in a different way. Problem remains.

- Tried underclocking the Core (1020 -> 1000) and Memory (1500 -> 1400). Problem remains.

Your advice would be very appreciated.


 07/26/2014 03:22 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 7
Joined: 07/22/2014

Looks like a few Nvidia cards have the same problem as you do.

Some of the succesful solutions was to increase you voltage for your GPU. For this you might want to use the AMD Overdrive (be careful when using)

See this for extra information: (you have to go a bit down before finding the solution with the voltage)

Hope this helps 

 07/27/2014 05:54 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 2
Joined: 07/25/2014

Thanks! That was a good idea. Unfortunately, it didn't work...

I think I'll try to RMA the card, and hopefully they'll accept it even though I don't have the reciept.

93137 users are registered to the AMD Support and Game forum.
There are currently 4 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.