Topic Title: AMD Radeon R9 290 Installation
Topic Summary: Device Manager doesn't show card
Created On: 08/02/2014 11:53 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 08/02/2014 11:53 AM
User is offline View Users Profile Print this message

Author Icon
DrPopping
Peon

Posts: 1
Joined: 08/02/2014

Hello,

 

I recently bought the R9 290 and connected it to my mother board but it isn't really working. Here's what I tried so far:

 

Completely uninstall any other graphic drivers, exept the one for my intergrated GPU (intel). Reboot and installed the AMD Catalyst driver, rebooted again and didn't work.

Gone into the BIOS and set primary graphics to PCI, reboot still nothing. Reinstall Catalyst and rebooted, still a no.

Device Manager also doesn't show the R9 290, even with the drivers installed.

My pc specs:

 

  • OS: Windows 7 Home Premiun 64bit
  • CPU: Intel Core i7-37770 CPU @ 3.40Ghz 8 core
  • 8192MB RAM
  • Graphics Card: AMD Radeon R9 290
  • Intel HD Graphics 4000 (intergrated)
  • Motherboard: ASRock Z77 Pro4
Additional Details:
The R9 GPU is currently connected with a HDMI cable to my monitor. The intergrated GPU (intel) with regular VGA. Also, the R9 has two power sockets. However, I couldn't find the second cable so it currently is only connected to the PCI socket on my motherboard and the one power cable.
The socket all the way left is connected at the moment. The card IS running though, air flows out of the back.
Please help and ask if any information is missing!
Kind regards,
Steve
Edit: pictures of my pc for more details

 



Edited: 08/02/2014 at 12:22 PM by DrPopping
 08/02/2014 08:18 PM
User is offline View Users Profile Print this message

Author Icon
goodplay
Cookie Monster

Posts: 427
Joined: 08/21/2011

New power supply required.See card manufacturers website for requirements.



-------------------------

i5 3570k(@4.5)./ga-z77x-ud5h-wb./hyper T4./2 x 4gb vengeance 1600 c8./sapphire dualX 7970 3gb OC boost v2./1tb WD FAEX Black./lg bh10 blu-ray r.w../corsair hx850./antec df30./z506 spkrs./lg e2240v./win 8(8.1) pro x64 

Statistics
85715 users are registered to the AMD Support and Game forum.
There are currently 4 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.