Topic Title: Sapphire Tri-X r290 underperforming & unstable
Topic Summary: Detailed Report with Logs showing problems with this GPU/drivers
Created On: 08/04/2014 07:17 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 08/04/2014 07:17 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 1
Joined: 08/04/2014



I have a (Sapphire Tri X r290) and am having huge/regular frametime/low fps spikes). I'm also getting 0xa0000001 and atikdag.sys BSODs with some versions of the CCC (see notes below). This is my first AMD card in about  twelve years and I'm really disappointed so far. I've tried everything I can think of and if anyone knows how to fix this then please please help.


Main Issues:


Spikes in frametimes (low fps spikes) which brings overall benchmarks in Heaven/Valley/FarCry 3 etc really low. For example, in FC3 I'm getting in FPS average in the 30s and I'm only running at 1080p. In Unigen's benchmarks I get lows sometimes under 10fps even though most of the time it's high. I've checked out official benchmarks for my card and my performance is severely under par. Even with the exact same benchmark versions and CCC drivers I'm getting way lower fps. This card is meant to be for 4k gaming and yet it's not even performing good enough for 1080p (the monitor I have). My girlfriend even tried playing old games like the Sims 3 and it's really laggy. 


AfterBurner logs:


Heaven Benchmarks


CCC 13.11 beta 9.5


CCC 14.6


Valley Benchmarks


CCC 14.4


CCC 14.6


MiniDump Crash Report




AMD Sapphire Tri X r290 4GB

Processor: Intel(R) Core(TM) i7 CPU  920  @ 2.67GHz (8 CPUs), ~2.7GHz

Memory: 18432MB RAM

Available OS Memory: 18424MB RAM

Page File: 7470MB used, 31432MB available

Windows Dir: C:\WINDOWS (windows 8.1)

DirectX Version: DirectX 11


CCC installs/drivers, my notes:


*14.6 beta rc2

-This has BSOD with atapiati errors (AMD process)

-It has some WD optimisations



-I was running this (went back to it due to BSOD) Found in FC3 it was giving me only 30fps

-Tried benchmarking on both this 14.6rc2 and dropped back to 13.11 all had no impact on FC3.

-Check benchmarks

- Sound errors .. doesn't see any sound for amd hdtv 14.6 has updates to the hdmi audio driver and the audio driver will now go back up and see if I can put up with the BSODs (so long as the audio is ok )

-Another bsod due to atikmdag.sys (03/08/14)



-no improvement in FC3

-this driver was used in benchmarking review of my gpu

-my benchmarks dont match up




To install drivers I've tried using CCC's full/clean remover (in Safe Mode) as well as DDU. I don't think the issue is to do with left over files. I've even repeated this process several times and one of the last times ran Driver Fusion to make double sure nothing was left over. 


I attempted to find all the chipset drivers I could. My mobo maker Asus doesn't have any drivers for Windows 8.1 (for the P6T Deluxe V2). I went to Intel and downloaded what I thought are the right drivers.  I also bought a premium version of Driver Fusion since it claimed to find chipset drivers that were missing. Once bought, it installed those drivers but nothing's improved.


Edited: 08/04/2014 at 07:33 AM by pixeldamage
 08/04/2014 07:49 AM
User is offline View Users Profile Print this message

Author Icon
Heavy Wizardry

Posts: 8744
Joined: 11/13/2009

...and your PS is what?


Intel I7 960 @ 3.87ghz *Intel DX58SO *AMD R9 290 4gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit 

***** cetera fallunt, ludere mortuus ******

 08/05/2014 04:52 PM
User is offline View Users Profile Print this message

Author Icon
Grinding Levels

Posts: 147
Joined: 08/04/2014

Same Problem with AMD.

I did everything. My vendor is saying and my research over the web is saying its the driver or defect memory on the card.

Like you something like this is new too me because i never had a AMD before.

I even didnt know that Graphiccards could make BSODs :S ....

But the same i have. Other driver brings other BSOD.

Bring it back and hope the repaired / new graphiccard will not make the same ****

Else you can only go to N..... and this would be ..... but than you have a running and stable system.

AMD has only one job. Making his solutions in the dektop area working. But AMD solutions are not working propper.

 08/13/2014 11:04 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 9
Joined: 08/04/2013

i solved all my problems by returning the 290x and purchasing a 780ti

life cant be better at the moment  

 08/14/2014 08:54 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 1
Joined: 08/14/2014

There is little BIOS switch on your card.

try to change it's position (don't forget to turn off pc first).

From what i see, your card is trying to stay at 73c temp AND at 33% FAN speed at same time. In that case it's only option is to decrease GPU frequency (which result in FPS drop), so your BIOS probably in silent mode.

I am using Gigabyte 290 myself, but i was facing something similar in silent mode too...

93055 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.