Topic Title: Sapphire R9 295x2
Topic Summary: CrossFire not showing/ Not showing R9 295x2
Created On: 08/04/2014 07:46 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 08/04/2014 07:46 PM
User is offline View Users Profile Print this message

Author Icon
NickJP
Peon

Posts: 1
Joined: 08/04/2014

Graphics Card
-Sapphire R9 295x2

AMD Catalyst Driver Version, and Driver History
- 14.7 Beta and 14.2

Operating System
- 64bit Win 7

Issue Details
- For some reason i dont have the crossfire option in CCC and in device manage and everywhere else it says my card is R9 200 Series. Yet in my GF computer she has windows 8 apart from that everything is the same and hers HAS crossfire option and says R9 295x2 in device manager im not sure if there is something wrong with my card. IM also not getting same performance as her in games and she is playing at 4K



Motherboard or System Make & Model
- Asus Maximus Hero

Power Supply

- Corsair 1200i

Display Device(s) and Connection(s) Used
- Cheap DELL monitor using DVI

Applications and Games

- Wildstar

CPU Details
- i5 4670K 1150pin

Motherboard BIOS Version
- not sure

System Memory Type & Amount
- 16gb Ripjaws 1866

Additional Hardware
- 1tb SSD



Statistics
85573 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.