Topic Title: ASUS PG278Q Monitor on AMD R9 series
Topic Summary: Anyone got this monitor to do 144Hz on a AMD card
Created On: 08/12/2014 02:54 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 08/12/2014 02:54 PM
User is offline View Users Profile Print this message

Author Icon
thomasbo
Peon

Posts: 2
Joined: 05/12/2014

Hi,

Just got this monitor (2560x1440) at 60/120/144 hz, but can not get it to run 144Hz. Doing that makes the image flicker like crazy.

If i put the monitor on a nVidia 780ti it does 144 nicely.. also without engaging G-Sync.

Is there an issue with the AMD drivers that make the signal unstable at 144Hz with this monitor ?

I am using Club 3D R9 290x at stock clocks.



Edited: 08/14/2014 at 03:09 PM by thomasbo
 08/29/2014 03:13 PM
User is offline View Users Profile Print this message

Author Icon
seslash
Peon

Posts: 2
Joined: 08/29/2014

+1

Just got this monitor. I'm getting crazy flickering at 144Hz as well. Did a quick search on the internet, this is seems to be an issue with AMD GPUs. Most likely due to a driver issue. 120Hz runs like a dream though.

I'm running MSI R9 290X Twin Frozr and Catalyst 14.7 RC1 (RC3 degrades performance in bf4 after 30-60 minutes of play).

I also get an ocasional flicker every once in a while, which occurs with weird frequency (1-120 minutes). Thomasbo, are you getting that as well?

 08/29/2014 09:33 PM
User is offline View Users Profile Print this message

Author Icon
Ossian512
Peon

Posts: 2
Joined: 08/29/2014

I'm in the same boat. I can't get above 85 Hz though without the monitor completely losing signal -- not even a flicker, just a complete blank.

I had concerns, considering this was obviously an Nvidia focused product, but I thought worst case I'd at least get 1440 and 144 Hz!

I'm not really confident that AMD is going to see this as a priority driver update  

 08/31/2014 03:09 PM
User is offline View Users Profile Print this message

Author Icon
seslash
Peon

Posts: 2
Joined: 08/29/2014

Ossian, 290/290x should be able to run at 120Hz with this monitor. What card do you have? Try using latest Beta drivers. Otherwise it could be hardware issue with either the card or the monitor.

 09/02/2014 10:05 AM
User is offline View Users Profile Print this message

Author Icon
MDK350
Peon

Posts: 7
Joined: 09/02/2014

Also having this issue.

Flickering at 144hz with crossfire 290x. 

 09/02/2014 11:15 AM
User is offline View Users Profile Print this message

Author Icon
madman962
Peon

Posts: 4
Joined: 09/02/2014

I can confirm I am having the exact same issue.  

I'm running 2 x XFX R9 290.  I have tried disabling cross fire but the issue remains. 

I am 100% stable at 85hz, but I can't get past that.  It get's progressively worse each step up (100, 120, 144).  I get a mixture of black screens, tearing, flickering, and at 144 the image just completely distorts and I have a hard time getting it back to 85. 

This very much appears to be an AMD driver issue since we are all having the same issue on this card. 

I am running catalyst 14.7 which should be the most recent non-beta version.  I am going to try the beta driver and see if I can get 120hz working like someone else mentioned. 

 09/02/2014 11:20 AM
User is offline View Users Profile Print this message

Author Icon
MDK350
Peon

Posts: 7
Joined: 09/02/2014

Anything up to and including 120hz works fine on my card, 144hz does the flickering.

How do we get a response to this from someone at AMD?

 09/02/2014 11:21 AM
User is offline View Users Profile Print this message

Author Icon
madman962
Peon

Posts: 4
Joined: 09/02/2014

MDK350 - Can you tell us what driver version you are using? 


Beta or regular? 

 09/02/2014 11:22 AM
User is offline View Users Profile Print this message

Author Icon
MDK350
Peon

Posts: 7
Joined: 09/02/2014

I used 14.6 beta and 14.7 beta.

 09/02/2014 09:26 PM
User is offline View Users Profile Print this message

Author Icon
madman962
Peon

Posts: 4
Joined: 09/02/2014

Tonight I did fresh installs of 14.6 rc2, 14.7 rc1, and 14.7 rc3.  I was unable to get anything beyond 85hz on all 3 of those drivers.  If anyone else is having success with another version besides one of those 3 please let us know! 

The 14.6 rc2 was the closest for me.  I could run at 100hz and the screen would black out about every 5 seconds.  Every other driver was worse than that.

No issues with my cards at all maxing them out in games, so I'm still convinced this is a driver/monitor compatibility problem.

 09/03/2014 01:49 PM
User is offline View Users Profile Print this message

Author Icon
Qwixt
Grinding Levels

Posts: 121
Joined: 02/07/2008

This would be the first monitor at 2560x1440 to officially go over the standard 60 hz. Some korean models overclock up to 120 (not sure if it's a true 120). The 144 is probably some gsync trickery, and the fact that you are using a card that is not compatible with gsync shows that.

 09/03/2014 02:03 PM
User is offline View Users Profile Print this message

Author Icon
MDK350
Peon

Posts: 7
Joined: 09/02/2014

You can run 144hz on Nvidia with Gsync off, so its not any sort of trickery. AMD cards should be able to output 144p at 144hz without an issue. 

 09/03/2014 05:51 PM
User is offline View Users Profile Print this message

Author Icon
Qwixt
Grinding Levels

Posts: 121
Joined: 02/07/2008

I just looked it up today, and this is the first monitor to support those rates natively.

Are you using a display port cable?

 09/03/2014 06:17 PM
User is offline View Users Profile Print this message

Author Icon
MDK350
Peon

Posts: 7
Joined: 09/02/2014

Correct, the PG278Q only has a DP input.

I tried to use a DP-> DVI active adapter on the monitor end, but those must be one way; didnt work.

 09/04/2014 06:20 PM
User is offline View Users Profile Print this message

Author Icon
MDK350
Peon

Posts: 7
Joined: 09/02/2014

Over on the Asus support forum for this monitor, an employee of Asus is suggesting that the issue is with the drivers.

http://rog.asus.com/forum/showthread.php?50236-PG278Q-with-Radeon-HD&p=426683&viewfull=1#post426683

Is AMD going to look into updating the driver to support this monitor?

 09/04/2014 08:47 PM
User is offline View Users Profile Print this message

Author Icon
Ossian512
Peon

Posts: 2
Joined: 08/29/2014

Gotta be a driver issue.

My card is a Saphirre Tri-X R290, and I tried clean installs on drivers including the Beta's and was still unable to get above 85Hz.

 

Asus support assumed it was a hardware issue and iaaued an RMA. I picked up an EVGA GTX 780 ti and the Swift is now running flawlessly, so not a problem with the monitor itself.

I guess we shouldn't be too surprised --- Asus was pretty clear that this was a monitor built in conjunction with Nvidia and specifically designed to capitalize on their proprietary features. Still, pretty disappointing that it doesn't currently perform as a high refresh 1440 display for all card types -- I would have been happy with that. Having experienced G-Sync and ULMB now, however, I won't be going back...

 09/05/2014 10:35 AM
User is offline View Users Profile Print this message

Author Icon
madman962
Peon

Posts: 4
Joined: 09/02/2014

Guys, take a few minutes and fill out the form at the link below.  The more people that report this issue the faster it will be fixed:

http://www.amdsurveys.com/se.ashx?s=5A1E27D25AD12B5A

 

 09/05/2014 10:56 AM
User is offline View Users Profile Print this message

Author Icon
MDK350
Peon

Posts: 7
Joined: 09/02/2014

Great idea. I posted that form over on the Asus site so hopefully we get more visibility on this issue. 

 09/06/2014 02:29 AM
User is offline View Users Profile Print this message

Author Icon
forserum
Peon

Posts: 1
Joined: 09/06/2014

Originally posted by: thomasbo Hi,

 

Just got this monitor (2560x1440) at 60/120/144 hz, but can not get it to run 144Hz. Doing that makes the image flicker like crazy.

 

If i put the monitor on a nVidia 780ti it does 144 nicely.. also without engaging G-Sync.

 

Is there an issue with the AMD drivers that make the signal unstable at 144Hz with this monitor ?

 

I am using Club 3D R9 290x at stock clocks.

 

 

 

same skit here with 2 290x sapphire trix, evrything over 60hz flicker  but for 2 weeks ago i had 7970 matrix in crossfire and it worked with asus swift at 144hz

Statistics
87660 users are registered to the AMD Support and Game forum.
There are currently 4 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.