Topic Title: Battlefield 4
Topic Summary: MSI AMD R9 280x 3GB
Created On: 08/14/2014 01:34 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 08/14/2014 01:34 AM
User is offline View Users Profile Print this message

Author Icon
sabariboss
Peon

Posts: 49
Joined: 12/13/2013

Hi,

    Guys i could always used to run the battlefield 4 game in ultra in SP & MP without fps drops below 60. But now after the bf4 update i couldn't handle the game in ultra settings in mp & sp stuttering issues. I don't know what happened ? It's the driver issue or Dice issue no one knows. I am waiting for the new WHQL driver for AMD asap.. In battlelog i have seen some fix regarding this issue, I had created some user.cfg inside the game for fps issues, While running the game with mantle settings the fps didn't raise above 60. It stands stable on 60fps. Somtimes it lags & stuttering.

 08/14/2014 06:51 AM
User is offline View Users Profile Print this message

Author Icon
Denonite
Peon

Posts: 3
Joined: 08/14/2014

BF4 is completly broken, I'm running 2x 280x in Crossfire with 3x 24" Eyefinity setup and can't even load a map with crossfire enabled, keep getting out of memory - makesure you have a supported graphics card with at least 512MB RAM - what a joke. Seems lots of others having the same issue but no one has a fix. Never had the issue with my old nvidia SLI/surround setup

 

Looks like the last BF4 parch really screwed things for AMD card users.



-------------------------

Intel 2500K @ 4.6GHz, 8GB Brucial Balistix Tracer 1866MHz RAM, 2 x 280X, Asus Sabretooth Z77MB, Corsair Force GT SSD, Windows 8.1

Statistics
86374 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.