Topic Title: Faulty XFX R9 290 DD?
Topic Summary: Can someone advise me if this is faulty or a driver issue?
Created On: 08/16/2014 07:19 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 08/16/2014 07:19 AM
User is offline View Users Profile Print this message

Author Icon
Ferocious
Peon

Posts: 2
Joined: 08/16/2014

Hi, I recently purchased an XFX R9 290 DD edition.

Sometimes I get random horizantal lines on the desktop. When I move windows around the screen it gets worse. When nothing is moving it seems not to happen at all. In the 3 weeks I have had this card I have seen this around 5 times.

 

Also sometimes my mouse pointer will become corrupted. This seemingly happens at random too.

 

My system:

Gigabyte GA-970a-DS3p motherboard - AMD FX6300 CPU - 2x4GB Crucial ballistix DDR3 - XFX R9 290 DD GPU - XFI Xtreme music sound card - Crucial MX100 SSD - WD 1TB Blue HDD - Corsair CX600 PSU

 

Monitor is an AOC e2250Swda (1920x1080 DVI).

I have also seen the issues on an Asus VE228TR monitor using a different DVI cable and even using a DP to VGA converter.

 

I have tried to capture the lines but cannot seem to time it right in a screenshot, even tried screen cap software but they do not seem to show up in it.

 

Playing a video seems to make them go away once they have appeared. Something to do with resetting the driver or putting it in a different mode for the overlay maybe?

 

Any advice would be appreciated. XFX have said they will take it back but it could take 6-8 weeks for replacement, and if they don't see the issue it would be a waste of time....

 

I do not have another system to test it in either.

 

EDIT: All drivers are up to date in my system, have tried different AMD drivers from 13.12 to 14.7 RC3 (Using DDU in between of course) and have seen both issues in all of them.

 

EDIT2: Windows 7 x64. Tried without overclock on my CPU. GPU has always been at stock clocks. Tried with +50% power limit in CCC (have to do this to make it actually hit stock clocks in games it would seem - is this normal?)



Edited: 08/16/2014 at 07:28 AM by Ferocious
Statistics
86427 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.