Topic Title: Trouble with Radeon HD 7500 Series and gaming...
Topic Summary: Black screens shortly after game starts.
Created On: 08/29/2014 10:00 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 08/29/2014 10:00 PM
User is offline View Users Profile Print this message

Author Icon
ZKtheMAN
Peon

Posts: 4
Joined: 08/12/2014

Graphics Card: AMD Radeon HD 7500 Series, came with the Dell XPS 8700

AMD Catalyst Driver Version, and Driver History: OEM drivers -> AMD Catalyst ver. 14.4

Operating System: Windows 8.1 with all current updates

Issue Details:

So whenever I play any game, save old ones like CS 1.6 and Warcraft 3, a black screen always comes up and the monitor says that it isn't recieving any signal. I have to hard reset the computer to get back my screen. This can be delayed by constantly alt-tabbing every one in a while.

Steps to reproduce:

1) Start any 3D game that isn't older than Warcraft 3.

2) Play without switching windows.

3) After a bit, the screen should go black.

Motherboard or System Make & Model: whatever comes with the XPS 8700

Power Supply: ^

Display Device(s) and Connection(s) Used: The output from the card goes to a converter to VGA, which then goes to my monitor.

Applications and Games:

It happens with these games:

Counter-Strike: Source

Counter-Strike: Global Offensive

League of Legends

Dota 2

Dawngate

Starcraft II

Team Fortress 2

Tribes: Ascend

Crysis 2

Deus Ex: Human Revolution

Smite

It does not happen with these games:

Counter-Strike ver. 1.6

Warcraft III: Reign of Chaos and The Frozen Throne expansion

Starcraft and Starcraft: Brood War expansion

CPU Details: Intel Core i7, don't know beyond that

Motherboard BIOS Version: The newest version i think

System Memory Type & Amount: stock hardware

Additional Hardware: ^

Additional Details: I went to the Windows support forums, which, I realize, was the wrong thing to do, and I am totally stupid, but I'll link it to let you know what happened. Ignore that bit on it only happening to fullscreen games, that's been disproven.

http://answers.microsoft.com/en-us/windows/forum/windows_8-gaming/screen-goes-completely-black-shortly-after-playing/e9952d02-8d0c-4f10-9833-d5ba496c4672?page=1&msgId=eb12723a-dffb-4a09-a199-92c480182723

 

Soo, yeah, can anyone help me, or do I have to get a different card?

 09/01/2014 02:51 PM
User is offline View Users Profile Print this message

Author Icon
ZKtheMAN
Peon

Posts: 4
Joined: 08/12/2014

plea-of-help bump

 09/01/2014 10:17 PM
User is offline View Users Profile Print this message

Author Icon
speedysami
Peon

Posts: 4
Joined: 09/01/2014

Hey ZK!

You are not alone. I am in the same boat.

Running an asembled machine. This started happening (I think) after a windows update.

*History*

I discovered the problem running Watch Dogs, it was running fine, then the screen went black, audio still played, but PC was completely non responsive.

I did a hard reset. Problem persisted on other games like Autosport & Black Flag. Few minutes into the game and boom. I did a system restore, problem persisited.

*Now*

I did a driver rollback and ran the Grid Autosport Benchmark, did really good, no crash. Then I decided to run Watch Dogs and boom! BSOD.

Will let you know of the other things I try.

 

 09/01/2014 10:33 PM
User is offline View Users Profile Print this message

Author Icon
ZKtheMAN
Peon

Posts: 4
Joined: 08/12/2014

At least someone out there knows my pain.

 09/01/2014 11:40 PM
User is offline View Users Profile Print this message

Author Icon
speedysami
Peon

Posts: 4
Joined: 09/01/2014

Did you by any chance try...

  1. Rolling back Drivers and installing the most current driver after the update?
  2. Reinstalling Windows?

 09/02/2014 09:23 AM
User is offline View Users Profile Print this message

Author Icon
speedysami
Peon

Posts: 4
Joined: 09/01/2014

I think I have fixed my issue. Here is what I did...

1. Rolled back drivers

2. Restarted

3. Re-Downloaded/installed lates drivers for my device (HD7770) via the AMD game site.

4. installed driver, it actually asked for a restart so I did

Thats it... no crashing on Watch Dogs or Autosport or other DX11 games so far.

I

 09/02/2014 12:50 PM
User is offline View Users Profile Print this message

Author Icon
speedysami
Peon

Posts: 4
Joined: 09/01/2014

No. No its back and this time the symptoms point towards a failing PSU

 09/06/2014 02:45 PM
User is offline View Users Profile Print this message

Author Icon
ZKtheMAN
Peon

Posts: 4
Joined: 08/12/2014

Yeah, that's what happens after you reinstall drivers. First it seems like it goes away (but my theory is that it just takes way longer to crash after) but then after a while it comes back, and the time taken to crash just shortens.

What's a PSU? 

Statistics
85407 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.