Topic Title: Skyrim CrossfireX Flickering
Topic Summary: Graphics flickering while crossfireX is enabled on Catalyst 12.8
Created On: 08/17/2012 05:49 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 08/17/2012 05:49 PM
User is offline View Users Profile Print this message

Author Icon
rinks361
n00b

Posts: 5
Joined: 08/17/2012

I was looking online and found that a new set of drivers had been released, some of which were supposed to clear up the flickering caused by enabling CrossfireX in Skyrim. However, upon uninstalling the older drivers and installing the newer drivers, I've found that the flickering still occurs.

So far, 11.2 has been the only drivers that have not caused the bright, white flickering in Skyrim. While in Crossfire mode, I can tell the performance is greatly increased and gameplay seems smoother than when running off of one card, however the flickering is still there. With the 12.8 release the flickering isn't as bright and the game is semi-playable, however it is still there and still noticable. I'm not sure if anyone else is still getting this issue, as I read that the Crossfire issues were supposedly resolved. I'd like to be able to play this game with Crossfire enabled. While it runs decent on one card, I still get some stuttering during intense fights, especially when using magic against dragons and other mages. While playing with Crossfire on, there's no stuttering at all, but I have to choose between suffering from epilepsy playing on Crossfire or the stuttering while running a single card.

 

Graphics Card
- 2x AMD ATI Radeon HD5780

AMD Catalyst Driver Version, and Driver History
- 12.8 current version. Tested 11.2 and up.

Operating System
-Windows 7 Pro 64bit

Issue Details
- While running Skyrim in game with CrossfireX mode enabled, I receive constant, bright white screen flickering while playing. With CrossfireX off, the flickering stops and the game graphics display normally.
- All settings in CCC are set to application controlled, no extra settings used, all other settings on default. No hardware accelleration used.
- links to videos or pictures that may demonstrate your issue

Applications and Games
- TESV: Skyrim, up to date with latest patch and Dawnguard DLC installed.

CPU Details
-AMD Phenom II x4 945 3.0Ghz (not overclocked)

Display Device(s) and Connection(s) Used
- include specific brand & model (ex:  DELL U2411)

Motherboard or System Make & Model
-ASUS GA-890XA-UD3

Motherboard BIOS Version
- 2.4

System Memory Type & Amount
- 8GB DDR3 Corsair Memory 

Power Supply
- Antec TruePower Quattro 1000W ATX 12V & EPS 12V PSU

Additional Hardware
- 8 5" Case Fans, 3x 250GB SSD Hard Drives, 1x 500GB SSD hard drive, Sound Blaster Audigy 4 sound card.


Additional Details
- Updated all system drivers, uninstaleld/reinstalled graphics drivers and used Driver Sweeper to clear additional files, uninstalled/reinstalled Skyrim.

- The only driver package that works with CrossfireX enabled is 11.2. All drivers beyond that cause the screen flickering to occur when CrossfireX is enabled.

 08/17/2012 06:10 PM
User is offline View Users Profile Print this message

Author Icon
rinks361
n00b

Posts: 5
Joined: 08/17/2012

Just uploaded a video to YouTube showing off the issue that I am having:

http://youtu.be/9gp5NyV_tiE

 08/17/2012 06:34 PM
User is offline View Users Profile Print this message

Author Icon
bladesman83
n00b

Posts: 10
Joined: 08/14/2012

May be a daft question but........are you using any caps?



-------------------------

Phenom II x6 BE 1090T @ 3.8GHz 1.40V
Asus Crosshair IV Formula

8GB GSkill Ripjaw @ 1333 7-7-7 1.60V
HIS Radeon HD6850 IceQX Turbo 1GB CrossfireX
OCZ Vertex+ SSD
2x WD Blue SATAIII
CM GX 650

 08/17/2012 06:47 PM
User is offline View Users Profile Print this message

Author Icon
rinks361
n00b

Posts: 5
Joined: 08/17/2012

Originally posted by: bladesman83 May be a daft question but........are you using any caps?

 

Yea, have 12.7 CAP 3 installed

 08/17/2012 06:58 PM
User is offline View Users Profile Print this message

Author Icon
bladesman83
n00b

Posts: 10
Joined: 08/14/2012

OK.

Have you tried using only one card? Lets see if we can confirm it's crossfire related.

If so, try disabling Vsync. To do this:-

add iPresentInterval=0 to documents>skyrim>skyrimpref.ini using notepad.

 



-------------------------

Phenom II x6 BE 1090T @ 3.8GHz 1.40V
Asus Crosshair IV Formula

8GB GSkill Ripjaw @ 1333 7-7-7 1.60V
HIS Radeon HD6850 IceQX Turbo 1GB CrossfireX
OCZ Vertex+ SSD
2x WD Blue SATAIII
CM GX 650

 08/17/2012 07:06 PM
User is offline View Users Profile Print this message

Author Icon
rinks361
n00b

Posts: 5
Joined: 08/17/2012

Originally posted by: bladesman83 OK.

 

Have you tried using only one card? Lets see if we can confirm it's crossfire related.

 

If so, try disabling Vsync. To do this:-

 

add iPresentInterval=0 to documents>skyrim>skyrimpref.ini using notepad.

 

 

 

With one card/Xfire off and vsync off or on the flickering stops.

With both cards in Xfire and vsync off or on it starts the flickering again.

 08/17/2012 07:56 PM
User is offline View Users Profile Print this message

Author Icon
bladesman83
n00b

Posts: 10
Joined: 08/14/2012

Then chances are (as I had with BF3) it's a concoction of drivers causing the error.

I would suggest either a re format or, play with one card. As I did for a while.

 

As a final option, you could try underclocking the memory of your cards. It's been known to fix many graphical glitches.

 

Good Luck.



-------------------------

Phenom II x6 BE 1090T @ 3.8GHz 1.40V
Asus Crosshair IV Formula

8GB GSkill Ripjaw @ 1333 7-7-7 1.60V
HIS Radeon HD6850 IceQX Turbo 1GB CrossfireX
OCZ Vertex+ SSD
2x WD Blue SATAIII
CM GX 650

 08/17/2012 08:28 PM
User is offline View Users Profile Print this message

Author Icon
rinks361
n00b

Posts: 5
Joined: 08/17/2012

Originally posted by: bladesman83 Then chances are (as I had with BF3) it's a concoction of drivers causing the error.

 

I would suggest either a re format or, play with one card. As I did for a while.

 

 

 

As a final option, you could try underclocking the memory of your cards. It's been known to fix many graphical glitches.

 

 

 

Good Luck.

 

I did the underclocking but it did not do anything to help. I also cleared out all display drivers before I installed 12.8 using ATI's recommended uninstall proceedure and then also ran DriverSweeper to clear out any remaining ATI drivers.

I did however come across one solution that does work. http://www.youtube.com/watch?v=zF9cQxbn3dE

I don't know how using Assassin's Creed Brotherhood clears up the flickering, but it works. The only time it flickers is when you go to the quest menu, which I can tolerate since I'm only on that menu when I change quest markers and exit the game. As far as the rest of the game, it runs great now.

I'm not very technical nor do I know the difference between the TES:V and ACB?p.exe profiles but clearly something is working with that profile that isn't working in the normal Skyrim profile. Until a solution comes around, this will have to do. I'm starting to wonder if it's an issue with the HD 5800 series cards itself.

 12/05/2013 02:35 AM
User is offline View Users Profile Print this message

Author Icon
FelipeCoaL
Peon

Posts: 2
Joined: 12/05/2013

I have the same problem just when I use my 2 280X with crossfire. =/

When I'm near the water the game flickering. Same happen with some creatures of the game.  

 03/12/2014 06:07 PM
User is offline View Users Profile Print this message

Author Icon
baz_lad
Peon

Posts: 1
Joined: 03/12/2014

Hi, i have the same issue, im using 4870 hd in crossfire and have not managed to find a fix, i get better fps with 2 cards running but the flicker makes it un playable. Have you found a fix yet?

 11/07/2014 06:03 AM
User is offline View Users Profile Print this message

Author Icon
Rudwolf
Peon

Posts: 8
Joined: 11/07/2014

I'm using my AMD 7730M (mobile-notebook) and I have the same problem, including with Castlevania: Lords of Shadow 2. When i desabled my dedicated graphic card and run it by Intel HD Graphic (shared graphic card), flickering stops. Other thing that helped was using games windowed mode, because fullscreen make flickering again.
Any Solution yet?

Statistics
88947 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.