Topic Title: World of Warcraft DirectX 11 Radeon HD 7850 freeze+crash Catalyst driver related issue
Topic Summary: Freeze+crash with directx 11 enabled in wow with Radeon HD7850 all catalyst versions back to 12.4
Created On: 09/03/2012 12:10 PM
Status: Post and Reply
Linear : Threading : Single : Branch
<< 1 2 3 Previous Next Last unread
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 10/22/2012 07:25 PM
User is offline View Users Profile Print this message

Author Icon
locc
Peon

Posts: 6
Joined: 01/30/2010

Did 9h marathon test with 12.9 beta drivers in DX9 mode and got no crashes.
Today 12.11 beta drivers came out so I installed those, changed wow to DX11 mode and prayed.. after running wow in DX11 mode the whole system froze with looping sound after ½h. So still no fix for warcraft.

 10/22/2012 08:41 PM
User is online View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7028
Joined: 11/13/2009

...and again > http://www.google.com/search?q=wow+dx11+crash&sourceid=ie7&rls=com.microsoft:en-us:IE-SearchBox&ie=&oe=

If you would spend as much energy writing to WOW it probably would be fixed by now. Just play in dx9 and wait for them to fix it.



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

 10/25/2012 03:37 AM
User is offline View Users Profile Print this message

Author Icon
shadowsky76
Peon

Posts: 13
Joined: 09/14/2012

Yeap, freezes again with 12.11 Betas. I'm back to perfectly stable 12.3

 10/30/2012 10:15 AM
User is offline View Users Profile Print this message

Author Icon
Rumraket
Peon

Posts: 19
Joined: 09/03/2012

Yep, same experience. New 12.10 and 12.11 beta drivers result in freeze+crashes WoW in DX11 mode, but with the old 12.3 version my system is stable. 

 10/31/2012 04:35 PM
User is offline View Users Profile Print this message

Author Icon
locc
Peon

Posts: 6
Joined: 01/30/2010

I've tried basically everything possible. Clean install of windows, no addons on wow, 32bit & 64bit wow.exe, disabled dhmi, multiple drivers (including 12.3), 1 or 2 monitors active, all wow settings reset to defaults etc. This isnt even the full list. I start to think that there is some hardware or bios firmware problem with cards which freeze in DX11 mode.

 11/13/2012 10:50 AM
User is offline View Users Profile Print this message

Author Icon
l3vi4than
Peon

Posts: 6
Joined: 11/13/2012

I've got exactly the same effect with WoW. Only switching down to DX9 "fixes" the issue. My system was perfectly stable before getting a 7850.

i7 920, 3 GiB RAM, Sapphire Radeon 7850, Gigabyte GA-EX58-UD4.

Windows Server 2008 all HotFixes, service packs and what not. Tried the beta drivers - same effect. Tried also reverting back to the suggested 12.3 drivers, it works fine, but the performance is horrific.

Playing at nearly lowest detail levels, windowed mode.

 11/13/2012 01:12 PM
User is offline View Users Profile Print this message

Author Icon
locc
Peon

Posts: 6
Joined: 01/30/2010

I might be biased to say but I've a feeling (based on going through multiple posts at multiple forums) that most of the time ppl have this issue when running on X58 systems. I've x58 system so like said I might have just noticed those more easily. That being said I've seen simialer reports on other platforms too. All in all I've still the same freezing issue in DX11 mode while DX9 is rock stable. Running 12.11 beta 7's atm.

 11/14/2012 08:16 AM
User is offline View Users Profile Print this message

Author Icon
l3vi4than
Peon

Posts: 6
Joined: 11/13/2012

I've got the exact same idea. X58 seems the common denominator, I'll try to update the BIOS during the next couple days.

 11/26/2012 10:34 AM
User is offline View Users Profile Print this message

Author Icon
l3vi4than
Peon

Posts: 6
Joined: 11/13/2012

Just a forward of a Support Ticket I sent to ATI, describing the issue in-depth:

----

World of Warcraft: Mists of Pandaria, current retail version. Running Windowed Mode with Everything mostly on Ultra Low, , Projected Textures and Particles a bit higher. The GPU is running at low temperatures. No overheating of any kind.

 

The whole OS freezes hard after a random amount of time in-game when DX11 rendering is used. Completely randomly, not even correlated to GPU-load, I had freezes after time ranging from 10mins to 2hrs+ of gameplay, either GPU-idle or while raiding. If I revert back to DX9, it's stable. But I can quite feel a performance difference. What is worth noting, it's not a bluescreen, it's a freeze. I encountered a couple situations where it seemed the system recovered from a 30second freeze, somehow. I had a BSOD once, with VIDEO_SCHEDULER_INTERNAL_ERROR.

 

I'm not sure, but it might have something to do with Windowed Mode or Cooperative-DirectX-Modes, right now, with my system being stable, the rendering background process of Chrome crashes, but only if WoW is running.

 

Current Catalyst drivers, tried the newest beta - gives the same effect. I tried downgrading the drivers release by release, I did not encounter the crash in 12.3.

 

Before I had Rad 7850, I owned a 4850, and my system was rock-stable, no crashes, for months, literally, so memory/hdd/mobo-defect/overheating being a reason are impossible, or at least *highly* unlikely.

 

There is a discussion about that issue on AMD's forums:

http://forums.amd.com/game/messageview.cfm?catid=443&threadid=161015

 

I think it might have something to do with the X58/i7 platform, more sources of similiar reports can be found via google. ("7850 dx11 x58 freeze")

 

Feel free to contact me in case you have any questions, I'm able and willing to provide a minidump from that one stop-screen I got. I'm willing to assist in any way to fix that issue.

 

p.s. Windows Server 2008 32bit SP2(all hotfixes and what not) is actually my OS. Not present in the above combobox. Picked Vista, as it's the closest to W2K8.

 

---- Minidump verbose details follow ----

 

2: kd> !analyze -v

*******************************************************************************

*                                                                             *

*                        Bugcheck Analysis                                    *

*                                                                             *

*******************************************************************************

 

VIDEO_SCHEDULER_INTERNAL_ERROR (119)

The video scheduler has detected that fatal violation has occurred. This resulted

in a condition that video scheduler can no longer progress. Any other values after

parameter 1 must be individually examined according to the subtype.

Arguments:

Arg1: 00000500, The subtype of the bugcheck:

Arg2: 862445a0

Arg3: 863a8528

Arg4: 00ed9087

 

Debugging Details:

------------------

 

 

CUSTOMER_CRASH_COUNT:  1

 

DEFAULT_BUCKET_ID:  DRIVER_FAULT_SERVER_MINIDUMP

 

BUGCHECK_STR:  0x119

 

PROCESS_NAME:  System

 

CURRENT_IRQL:  9

 

LAST_CONTROL_TRANSFER:  from 8f55a230 to 826e3abf

 

STACK_TEXT:  

8b52f794 8f55a230 00000119 00000500 862445a0 nt!KeBugCheckEx+0x1e

8b52f7bc 8f4ca4f1 00000000 09000119 00000500 watchdog!WdLogEvent5+0x130

8b52f810 8f4ba405 862445a0 00000001 00000001 dxgkrnl!VidSchiProcessIsrPreemptedPacket+0xd6

8b52f83c 8f4ba5c3 8641c000 8b52f898 00000001 dxgkrnl!VidSchDdiNotifyInterruptWorker+0x261

8b52f858 8ea113ed 853b03d0 8b52f898 86136000 dxgkrnl!VidSchDdiNotifyInterrupt+0x68

WARNING: Stack unwind information not available. Following frames may be wrong.

8b52f8ec 8ec258f2 853b03d0 8b52f958 8b52fbd8 atikmpag+0x53ed

8b52f9ac 8ec2402a 00000004 8b52fa60 00000000 atikmdag+0x178f2

8b52f9c8 8ec25f91 00000000 8b52f9e4 8ec3261d atikmdag+0x1602a

8b52f9d4 8ec3261d 86136000 8b52fa60 8b52fa3c atikmdag+0x17f91

8b52f9e4 8ec82680 853b2000 8b52f9f8 8b52fbb0 atikmdag+0x2461d

8b52fa3c 8ec83345 86368000 8ec25f72 86136000 atikmdag+0x74680

8b52fa98 8ec831e1 86368000 86373d10 00000000 atikmdag+0x75345

8b52fab4 8ec839f1 86368000 86373d10 00000000 atikmdag+0x751e1

8b52fb68 8ec8325a 86368000 86373d10 00000000 atikmdag+0x759f1

8b52fb90 8ec8a32d 86368000 86373d10 8b52fbb0 atikmdag+0x7525a

8b52fc54 8ec80ca1 86368000 853b74c8 853b74c8 atikmdag+0x7c32d

8b52fc6c 8ec25d25 86368000 84ffbd18 8b52fc94 atikmdag+0x72ca1

8b52fc7c 8ea11e58 853b74c8 00000000 85bfc780 atikmdag+0x17d25

8b52fc94 8f4ba0f9 853b74c8 00000000 8b52fcb8 atikmpag+0x5e58

8b52fca4 826c58ed 85bfc780 853b03d0 00000000 dxgkrnl!DpiFdoMessageInterruptRoutine+0x17

8b52fcb8 8265cb41 85bfc780 853b03d0 8b52fce4 nt!KiInterruptMessageDispatch+0x12

8b52fcb8 826be7ae 85bfc780 853b03d0 8b52fce4 nt!KiInterruptDispatch+0x51

8b52fd54 00000000 0000000e 00000000 00000000 nt!KiIdleLoop+0x1a

 

 

STACK_COMMAND:  kb

 

FOLLOWUP_IP: 

dxgkrnl!VidSchiProcessIsrPreemptedPacket+d6

8f4ca4f1 8b5508          mov     edx,dword ptr [ebp+8]

 

SYMBOL_STACK_INDEX:  2

 

SYMBOL_NAME:  dxgkrnl!VidSchiProcessIsrPreemptedPacket+d6

 

FOLLOWUP_NAME:  MachineOwner

 

MODULE_NAME: dxgkrnl

 

IMAGE_NAME:  dxgkrnl.sys

 

DEBUG_FLR_IMAGE_TIMESTAMP:  4d383dc1

 

FAILURE_BUCKET_ID:  0x119_dxgkrnl!VidSchiProcessIsrPreemptedPacket+d6

 

BUCKET_ID:  0x119_dxgkrnl!VidSchiProcessIsrPreemptedPacket+d6

 

Followup: MachineOwner

 

 11/27/2012 05:24 AM
User is offline View Users Profile Print this message

Author Icon
Reneterning
Peon

Posts: 3
Joined: 11/27/2012

Any news?? Any solutions?? anyone heard from ATI???

 12/02/2012 06:31 PM
User is offline View Users Profile Print this message

Author Icon
xact4
Peon

Posts: 1
Joined: 12/02/2012

XFX DD Radeon HD 7850

ASUS P6T SE motherboard

Intel Core i7 920

1000W power supply

Running the latest beta drivers. Using directx 11 exact same problem. The 7850 is only about a month old, and thus far it will only lock up in LFR randomly. Temp is always low, FPS is always high, it just locks me up regardless.

 

Hoping AMD and WoW can get a fix soon, but looking at how long this has been happening through posts on the WoW forums and here I don't have much hope of that happening.

 12/04/2012 03:20 AM
User is offline View Users Profile Print this message

Author Icon
shadowsky76
Peon

Posts: 13
Joined: 09/14/2012

From latest AMD CATALYST 12.11 BETA11 DRIVER:

"Resolves a sporadic system hang encountered with a single AMD Radeon HD 7000 Series GPU seen on X58 and X79 chipsets."

 Cheers, will test it out later on

 12/04/2012 03:32 AM
User is offline View Users Profile Print this message

Author Icon
Rumraket
Peon

Posts: 19
Joined: 09/03/2012

Originally posted by: shadowsky76 From latest AMD CATALYST 12.11 BETA11 DRIVER:

 

"Resolves a sporadic system hang encountered with a single AMD Radeon HD 7000 Series GPU seen on X58 and X79 chipsets."

 

 Cheers, will test it out later on

 

Yes, spotted that too. Nice to see they acknowledge the issue. 

 12/04/2012 03:36 AM
User is offline View Users Profile Print this message

Author Icon
Rumraket
Peon

Posts: 19
Joined: 09/03/2012

On a related note, I've spend the last 3 weeks googling the issue in various ways to see if I could find someone coming up with a solution of some sort, and I happened to finally stumble in to this thread: 

http://forums.totalwar.com/showthread.php/35440-7xxx-Series-AMD-cards-freezes-and-lock-ups-solution-being-debugged-by-AMD/page117

Quote Originally Posted by Juanlo View Post

Hi guys,

I'm an AMD beta tester. I do not work for AMD, I'm just a gamer with direct contact with them so I can report bugs and problems. So far I have been able to reproduce this "freeze" with lots of games when using Crossfire & Eyefinity: the system just freezes and the only thing you can do is press the reset button. Recently I have also managed to reproduce the problem with just 1 card, but not in single screen resolutions. I have these problems on X58 and X79 chipsets. I also a have a computer with Z77 chipset that runs flawlessly with two cards and triple screen.

Now for the good news: AMD is aware of an incompatibility issue specifically with Intel’s X58/X79 chipsets and they are looking into it, this bug has been given the highest priority, but I would like to get some answers from you (I'm not ready to read over 100 pages of that thread, so maybe someone who has been here since the beginning could help me:

- Is your crash similar to this video? I'm not looking for BSODs or crashes to desktop, but for a complete system halt.
- What is your graphics card? 79xx? 78xx? Any 7xxx card?
- Is your chipset intel X58/X79? If not, what is it?
- Are you using multiple graphic cards? How many? 
- What is the resolution you are using when the computer crashes? Is it a triple screen resolution?
Anyway, currently testing the drivers and they seem to be working well so far in applications where I could normally provoke a system hang. 
My thanks and regards go out to the AMD engineers who seem to have tracked down and fixed the issue!
 12/04/2012 08:24 AM
User is offline View Users Profile Print this message

Author Icon
l3vi4than
Peon

Posts: 6
Joined: 11/13/2012

Will test it today.

Thanks to all involved AMD engineers that might stumble upon this thread, some day.

 12/04/2012 09:27 AM
User is offline View Users Profile Print this message

Author Icon
Marc@AMD
Forum Moderator

Posts: 774
Joined: 07/30/2012

The latest Catalyst 12.11 Beta was released yesterday.  From the updated release notes found here:

http://support.amd.com/us/kbarticles/Pages/AMDCatalyst1211betadriver.aspx

  • Resolves a sporadic system hang encountered with a single AMD Radeon HD 7000 Series GPU seen on X58 and X79 chipsets.


I am hopeful this will resolve your issues in WoW.

;Marc



-------------------------

AMD Customer Care

The information presented in this document is for informational purposes only and may contain technical inaccuracies, omissions and typographical errors. Links to third party sites are for convenience only, and no endorsement is implied.

 12/05/2012 03:30 AM
User is offline View Users Profile Print this message

Author Icon
Reneterning
Peon

Posts: 3
Joined: 11/27/2012

I was testing it in WoW yesterday evening.

 

Specs: Intel Core i7 @ 950 MHz

Board: Asrock X58 Extreme

GPU: Asus HD7850 2 GB

MEM: 12 GB DDR3

 

And the 4 hours I was online, I had no problems/freeze's.

And I will continue testing tonight.

All settings on Ultra with DX11.

I was raiding, and doing dailys, and BG's.

So this looks very good..

 

:Edit: 06-12-2012

Still stable after 2 days, intense WoW playing. Looks like we have a winner..

 

 

Keep up the good work.



Edited: 12/06/2012 at 04:39 AM by Reneterning
 12/05/2012 04:40 AM
User is offline View Users Profile Print this message

Author Icon
l3vi4than
Peon

Posts: 6
Joined: 11/13/2012

So far everything is rock-stable again for me. Thanks AMD. =].

 12/06/2012 06:19 AM
User is offline View Users Profile Print this message

Author Icon
Rumraket
Peon

Posts: 19
Joined: 09/03/2012

Originally posted by: l3vi4than So far everything is rock-stable again for me. Thanks AMD. =].

 

Same here. Thanks again, now I can finally enjoy my 7850 in all my games

 12/10/2012 10:15 AM
User is offline View Users Profile Print this message

Author Icon
dudeman5142
Peon

Posts: 1
Joined: 12/10/2012

Hey All,

I have found this thread very informative and have tried a few things with no luck.

 Is everyone still running rock solid on 12.11 beta? 

I installed beta the day after they came out and still got the crash, however i have freshly installed windows since then and have not tried 12.11 again. Since my fresh install  i have crashed on 12.8 and 12.10

I will attempt 12.11 tonight and if I crash ill try 12.3



-------------------------
Gigabyte AMD Radeon HD 7950 OC
Intel Core i7 920
OCZ Gold 6gb 1600mhz
Corsair 650tx
2x LG Flatron 27in 1080p
Statistics
84120 users are registered to the AMD Support and Game forum.
There are currently 7 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.