Topic Title: Amd display driver stopped responding (Tried every fix and test on the internet)
Topic Summary:
Created On: 09/25/2012 02:22 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 09/25/2012 02:22 PM
User is offline View Users Profile Print this message

Author Icon
wilsons102
n00b

Posts: 2
Joined: 09/25/2012

Symptoms : All games from , Skyrim to kerbal space program from 911 first responders to Dead Space 2 either fail to load and throw up a display driver has stopped responding and has recovered error , or they load up and then throw up the error a few seconds into gameplay.

(Black mesa source is the only game i have that works flawlessly)

 

System Specs are

ASUS Crosshair IV Formula motherboard AM3

AMD1100T X6 3.3ghz stock speeds (ECO A.L.C water cooled)

8GB PNY 1333mhz DDR3 RAM 2 x 4gig sticks

MSI HD6950 AMD Graphics card 2GB 

XFX 80+ True watt 750 watt PSU

256 gb HDD 7200rpm Seagate

64gb SSD OCZ Agility 3

Fixes i have tried so far

Editing the TDR Time in registry

Doing a full driver uninstall and driver sweep and intall latest drivers

Underclocking (Had some positive effects for some games but only temporarilly delayed the errors which came back)

Brand new PSU 80+ 750watt , also tried a friends 1000watt 

Tried Graphics card in another system which can barley run the card... ran flawlessly well at least no errors

Graphics card will pass Furmark, 3d mark 11 and MSI kombuster on current pc no issues. Only when gaming.

Temperatures are way bellow overheating , 28oC on idle and 60oC after running furmark for a while.

Tried a Nvidia Card in my system from my friends PC. No errors ran all games perfect.

Tried a different power outlet in the house.

GPU has latest BIOS 

Motherboard has latest BIOS + Chipset Drivers 

Tried different PCI-EX Slots all have same error

Tried different PCI-EX Power Cables

(Cant RMA Card as was bought brand new from ebay not from a retailer although RMA sounds pointless as runs fine in another pc)

 

Does anyone have any more ideas for me ? Im thinking of just going back to Nvidia Cards as i had this same problem with an AMD 5670 on a different motherboard and processor setup 

 

 

 

 09/25/2012 03:51 PM
User is offline View Users Profile Print this message

Author Icon
fretboard
Member

Posts: 329
Joined: 01/21/2010

Originally posted by: wilsons102

 

(Cant RMA Card as was bought brand new from ebay not from a retailer although RMA sounds pointless as runs fine in another pc)

 

 

Does anyone have any more ideas for me ? Im thinking of just going back to Nvidia Cards as i had this same problem with an AMD 5670 on a different motherboard and processor setup

 

 The games Skyrim, Dead Space 1&2, L4D 1&2, DEUS EX - HR, BIOSHOCK 1 & 2, All Assassin's Creed episodes, ALAN WAKE, Metro 2033 and the STALKER Trilogy all work fine on the HD69xx series of cards .. I know for a fact as I've built, configured, tested and messed around with countless systems using those cards, as it's my job at work to make sure client's PCs are fully working. Same with the HD56xx series of cards, not great for gaming but no issues there either TBH.

If it runs fine in a 2ndary system, then logic dictates that somehow yours isn't suitable, compatible, configured correctly or you're running utilities / 3rd party appz which may cause issues with things .. especially if you have an ASUcKS mainboard and run their garbage ASUcKS utilities.

The age old "who cares" nVidia comment is moot, void and pointless - as nobody here cares at all, really .. You've established that the card works, card works in system 2 but not system 1 .. and that a previous HD56xx card had issues = system 1 at fault - time to troubleshoot it thoroughly.

STICKY thread at top of forum may contain things you missed out in your post ..



-------------------------

AM3 965BE / Corsair H70 / 4Gb Corsair XMS3 2000Mhz / GigaByte 990FXA-UD5 / Corsair Force3 90Gb / x2 HD3870 Atomic Edition / x4 1Tb Storage & Momentus XT 250Gb / Sony AD-7700 DVD-RW / Auzen X-Mystique / Enermax INFINITI 650W / Lian-Li PC-7FNWB / Logitech X-530 / Logitech KBoard & MX620 / Logitech C525 / Epson RX685 / DELL U2312HM

 09/26/2012 08:22 AM
User is offline View Users Profile Print this message

Author Icon
wilsons102
n00b

Posts: 2
Joined: 09/25/2012

Thank you for your help , i removed all of the asus utilities like EPU and Turbo mode and all that garbage .. still no luck all games still crashing with display driver error, I also tried rolling back to various older drivers that didnt help either. Will do some more messing about with the settings and double check the BIOS of the motherboard to make sure its setup right.

Statistics
84277 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.