Topic Title: 7970 issues everywhere...
Topic Summary:
Created On: 11/03/2012 08:06 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 11/03/2012 08:06 PM
User is offline View Users Profile Print this message

Author Icon
Zild1
Peon

Posts: 9
Joined: 11/03/2012

Hi,

I recently bought AMD 7970 card and I think it might just be the worst mistake I ever commited PC wise.

First of all, when gaming, I see black artifacts all over the screen, sometimes more than others, and before someone says its faulty card, it is not, this also happened on my 7850 I had before (on a completely different PC)

Second, I just ran into two games that if ran on Directx11 PC will crash and lock up completely with horrible buzzing coming speakers (WoW and Shogun 2) I bet it wont be the only two games that have this issue.

I´ve been doing some research online and have found a lot of people with this issue and on topics that are over 6 months old, so this has been happening for a long time now with no apparent fix or even care on AMD´s part. Most of them just ended up buying Nvidias.

Is AMD ever planning on fixing this? Also I have not read a single post ANYWHERE from AMD saying were are looking into it or whatever. That just makes AMD look very bad and I´m pretty sure this will be hurting the company a lot, I would not reccomend this card even if I got payed for doing so, always been using Nvidia and I regret every minute I bought 7850 and most of all 7970 cause I just see I wasted my money.

Though I must admit if it werent for these issues it would be a great card, but TBH I´d rather be running my super old GTX9800 and have 30fps or less than having 60fps or greater and artifacts and issues everywhere.

For those that ask, card is at stock, I have not OC´d the card at all, have tried many different drivers, all have artifacts, temps are ok, maxed reached is 69ºC and I repeat this happened on my old 7850 aswell and this is a completely new PC.

Im not even going to post my PC specs because TBH they are irrelevant, the main issue here this card and 7xxx series from what I have read over the span of a few days. I have even read a post where a guy RMA his and got a completely new one and still expreienced same artifacts and issues, seriously AMD, wth?

I will post some vids from the issue THIS IS NOT MY PC (same issues)

http://www.youtube.com/watch?v=yyLAdh0CPls

http://www.youtube.com/watch?v=zG8v1P850ak

http://www.youtube.com/watch?v=47dlS5rclvA

Games I´ve played so far are:

Dishonored: artifacting to a lesser degree.

Shogun 2: artifacting to a lesser degree and PC crashing and locking up with DX11

Company of heroes: artifacting to a lesser degree.

WoW: artifacting a lot more common and DX11 crashing and locking up PC.

Payday the heist: Artifacting to a lesser degree.

 

 

 11/03/2012 09:09 PM
User is online View Users Profile Print this message

Author Icon
black_zion
80 Column Mind

Posts: 12474
Joined: 04/17/2008

Im not even going to post my PC specs because TBH they are irrelevant


Then don't expect a response from us then.

-------------------------
ASUS Sabertooth 990FX/Gen3 R2, FX-8350 w/ Corsair H60, 8 GiB G.SKILL RipjawsX DDR3-2133, XFX HD 7970 Ghz, 512GB Vertex 4, 256GB Vector, 240GB Agility 3, Creative X-Fi Titanium w/ Creative Gigaworks S750, SeaSonic X750, HP ZR2440w, Win 7 Ultimate x64
 11/03/2012 09:23 PM
User is offline View Users Profile Print this message

Author Icon
Zild1
Peon

Posts: 9
Joined: 11/03/2012

It is just not going to make to make any difference wether I post them or not with all these different people having same issues, it is obviously driver or something hardware related with the card.

But anyways, here you go:

CPU: i7 3820 @ 4.7

MB: Asus P9X79

RAM: G.Skill Ripjaws 16GB

SSD: OCZ Agility

PSU: Tacens Radix 850W

O.S: W7 SP1

 11/03/2012 10:33 PM
User is online View Users Profile Print this message

Author Icon
black_zion
80 Column Mind

Posts: 12474
Joined: 04/17/2008

Have you tried not powering it with a chinese firecracker?

-------------------------
ASUS Sabertooth 990FX/Gen3 R2, FX-8350 w/ Corsair H60, 8 GiB G.SKILL RipjawsX DDR3-2133, XFX HD 7970 Ghz, 512GB Vertex 4, 256GB Vector, 240GB Agility 3, Creative X-Fi Titanium w/ Creative Gigaworks S750, SeaSonic X750, HP ZR2440w, Win 7 Ultimate x64
 11/03/2012 11:33 PM
User is offline View Users Profile Print this message

Author Icon
Zild1
Peon

Posts: 9
Joined: 11/03/2012

So just because my PSU isn´t called Corsair or Antec or whatever, it´s a chinese firecracker? You probably have not even had one of these PSU or even better can you even find me a bad review or experience regarding this PSU?

So anyways, to answer your question...

I have another rig with a Corsair 850 and HD 7850 and I have SAME EXACT ARTIFACTS AND CRASHES WITH DX11 which I never experienced them when I had my GTX 9800, all this started when I connected my Hd 7850.

Like I said before this is obviously related with driver or hardware regarding 7xxx series, face it. Keeping this in mind I know i wont be getting any help here, so this is just rage,QQ post whatever you would like to call it and I know I just sent 400 bucks down the drain but god knows for sure I wont ever be buying nothing more from AMD.

Either way I will probably be acquiring a new GTX 680 this week and will be happy to post here that all problems have "magically" dissapeared as I have seen in other threads...

[mod snip] please... just refrain from posting asking me for useless/irrelevant information wasting my time in the process thanks.

 

 

 

 



Edited: 11/04/2012 at 12:50 AM by AMD Support and Game Moderator
 11/04/2012 01:36 AM
User is offline View Users Profile Print this message

Author Icon
Thanny
Alpha Geek

Posts: 1406
Joined: 07/13/2009

There is no general widespread problem with 7970's or their drivers.  When you search for problems, you're only going to find the few people who have them, not the vast majority who don't.

I'm one of the latter. 

Actually, I should say there was a point where I noticed poor stability in games, including lockups just like you describe.  I had recently bumped my i7 950's BCLK from 162 to 166 (3.9GHz to 4.0GHz), and since Prime95 had run for a couple hours without an error, I thought it was stable.  But it wasn't.  After another run of Prime95 showed errors (after a shorter period of time), I dropped the BCLK back down to 162.  That solved all the problems.

Which may in fact be very relevant for your situation, as 4.7GHz with a 3820 is no trivial overclock.  You should do at least half a day of Prime95 or IntelBurnTest before even start suspecting the GPU.  HCI MemTest would be a good idea as well, since that's better than both Prime95 and IBT at catching memory errors.

You didn't provide any details about your other machine, which had problems with a 7850 after no problems with a GTX 9800, but I'd be willing to bet that one also has a high overclock.  Adding a faster GPU can make the CPU do more work, which could make an unstable overclock reveal itself.

Overclocking has become quite common in recent times, but doing it right has not.  Your attitude strongly suggests to me that you're quite likely to be one of the many doing it wrong.

 

 11/04/2012 07:50 AM
User is offline View Users Profile Print this message

Author Icon
Zild1
Peon

Posts: 9
Joined: 11/03/2012

Well... I´m sorry to bring it to you Thanny but my other rig has an i7 950 with no OC.

I´ve ran Prime95 for 6 hours and came out ok, my cpu´s OC is stable and it is not causing these issues.

If so, would you please explain to me why in a more demanding game such as Dishonored ran at full settings in 1920x1080 I experience much less artifacting than in Company of Heroes, a game from 2006 ran at 1600x900?



Edited: 11/04/2012 at 08:18 AM by Zild1
Statistics
85465 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.