Topic Title: Really Choppy Game Performace
Topic Summary:
Created On: 11/09/2012 08:38 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 11/09/2012 08:38 PM
User is offline View Users Profile Print this message

Author Icon
AgentOrange86
Peon

Posts: 2
Joined: 11/07/2012

Hi, I just built a new system with the following specs:

Motherboard: MSI 970A-G46 Bios driver version 1.8

CPU: AMD FX 4100 3.6g x4

RAM: 4GB

PSU: Ultra LSP 750W

OS: Windows 7 64 bit

Ok so I put it all together and installed an ATI Radeon 5570 HD 1GB card with latest drivers and CCC. It worked fine for awhile but then one day my games(all of them) started running extremely choppy. Installed a borrowed HD 6450 and it worked perfectly. I wanted to know if my 5570 was the problem so I installed it in a different PC with similar specs and it worked perfectly in that computer(tested it on all the games I have with same settings). Switched them back and both computers ran choppy. I got the other PC to work fine again with my card but neither would work on my system again. Reinstalled Windows and got same problem. If anyone has an idea of what's going on I would appreciate any feedback, thanks.

 

 



-------------------------
 11/10/2012 12:56 AM
User is offline View Users Profile Print this message

Author Icon
go_for
Nerfed

Posts: 56
Joined: 10/21/2011

Could try uninstalling the latest Catalyst, then load/install an older version of the driver. Also update Win7 with Sp1 and all updates, if not done, before installing the Catalyst.



-------------------------

an Alpha Geek @ AMD Processors Forums | 01/21/2006 | post count 3217

Statistics
84891 users are registered to the AMD Support and Game forum.
There are currently 0 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.