Topic Title: RAGE (PC)
Topic Summary:
Created On: 01/05/2013 06:46 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 01/05/2013 06:46 PM
User is offline View Users Profile Print this message

Author Icon
bigica
Peon

Posts: 6
Joined: 01/05/2013

I bought RAGE for my PC at Steam, but performances are very low and textures problems. I 've tried all tweaks and drivers versions (Catalyst 11.6 but low improvements). This is problem with 5830 series as I've seen in other forums. I have the latest drivers installed v12.10. Will this issue ever be fixed in future drivers releases? There is a YouTube link to see a problem http://www.youtube.com/watch?v=5F6iS19mpCc

My PC config is:

Windows 8 Pro 64-bit (6.2, Build 9200) (9200.win8_gdr.121119-1606)

System Model: P5Q DELUXE

BIOS: BIOS Date: 07/10/09 18:35:53 Ver: 08.00.14

Processor: Intel(R) Core(TM)2 Quad CPU    Q6600  @ 2.40GHz (4 CPUs), ~2.4GHz

 Memory: 8192MB RAM

Available OS Memory: 8192MB RAM

GPU: ASUS EAH ATI 5830 1 GB DDR5

Page File: 3771MB used, 5699MB available

Windows Dir: C:\WINDOWS

DirectX Version: DirectX 11

DX Setup Parameters: Not found

DxDiag Version: 6.02.9200.16384 64bit Unicode

 01/05/2013 07:39 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7852
Joined: 11/13/2009

Voted the worst optimzed game for PC ever. Do yourself a favor and type  rage in the forum search.

Here's the latest help from Rage Support http://forums.bethsoft.com/topic/1236250-rage-support/page__p__18743528



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *AMD R9 290 4gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit 


***** cetera fallunt, ludere mortuus ******



Edited: 01/05/2013 at 10:27 PM by stumped
 01/06/2013 06:16 PM
User is offline View Users Profile Print this message

Author Icon
bigica
Peon

Posts: 6
Joined: 01/05/2013

Unfortunately even these 11.10 preview 2 drivers didn't help. Rage is the worst PC port in computer history, especially for AMD/ATI VGA cards. Id Software shame on you!

 01/06/2013 06:31 PM
User is offline View Users Profile Print this message

Author Icon
Practikill
Grinding Levels

Posts: 172
Joined: 08/07/2009

I would just like to interject, RAGE runs great on my system, with the 12.8 official driver.

 

Windows 7 64bit
Core2 Duo @2.8ghz
AMD HD 6870 1 gig
4gigs DDR2 Ram
X-FI Titanium PCI-e audio



-------------------------

Asus P5Q-SE+ / Core2 Duo E7400 2.8GHZ / 4GB DDR2 / HD6870 1GB / Sound Blaster X-Fi XtremeGamer / Ultra 650watt PSU / Windows 7 X64

 01/06/2013 08:47 PM
User is offline View Users Profile Print this message

Author Icon
UcouldBrong
Case Modder

Posts: 839
Joined: 01/05/2013

Huh...I think it is a great game...runs beautifully on my system...DLC was great, too! You state you've tried "all" tweaks and drivers... have you tried the 12.3 - 12.6 area of drivers? 

 

Be sure to COMPLETELY remove ALL traces of previous drivers as is frequently recommended on these forums.

Almost time for a new cpu, mb and gpu?



-------------------------

 


 


Non-noob components.



Edited: 01/06/2013 at 09:13 PM by UcouldBrong
 01/06/2013 09:47 PM
User is offline View Users Profile Print this message

Author Icon
black_zion
80 Column Mind

Posts: 13078
Joined: 04/17/2008

You'll forgive us if we don't believe you. 2.4ghz CPU is slow, I would suspect that is a big part of your problem.

-------------------------
AMD FX-8350 w/ Corsair H105, ASUS Sabertooth 990FX Gen3/R2, 8GiB G.SKILL DDR3-2133, XFX HD 7970, 512GB Vertex 4, 256GB Vector, 240GB Agility 3, Creative X-Fi Titanium w/ Creative Gigaworks S750, SeaSonic X750, Corsair C70, HP ZR2440w, Win 7 Ultimate x64
 01/07/2013 08:17 AM
User is offline View Users Profile Print this message

Author Icon
bigica
Peon

Posts: 6
Joined: 01/05/2013

No it's not slow. These are recommended Rage system requirements. My PC is even above recommended settings.

OS: Win XP SP3, Vista, Win 7

Processor: Intel Core 2 Quad or Equivalent AMD

Memory: 4GB

Hard Disk Space: 25GB

Video Card: GeForce 9800 GTX, ATI Radeon HD 5550

 01/07/2013 01:52 PM
User is offline View Users Profile Print this message

Author Icon
RobertC
Peon

Posts: 2
Joined: 01/07/2013

My friend and i just got Rage over the steam sale...And the game play good for me but my friend can not play rage he's only getting like 1fps...he's pc is a Amd Quad 3.5 ghz with 8gb 1600mhz ram and a hd 6790 gpu...he's also got 12.10 drivers..my systemAmd fx-8150, 8gp 1600 mhz,  Hd 6950should he just wait for the next driver 13.1 to come out..or just give up on this game. or is there a fix for the open GL for hd 6790 out....thx
 01/07/2013 03:41 PM
User is offline View Users Profile Print this message

Author Icon
UcouldBrong
Case Modder

Posts: 839
Joined: 01/05/2013

Is he getting 1fps on ANY graphic setting?  On ANY driver "properly" installed?

Have you tried an older driver in the 11 series?  A lower 12 series?  Is RAGE the ONLY game he is having issues with?  Has he attempted to overclock the card incrementally?

 

Have you tried putting YOUR video card in his mb to see if anything changes?



-------------------------

 


 


Non-noob components.

 01/07/2013 04:14 PM
User is offline View Users Profile Print this message

Author Icon
RobertC
Peon

Posts: 2
Joined: 01/07/2013

Yeah only on Rage...on low or high..I told him to check an old driver like 11.8...But he don't won't to go back that far just to play one game.. And he lives like 650 miles from me so  he can't use my gpu...he can play games like bf3,ns2,apb, metro2033 all on high settings good...I read that there are a lot pf people with hd6790 gpu haveing the same issue with rage.. Ohwell he paid only $5 for the game..its not a big loss.,,I Just wanted to know it the fixed the openGL with 12.11 beta or if maybe a newer driver was coming out soon ..Maybe there would be a fix.
 01/08/2013 01:53 PM
User is offline View Users Profile Print this message

Author Icon
UcouldBrong
Case Modder

Posts: 839
Joined: 01/05/2013

The 12.11 beta is only for 7000 series cards.



-------------------------

 


 


Non-noob components.

 05/20/2013 11:25 AM
User is offline View Users Profile Print this message

Author Icon
bigica
Peon

Posts: 6
Joined: 01/05/2013

Finally fixed in the latest driver version (13.4). Rage now runs smooth as silk. Thank you AMD.

 11/28/2013 08:17 PM
User is offline View Users Profile Print this message

Author Icon
Pauls1127
Peon

Posts: 1
Joined: 11/27/2013

yup I will agree with you here!

Statistics
88947 users are registered to the AMD Support and Game forum.
There are currently 0 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.