Topic Title: Unbearable jerkiness in Far Cry 3
Topic Summary:
Created On: 02/21/2013 12:52 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 02/21/2013 12:52 PM
User is offline View Users Profile Print this message

Author Icon
aleph99
Peon

Posts: 2
Joined: 02/21/2013

I bought a Radeon HD7750 2GB just to play Far Cry. Previously I was running the game without problems, with medium quality, through my onboard video card. Upon installation of the Radeon, the game would run nicely at 1920x1200 with optimal settings. However, I made the mistake of updating the driver to 13.1. The game became jerky. So I uninstalled the new version and went back to 12.9. It remained jerky, to the point of being unplayable (it appears to freeze every half second or so). This is most noticeable when running.

Among other things:

1. I reset everything in Catalyst to the default.

2. Following someone's recommendation in this forum, I tried RadeonPro. The stuttering remains even with low resolution and low quality, and even with the frame rate over 70 fps.

3. The game is still running fine in my onboard GPU - no stuttering, nice frame rate.

I am not a technical guy. Can someone help me fix this? (Incidentally, I am running Windows 7 64-bit on a Pentium i7 3400 with 8GB RAM).

 

 

 

 02/22/2013 05:35 PM
User is offline View Users Profile Print this message

Author Icon
Thanny
Alpha Geek

Posts: 1494
Joined: 07/13/2009

First, check for a game patch.  I seem to recall reading about a problem like that being solved by a patch for that game.

Second, perhaps try 13.2 Beta, which is supposed to have more consistent frame latencies.

Skyrim is a game that has bad stuttering, which can be solved by either setting the game to a single CPU core (which hurts performance in some locations), or using the preview version of RadeonPro to cap the frame rate.  Something similar might help with FC3.

 

 02/22/2013 10:56 PM
User is offline View Users Profile Print this message

Author Icon
aleph99
Peon

Posts: 2
Joined: 02/21/2013

Thanks, Thanny. I did try version 13.2 beta, but the problem remained. What is really puzzling me is that (a) the game still runs fine with my onboard graphics; and (b) the game was running fine with the Radeon as well until I updated the driver. It seems the new driver messed something up and now I can't get it back the way it was. I also followed someone's advice in this forum and used Windows Installer Cleanup and Driver Fusion to get rid of everything that had been installed by the new driver, to no avail.

So I'm at loss here. Apparently the problem isn't in the game, but in the graphics driver. Fact is, my onboard graphics card right now works better with Far Cry than the Radeon 7750. This is a real disappointment.

 02/24/2013 03:20 PM
User is offline View Users Profile Print this message

Author Icon
MyMedia59
Overclocker

Posts: 682
Joined: 10/30/2009

You do disable the onboard graphics card (in sys bios) when using the 7750?

 

 



-------------------------

GA 990FXA-UD3v4
AMD FX-8320
Kingston 8GB 1866 HyperX Fury
GPU Gigabyte R685OC-1GD
1x SSHD ST1000DX001/ 1x SATA3 WD Blue/ 1x STBV2000300
SeaSonic 650W
Win7x64


 

Statistics
88967 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.