Topic Title: Sapphire Radeon 7870 OC graphical issues and crashes in League of Legends
Topic Summary:
Created On: 08/23/2013 10:48 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 08/23/2013 10:48 AM
User is offline View Users Profile Print this message

Author Icon
loveinthespace
Peon

Posts: 3
Joined: 08/23/2013

Hi there,

I think I am having a driver crash during the game which makes my screen go black and have to restart the PC to make it work again.
I contacted League of Legends technical support and they said there's something up with the 7xxx series card drivers...
I have tried so many drivers, 13.4 and 13.6 and 13.8 (very unstable and buggy)  
Please release a fix or something I am feeling really bad about this issue.
Thank you 

Here's my PC information:

Windows 8 Enterprise 64 bit
Processor: AMD FX 8150 Octa Core Black Edition
Graphics Card: Sapphire 7870 2 GB Overclock edition 

RAM: 8 GB Gskill 1600 mhz DDR3
Hard Drive: 1 TB WD Caviar Black
Motherboard: Gigabyte 990FXA-UD3 version 1.0 (Latest BIOS 10a)



Edited: 08/23/2013 at 10:55 AM by loveinthespace
 08/25/2013 07:12 PM
User is offline View Users Profile Print this message

Author Icon
loveinthespace
Peon

Posts: 3
Joined: 08/23/2013

Could somebody please help me here?!

 09/04/2013 01:11 PM
User is offline View Users Profile Print this message

Author Icon
Ragnador
Peon

Posts: 11
Joined: 09/04/2013

Check Temps while Gaming. And try to remove the manufature overclock with catalyst control.

Check if the problem is still there.

 09/04/2013 09:02 PM
User is offline View Users Profile Print this message

Author Icon
Electronic_Pleasure
Peon

Posts: 22
Joined: 09/04/2013

No idea m8 but just looking at your spec's. Get an SSD you are limiting your self so much with the mechanical drive.



-------------------------
AMD A10 5800K
Biostar Hi-Fi A85S3
x2 4GB Ripjaw 1600's
OCz 240GB Vertex II SSD
X-Fi Titanium HD
AMD 7870 2GB

Acer W500 Windows8 Tablet AMD C50, 2GB, 32GB MicroSSD

AMD Phenom X2 Black Edition
4GB 1333mhz
500GB
Nforce 8200A AM3
 09/05/2013 04:56 AM
User is offline View Users Profile Print this message

Author Icon
Ragnador
Peon

Posts: 11
Joined: 09/04/2013

Originally posted by: Electronic_Pleasure No idea m8 but just looking at your spec's. Get an SSD you are limiting your self so much with the mechanical drive.

His problem is not loading time.

 09/06/2013 05:54 PM
User is offline View Users Profile Print this message

Author Icon
loveinthespace
Peon

Posts: 3
Joined: 08/23/2013

Originally posted by: Ragnador Check Temps while Gaming. And try to remove the manufature overclock with catalyst control.

 

Check if the problem is still there.

 

Hi there, thanks for your reply.
I believe my temp is pretty fine which is near 53C in the game, the card has a pretty decent cooling system. 

I think this is a problem between the driver and the game itself, like some nVidia games do the same with AMD cards... Not "fully optimized" 

@Electronic_Pleasure
Hey bro, I do think this is not about my Caviar Black being old tech or something, it's 7200 rpm and can handle large games pretty well, I have the 256 Pro series SSD from Samsung in my laptop, all it can do is to load the system pretty damn fast, and logging off is, too. The programs run fast, so as browsing in Windows Explorer, opening stuff... etc

I use my desktop for gaming, and yeah my graphics in the desktop is pretty advanced than in my laptop's HD 7600
 
SO I am waiting for the game manufacturers and AMD to release a fix for this issue, I am really annoyed and the game feels unstable here because of that.

 09/06/2013 06:08 PM
User is offline View Users Profile Print this message

Author Icon
WMudrockJr
Overclocker

Posts: 705
Joined: 04/01/2013

Did you fill out a driver problem report, because this is a user forum. Once you report it the problem it will take a little time or beta releases to get resolved if is a driver issue.

Have you done a search on the forum for other people question/issues with the game. 



-------------------------

AMD A10-5800K, XFX 7850 Ultra OC Edition 975MHz, 16GB RAM, Win 8.1 Pro 64 bit, MSI 7778 motherboard, 500W PSU, HP P7-1235, CCC 13.12 WHQL

Statistics
87497 users are registered to the AMD Support and Game forum.
There are currently 7 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.