Topic Title: 2 HD 7970 crossfire problem
Topic Summary:
Created On: 08/26/2013 10:57 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 08/26/2013 10:57 AM
User is offline View Users Profile Print this message

Author Icon
XxXtriplXxX
Peon

Posts: 4
Joined: 08/26/2013

Well As I said I Have same Problems with my 2 HD 7970 actually it's crossfire problem when i enable crossfire i get less fps in BF3  Between 100-59 but when i disable it i get more fps between 170-90 This is weird cause when iplay with 2 cards in must get more performance i dont know why i have the last version of my amd 7970 driver and i have a very good reg :
 CPU: i5 3470 @3.50 Ghz
GPU: ATI 7970 3 GB X2
 MOTHERBOARD: Gigabyte ga-z77x-D3H
DDR: DDR3 1600 16Go
 PSU : CONSAIRE GS 850 Wat

thank you and hope that same body help me with that

 08/26/2013 04:24 PM
User is offline View Users Profile Print this message

Author Icon
XxXtriplXxX
Peon

Posts: 4
Joined: 08/26/2013

Is there any admin here can help us why there is no bady to help

 08/27/2013 02:16 PM
User is offline View Users Profile Print this message

Author Icon
Kent@AMD
Grinding Levels

Posts: 127
Joined: 01/10/2013

Have you tried the 13.8Beta driver, or if you're using 13.4 have you installed the Catalyst Application Profiles? Is this issue present in multiple Catalyst suites, or only in the one that you're using (speaking of which, which Catalyst are you using)?



-------------------------
AMD Customer Care

The information presented in this document is for informational purposes only and may contain technical inaccuracies, omissions and typographical errors. Links to third party sites are for convenience only, and no endorsement is implied.
 08/27/2013 05:27 PM
User is offline View Users Profile Print this message

Author Icon
XxXtriplXxX
Peon

Posts: 4
Joined: 08/26/2013

Yes i have the last version 13.8Beta and have to the the Catalyst Application Profiles the problem that when i using only one cart i get more fps than when i enable crossfire why is there any solution for my problem plz ?

 08/30/2013 06:00 PM
User is offline View Users Profile Print this message

Author Icon
DarkOrochi
Peon

Posts: 5
Joined: 08/30/2013

@ XxXtriplXxX,I think you're drop in FPS with 2 7970s is due to a CPU Bottleneck @ 3.5 GHZ Frequency.  If you brought up the Core Frequency, then you're FPS will probably go up.  How much, I am not entirely certain what the correlation is.  @ 4.6 GHZ, I typically see like 200 to 100 FPS with everything maxed, 4xMSAA + FXAA enabled in-game, and I think MLAA is enabled in my Catalyst 13.8B.  Frame Latency Band ranges from 6ms to 8ms, 10ms at the most.I would suggest getting MSI Afterburner, or RadeonPRO, and enable On Screen Display to monitor your performance.

-------------------------
I7 3930k @ 4.6
AsRock Extreme 11
Asus ROG Ares II
65.5 GBs DDR 3
Statistics
84138 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.