Topic Title: amdcpusetup.exe problem
Topic Summary:
Created On: 10/11/2013 07:24 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 10/11/2013 07:24 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 1
Joined: 10/11/2013

First this is my first post so Hi all.

I've installed "Game of Thrones" via Steam and during the final bit where it installs all of the incidentals before launching it gets to "installing amdcpusetup.exe" and gets stuck (it doesn't freeze it just goes on forever)

BTW I don't have an amd cpu just an amd gpu

Anyway I followed all the troubleshooting steps advised by steam, all successfully except installing said .exe manually, when I try this I get the message "this version of amd cpu driver only applies to winxp"

Since then I've searched everywhere for a windows 8 version I've also tried deleting it but it always says "cannot delete because amdcpusetup.exe is open in amdcpusetup.exe" (it's open in itself lol ) I'm getting very frustrated and steam seem to just churn out set solutions that don't work anyway.

Please help me if you can.

Sapphire 11200-14-20G OC Sapphire Card (2GB, HD7850, GDDR5)

AMD catalyst driver 13.9

Windows 8 OEM

Intel i7 3770K

Asrock Extreme 4 mobo

BIOS: American Megatrends Inc. P1.40 05/14/2012

I appreciate your time and advice


Edit-OK good job I managed to sort this myself given the help I got from this forum.

I went into task manager and with all incidence of amdcpusetup.exe (and there was several) I right clicked and selected "end task".

I then browsed to amdcpusetup.exe and deleted it (made a copy first just in case) my reasoning being that as I didn't have an amd cpu this file was probably not meant to be there anyway and it was perhaps some sort of crossed wires (metaphorically) because of my amd gpu.

Anyhoo, wether the logic was sound or not, it worked.

So I bid this forum goodbye and hope you get more response than I did!






Edited: 10/12/2013 at 08:54 AM by sizzler27
93158 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.